none
How to manage the size of the SFTFS.FSD file when using SoftGrid standalone mode?

    Question

  •  

    I have created a Softgrid install that is 1.5 GB in size and have created an MSI using the MSI utility to deploy via SCCM. My clients are v4.2.2.15 and configured to work in offline mode with a 5GB virtual cache space. I have successfully deployed the software but a new update requires the app to be modified and re-deployed. Since I am using stand alone mode only, I need to make the changes and resend the entire install(1.5GB). In testing, I have noticed that the SFTFS.FSD file increases in size as more packages are added since the MSI fully caches the contents of the installation. This file does not decrease in size, even if previous virtual apps are removed. I am able to regain the space in the 5GB virtual cache space, but the SFTFS.FSD remains the same. Due to the nature of the app, I will have to redeploy at least two more times by next year. This would cause the SFTFS.FSD to grow to 6GB. Is there a way to better manage this file or will it continue to hold archived installations even if they are removed? How can I keep only production apps in this local cache file?
    Friday, September 12, 2008 6:44 PM

Answers

  • Hi,

     

    the behaviour of the Cache file you are seeing is quite normal, but it is only the Size that does not decrease. Inside the cache file, after you have removed a large application, there is space for the new one. (So, using your figures: you deploy 3 versions of your app and some small others, so your cahce fill will grow up to 5 GB on the client. When you clear the oldest two versions out of the cache manually, SFTFS.FSD still is 5GB in size - but 2/3 of it are literally empty (usable by new versions). The App-V cache also has a default parameter that kicks blocks out of the cache if the space is needed for a new application (longest-not-used blocks can be kicked out).

     

    You can decrease the file size of the cache to its 'really needed' size, but during this operation the whole cache gets wiped, so you have to load every appliaction again.

     

     

    Monday, September 15, 2008 5:39 PM

All replies

  • Hi,

     

    the behaviour of the Cache file you are seeing is quite normal, but it is only the Size that does not decrease. Inside the cache file, after you have removed a large application, there is space for the new one. (So, using your figures: you deploy 3 versions of your app and some small others, so your cahce fill will grow up to 5 GB on the client. When you clear the oldest two versions out of the cache manually, SFTFS.FSD still is 5GB in size - but 2/3 of it are literally empty (usable by new versions). The App-V cache also has a default parameter that kicks blocks out of the cache if the space is needed for a new application (longest-not-used blocks can be kicked out).

     

    You can decrease the file size of the cache to its 'really needed' size, but during this operation the whole cache gets wiped, so you have to load every appliaction again.

     

     

    Monday, September 15, 2008 5:39 PM
  • Hello.  Thank you for your response.  Just to clarify, since I have the SG client configured to use up to 5GB of space, the SFTFS.FSD file will never grow passed 5GB.  If it does grow to 5GB, the file will never decrease in size but by removing a previously cached application it will allow old contents to be purged from this file and replaced by new contents. The file will always remain at the 5GB capacity once it is reached. Is that correct? 

     

    If I was to decrease the file size to its 'really needed' size, how would I do that without uninstalling the client? 

     

    Monday, September 15, 2008 6:06 PM
  • Correct.

     

    You cannot not set it to the "really needed" size. Just how big it can get (or how much free space to leave in 4.5).

    You can set *State=0* in the registry and reboot and this will reset the file to its initial size (~700k) and it will grow from there as needed.

     

    Tuesday, September 16, 2008 12:41 PM