none
Visual Studio 2010 Sequncing using APPV 4.5 Sequencer

    Question

  • Hi,

    I tried to sequence visual studio 2010 Professional using Softgrid sequencer 4.5 Sp1 in XPSP3 Machine.

    First i installed .net frame work 4.0 and Windows installer 4.5 and 4.5 Update and started sequencing .

    While installing some components (like Visual studio 2010 , ASP.net MVC 2), I am geting UNKNOWN ERROR.

    I tried sequencing using Windows 7 OS, It completed successfully but i am unable to launch from client machine and giving UNKNOWN Error.

    Can anyone please suggest how to go forward on this...

    Regards,

    Siva.

    Friday, April 23, 2010 6:14 AM

Answers

All replies

  • Have you tried sequencing with version 4.6 of the Sequencer?

    I've not attempted to sequence any of the Visual Studio products, because developers generally have some addins to it as well which can make integration with 3rd pary products and keeping a package up to date a challenge. However it is always worth sequencing with the most recent version.

    Friday, April 23, 2010 8:53 AM
  • Hello Siva,

    Did you check this guide? How to Sequence Visual Studio 2008 in Microsoft Application Virtualization 4.5 (App-V) http://technet.microsoft.com/en-us/appvirtualization/dd334515.aspx

    Applies for VS 2008, but it will give you some guidance about the process.

    Hope it helps,

    Cheers!

     


    augusto alvarez | it manager | http://blog.augustoalvarez.com.ar/
    Friday, April 23, 2010 3:34 PM
  • Hi,

    I already checked this guide. But to follow the same procedure we need to have some hotfixes and dlls, which were not released for Visual Studio 2010 till now.

     

    Tuesday, April 27, 2010 7:10 AM
  • With Visual Studio 2010, you may need to wait as a workable solution to sequence it underway. May be something like the deploy pack for Office 2010.
    TroyW
    Tuesday, April 27, 2010 5:20 PM
  • I tried sequencing using 4.6 version. It went successfully without any errors.

    But while launching from 4.6 client it throws an unknown error. My server version is 4.5SP1.

     

     

     

    Wednesday, April 28, 2010 6:44 AM
  • Hello,

    If you want assistance with this I suggest you post more information, such as what steps you performed during sequencing and exactly where in the process of deployment you consider it to fail - and exactly what that behavior is.

    /Znack
    Saturday, May 01, 2010 9:25 PM
  • I`ve tried sequencing VS 2010 with the 4.6 Sequencer and the package is created without issue, but running VS gives the "Invalid License data. Reinstall is required." error. I suppose we will have to wait until MS releases a patch like the one for VS 2008 to fix the licensing components to work with App-V. I tried MavVak2008.dll from the 2008 sequencing guide and that did not work either.
    Wednesday, June 09, 2010 12:45 PM
  • I have exactly the same :
        1. [Sequencer version 4.6] running on [Windows XP x86 with SP3] => sequencing without error but slow (> 1 hour...)
        2. Log on a client PC [Windows XP x86 with SP3]
            2.1 Look at the Start Menu => [Visual Studio Documentation] shortcut not there ???
            2.2 Click on vs2010 program => splash screen appears in about 4 seconds
                        but then I receive an error dialog : "Invalid License data. Reinstall is required."

    It's very annoying.

    Anyone knows of information/fix/pacth from MS in the air ?

     

    Monday, June 14, 2010 10:06 AM
  • Anyone knows of information/fix/pacth from MS in the air ?

     

    Thursday, June 17, 2010 4:06 PM
  • I too need to sequence this program and have been having issues, hopefully a patch is coming soon?
    Thursday, July 01, 2010 11:34 PM
  • I too need to sequence this program and have been having issues, hopefully a patch is coming soon?

    We have opened a ticket at Microsoft for this issue, they should have more news in July they said. Lets hope this 'more news' will be a patch.
    Monday, July 05, 2010 9:03 AM
  • Hello Microsoft.

    Does a Microsoft Visual Studio 2010 Deployment Kit for App-V will be available soon

         as one exists for The Microsoft Office 2010 Deployment Kit for App-V ???

    Thank you in advance

    Thursday, July 22, 2010 4:47 PM
  • I hope so too
    Wednesday, July 28, 2010 9:05 PM
  • Hello, Microsoft please.

    In 18 days, in our high school here in Belgium, the students begin the next academic year !
    And at this time they will start to work with Visual Studio 2010.
    I would like to install VS 2010 as a virtualized application.

    Do you intend to offer a Microsoft Visual Studio 2010 Deployment Kit for App-V

     soon, please ?

    Thank you.

    Monday, August 16, 2010 5:20 PM
  • Hello,

    To get an official response (or an response from Microsoft) I would suggest to contact your Technical Account Manager or an official Microsoft representative.

    These forums are a community effort.

    /Znack

    Wednesday, August 18, 2010 10:08 PM
  • Hello,

    To get an official response (or an response from Microsoft) I would suggest to contact your Technical Account Manager or an official Microsoft representative.

    These forums are a community effort.

    /Znack


    Eh, nobody at MS appears to know or care about this. We've had NUMEROUS MS assets on site and every one of them turns into a black hole when asked about this issue. They say they will see what is going on, and poof, never another word.

    Pretty sucky Microsoft. One of your flagship products and one of your fairly hard-sold emerging technologies, and we are how many months past the retail date for VS2010 and the SAME problem that impacted 2008 impacts 2010?

    Another case of MS valuing licensing more than their paying customers. Office 2010 and SPP anyone? making MAK keys USELESS by limiting the number of installs they are good for. Forcing everyone to use KMS which expires in 180 days (which is dandy for sales staff and their laptops btw).

    I'm kind of over MS's ____ at this point. And I know saying so here is preaching largely to the choir, but seeing as how the last bit of the domain is microsoft.com I can only hope that SOMEONE at one of the largest tech companies in the world bothers to even skim their own forums.

    Monday, August 30, 2010 2:32 PM
  • hello, See this post; http://blogs.technet.com/b/appv/archive/2010/10/18/sequencing-microsoft-visual-studio-2010-with-app-v.aspx /Znack
    Monday, October 18, 2010 3:14 PM
  • See the recipe now posted here: http://social.technet.microsoft.com/Forums/en-GB/prescriptiveguidance/thread/5eade6a1-44b1-41f9-8af2-0534ef5c8c71

    This forum post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.
    Monday, August 29, 2011 4:28 PM
  • Thank you very much for this foollow up.

     

    Monday, August 29, 2011 10:12 PM