none
System Center 2012 Virtual Machine Manager

    Question

  • I have sequenced the SCVMM Console and so far everything seems to work except for "Connect via Console".

    When I attempt to connect, I receive the following error:

    Your credentials did not work: Your system administrator does not allow the use of default credentials to log on to server. Please enter new credentials.

    This appears to be a delegation issue, so I tried tweaking the delegation policies on the remote server, but it did not help. When sequencing the app, I did not enter any credentials but chose to have them entered at the time SCVMM is run.

    Any thoughts?

    Friday, June 15, 2012 1:32 AM

Answers

All replies

  • Hello,

    When you are saying you tweaked the delegation policies - is this what you mean?

    http://social.technet.microsoft.com/Forums/en/virtualmachinemanager/thread/88168072-281e-4947-96cf-b10b1a760212

    http://support.microsoft.com/kb/954357


    Nicke Källén | The Knack| Twitter: @Znackattack


    • Edited by znackMVP Friday, June 15, 2012 4:33 AM
    • Marked as answer by Tim Boggs Monday, July 09, 2012 5:32 PM
    Friday, June 15, 2012 4:32 AM
  • I followed the directions on both of the links. First I tried manual configuration then I tried theFix It - it said it did not apply to my OS.

    Regardless, I am still unable to connect to the console. From what I'v read, this behavior is similar to having a non-domain joined host.

    What regarding authentication is APP-V virtualizing that prevents proper authentication? The app works fine if it is not virtualized.

    Saturday, June 16, 2012 5:49 PM
  • This link does have the tweak that is needed but I still have questions:

    http://support.microsoft.com/kb/954357

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa\Credssp\PolicyDefaults\AllowDefaultCredentialsDomain

    Name: Hyper-V
    Value type: String Value
    Value data: Microsoft Virtual Console Service/*

    That is the registry change that I required to get the authentication working, and it must be applied to the desktop running the APP-V client. No changes required to the server which some of the articles indicated.

    What puzzles me is that the APP-V package has all of the registry entries described in the KB article. I even modified it to overwrite the key instead of merging. Any ideas of why it wouldn't be using the merged registry?

    • Marked as answer by Tim Boggs Monday, July 09, 2012 5:32 PM
    Saturday, June 16, 2012 8:46 PM
  • Hello,

    Considering that these changes are Operating System specific and seem to to effect services running in the Operating System - applying them in the package might not effect the Operating System you are running the application in.

    Nicke Källén | The Knack| Twitter: @Znackattack

    Sunday, June 17, 2012 8:19 PM
  • I guess that makes sense. The service that requires the registry setting is outside the App-V environment so it can't read the virtualized registry settings.

    Thank you for walking me through it.

    Monday, June 18, 2012 9:58 PM
  • Hi Tim,

    I am attempting to sequence the SCVMM 2008R2 console in App-V and have run into the same issue you describe.

    Can you clarify if you were ever able to get the console viewer working in the virtual app?

    Thanks,
    Paul

    Monday, September 10, 2012 4:24 PM
  • Yes, with this registry change on the client.

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa\Credssp\PolicyDefaults\AllowDefaultCredentialsDomain

    Name: Hyper-V
    Value type: String Value
    Value data: Microsoft Virtual Console Service/*

    I created a group policy to push this registry edit using the same security group I use to deploy the APP-V package. Then it runs fine.

    FYI, I packaged the app in a remote session at a fairly low resolution and the icons and graphics in the resulting package appear to be low resolution. When I install the console locally on a desktop, they look more crisp. I think I should have bumped up the resolution before creating the package. I haven't tested it, but it's the only thing I can figure.

    Monday, September 10, 2012 4:49 PM
  • Tim,

    Thanks very much for the prompt reply. Your suggestion does work. So I'm clear, modifying the App-V package registry setting to overwrite the local registry did NOT work, correct?

    Thanks again,

    Paul

    Monday, September 10, 2012 5:23 PM
  • Correct. The change has to be applied directly to the registry of the client outside of APP-V.
    • Edited by Tim Boggs Monday, September 10, 2012 7:22 PM
    Monday, September 10, 2012 7:21 PM