none
Instalátor Windows 7 spuštěný po síti přes WDS (Windows Deployment System) se zasekne na kroku "Rozbalování souborů systému Windows"

    Dotaz

  • Ahoj. Již nějakou dobu se marně pokouším o centrální instalaci Windows 7 na 30 počítačů pomocí WDS, které je spuštěné na Windows Serveru 2008R2. Bez problému sem nastavil linuxový dhcp server, aby klienty informoval o serveru se spuštěnou WDS službou. Do WDS jsem přidal boot.wim a install.wim z instalačního DVD Windows 7 Professional 64bit. Vytvořil jsem soubory odpovědí pro bezobslužnou instalaci pro architekturu x64. Pokud na klientech nastavím bootování ze sítě, tak se instalace bez problému načte, automaticky se mi vytvoří systémový oddíl a začně se instalovat systém. Jenže ve chvíli, kdy se provádí (respektive začíná provádět - je tam 0%) krok instalace "Rozbalování souborů systému Windows" se počítač naprosto zasekne. Nejde třeba ani vypnout NumLock na klávesnici. Marně jsem se tento problém pokoušel vyřešit tak, že:

    • odebral jsem XML soubory s odpověďmi pro bezobslužnou instalaci,
    • flashnul jsem na klientském PC nový BIOS,
    • resetoval jsem BIOS do default nastavení,
    • zapnul jsem všechno v BIOSU do compatible módu (SATA),
    • odpojil jsem USB zařízení (myš) během instalace (našel jsem v jednom fóru jako radu),
    • přidal jsem do WDS všechny ovladače základní desky klientského PC.

    Velice zvláštní je to, že pouze na jednom PC z těch 30 instalace proběhla vždy v pořádku. Hardware všech PC je ale 100% totožný, takže tohle nechápu. Dokonce i kabely jsou zapojené stejně a pomocí programu hwinfo jsem si ověřil, že je to opravdu totožné). Na těch ostatních lze nainstalovat Windows 7 přímo z DVD také bez problému, ale síťová instalace zasekne PC.

    V čem by mohl být problém? Nelze nějakým způsobem zapnout debugování instalátoru, abych viděl co přesně dělal než se to kouslo? V logu na Windows serveru není nic (jen poslední log klient XY úspěště přes TFTP stáhnul to a to ...).

    25. června 2013 21:48

Odpovědi

  • Tak jsem to vyřešil. Ten jediný funkční počítač měl 1 HW odlišnost - 3 GB paměti, ostatní mají 4 GB. Po odebrání 1GB modulu už instalace funguje. Nechápu ale proč..., když z DVD to šlo normálně.
    26. června 2013 13:23

Všechny reakce

  • Pomocí LIVE CD linuxu jsem se dostal na instalační oddíl, kde ve $WINDOWS.~BT\Sources\Panther\setuperr.log není nic a v setupact.log jsou poslední řádky:

    2013-06-26 12:51:42, Info       [0x0600f3] IBS    CallBack_PickTempDrive_CreateSetupLocalFolder:Successfully created the local sources folder.
    2013-06-26 12:51:42, Info       [0x06050f] IBS    Entering Callback_Rollback_InitializeRollback
    2013-06-26 12:51:42, Info       [0x064147] IBSLIB RollbackInitialize in progress...
    2013-06-26 12:51:42, Info       [0x064148] IBSLIB RollbackInitialize finished.
    2013-06-26 12:51:42, Info       [0x06412c] IBSLIB SetCheckpoint: Checkpoint("StartPhaseCleanUpCheckpoint") in progress...
    2013-06-26 12:51:42, Info                  IBSLIB TrackVolume: Successfully marked that [$Setup_BTFolderVolume$] is on drive [C:].
    2013-06-26 12:51:42, Info                  IBSLIB TrackVolume: Successfully marked that [$Setup_LSFolderVolume$] is on drive [C:].
    2013-06-26 12:51:42, Info       [0x06412e] IBSLIB SetCheckpoint: Checkpoint "StartPhaseCleanUpCheckpoint" successfully set.
    2013-06-26 12:51:42, Info       [0x06412c] IBSLIB SetCheckpoint: Checkpoint("WinPEPrepareInstallDriveCheckpoint") in progress...
    2013-06-26 12:51:42, Info                  IBSLIB TrackVolume: Successfully marked that [$Setup_InstallVolume$] is on drive [C:].
    2013-06-26 12:51:42, Info       [0x06412e] IBSLIB SetCheckpoint: Checkpoint "WinPEPrepareInstallDriveCheckpoint" successfully set.
    2013-06-26 12:51:42, Info       [0x06412c] IBSLIB SetCheckpoint: Checkpoint("StartPhaseSystemVolumeSelectedCheckpoint") in progress...
    2013-06-26 12:51:42, Info                  IBSLIB TrackVolume: Successfully marked that [$Setup_SystemVolume$] is on drive [C:].

    26. června 2013 11:18
  • Tak jsem to vyřešil. Ten jediný funkční počítač měl 1 HW odlišnost - 3 GB paměti, ostatní mají 4 GB. Po odebrání 1GB modulu už instalace funguje. Nechápu ale proč..., když z DVD to šlo normálně.
    26. června 2013 13:23
  • Wow.


    ---------- Ondrej Zilinec - Cievo ----------

    27. června 2013 12:25