none
Windows Update task taking an hour during deployment

    Frage

  • For some reason, when deploying an image that is newly created with all available windows updates, the windows update task is taking over an hour.  Anyone have any ideas on what I can check to see why its taking that long?  I don't want to disable the task because I want the machines to be fully updated each time. It was doing this before the new image, that is why I created the new one to have the updates already done since it was 75 updates.  It didn't help at all.  I am behind a proxy and I have the proxy settings merged into the registry before the windows updates task is ran.  It does multiple restarts during the updates task as well.
    Donnerstag, 14. Juni 2012 17:26

Alle Antworten

  • had the same issue.  i found it was a system time issue.  when i brought in new dells from the factory, their system clock was two hour ahead.  this time difference seemed to stall the windows update process.  since i have been adjusting the system time before deploy i have not experienced the problem.  i thought about putting a script in the TS to adjust the time before the WU, but never got around to it.
    Donnerstag, 14. Juni 2012 18:01
  • As a suggestion you could use "cmd /c net time \\{server} /SET /Y" as a command line to sync the time before running WSUS. No need for a fancy script. This will just set the time to a known good source that you specify.

    As for the main issue here, its as simple as your base image that you're pushing out is likely not patched up to date as you believe it is. I would suggest running the create process again and checking your ZTIWindowsUpdate.log before capturing to see if you have any issues that need resolved.

    Donnerstag, 14. Juni 2012 18:09
  • Thanks, I'll try the time command to see what happens.  The updates are there in the image.  I am getting an error at the end of deployment saying "
    FAILURE (9902): ZTIWindowsUpdate has run and failed too many times. Count =8
    Donnerstag, 14. Juni 2012 18:31
  • You say you are behind a proxy...does this proxy need you to authenticate before you can see the outside world? If the TS has you're logged on as a local admin then you may not be able to see the internet without manual intervention to authenticate.

    Are you using Windows Update as opposed to WSUS?

    Donnerstag, 14. Juni 2012 18:46
  • No, no auth required before accessing externally.  I'm using both windows update and wsus as our machines have to be fully patched before setting up for a user so I want windows update to run asap.  maybe I'm missing how this is supposed to work?
    Donnerstag, 14. Juni 2012 18:55
  • Whats in your CustomSettings.ini file in regards to WSUS? Can you post your ZTIWindowsUpdate.log?
    Donnerstag, 14. Juni 2012 18:59
  • WSUSServer=http://MyWsusServerName
    looking for the ztiwindowsupdate.log file.
    Donnerstag, 14. Juni 2012 19:11