none
one or more prerequisites fir protecting this data source is missing

    Frage

  • hi, i have successfully attached an agent to my dpm server but when i try to select the disks to backup it pops up with the follwing error

    One or more prerequisites for protecting this data source is missing.
    Ensure that the following prerequisite software is installed on server and/or all nodes in the cluster:

    Windows Server 2003 SP1 with Knowledge Base article 940349 (http://go.microsoft.com/fwlink/?LinkId=99034)
            - OR –
    Windows Server 2008 (http://go.microsoft.com/fwlink/?LinkId=128812)

    If you have already installed the required prerequisite, refresh the agent status in the management tab and try again.

    i have also installed the updates as reqted by the link in the error and it still does not work.

    ID: 31309

     

     

    I am using dpm 2010 on 2008.  The target server is w2k3 sp2, sql2005 sp3.  I have tried refreshing the connection to the agent and this does not resolve this issue either.

    Thanks

     


    phill
    Dienstag, 3. August 2010 05:37

Alle Antworten

  • You did install the KB940349 hotfix on the 2003 server, correct?
    Dienstag, 3. August 2010 05:46
  • I'm having the same issue. Installed KB940349 on both nodes of the CCR cluster, restarted them, refreshed the agents, and still no go. Both of the Exchange Cluster Nodes are running Server 2003 R2 SP2, and the DPM server is running DPM 2010 RTM on Server 2008 R2. 

     

    This cluster was previously protected by DPM 2010 RC and DPM 2007 SP1. I've verified that all of the files from the KB match the versions running on the servers. 


    Somthing
    Mittwoch, 18. August 2010 13:20
  • Updated to the latest Exchange update, still a no-go.


    Somthing
    Freitag, 27. August 2010 18:07
  •  

    Any update ?

    I am facing same issue.


    Venkat
    • Als Antwort vorgeschlagen Basel21 Donnerstag, 21. Juni 2012 10:17
    Freitag, 25. Februar 2011 12:51
  • even I am facing the same issue I uninstall the agent and install it again after restart both server but still same any one have any Idea .......??????

    Danish Khan DK

    Sonntag, 10. Juni 2012 12:29
  • Software update 940349 must be installed on the Data Protection Manager server and on each protected computer that is running Windows Server 2003 Service Pack 1 (SP1) or a later version of Windows Server 2003.

    i install it and it work fine after.

    Donnerstag, 21. Juni 2012 10:03
  • Khan,

    DPM uses WMI to query hotfixes on the protected server - if WMI is not working or if the required QFE is not listed in the output of the WMI query, then that is why you are seeing the popup.

    Try one of these commands from an administrative command prompt:

    Run from ADMINISTRATIVE COMMAND PROMPT on the Protected Server:   wmic qfe list >c:\temp\qfe.txt
    -or-
    RUN FROM Windows 2008 POWER SHELL on DPM Server.

    Find specific QFE on the protected server:

    get-hotfix -computer ps_name | ? {$_.HotfixID -match "KB975354"}


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.

    Sonntag, 24. Juni 2012 19:15
    Moderator