none
Remote-Verbindung zum Server 2005 nur mit der Port-Eingabe möglich

    Frage

  • Hallo Forum,
    allg. Angaben:
    OS: 2008 64 bit R2
    SQL: 2005 EE 64-bit
    ich habe die Aliases für den Server eingetragen (incl. Portnummer), die dynamischen Portsnummer habe ich entfernt. Seitdem kann ich den SQL-Server remote (anderer Rechner, Server Management Studio) nur mit der Angabe vom Port erreichen, z. B. ServerName.domain.de\INSTANZ,6201. Ohne die Portangabe bekomme ich die Fehlermeldung:

    Alles 100-mal überprüft:
    remote connections sind zugelassen, Firewall deaktiviert, Account f. SQL-Browser überprüft, TCP, NamedPipes (wenn die Protokolle falsch/deaktivert wäre, würde ich keine Verbindung mit der Portangabe hinbekommen..),, etc., alles scheint in Ordnung zu sein.
    Ich habe mehrere solcher Server bereits mit Aliases installiert, keine Probleme - bis jetzt.
    Was kann ich noch überprüfen?
    Danke für Eure Hilfe
    P.


    • Bearbeitet Purclot Montag, 9. Januar 2012 15:51
    Montag, 9. Januar 2012 15:47

Alle Antworten

  • Hi,

    dann läuft deine Instanz unter dem Port 6201. Da das kein Standardport ist, musst Du den angeben. Falls das nicht gewünscht ist, stell über den SQL Server Konfigurationsmanager den Port für diese IP/alle IPs auf 1433, dann sollte es auch ohne Portangabe funktionieren.

    Geh dazu beim Protokoll TCP/IP auf den Reiter IP-Adressen, scoll ganz runter und schau mal, was bei "IPAll" -> "TCP-Port" steht. Falls Du den Port 6201 zusätzlich brauchst, kannst Du dort auch mehrere Portnummer, getrennt mit Komma angeben. Also bspw. so:

      1433,6201,12345

     


    Gruß, Stefan
    Microsoft MVP - Visual Developer ASP/ASP.NET
    http://www.asp-solutions.de/ - Consulting, Development
    http://www.aspnetzone.de/ - ASP.NET Zone, die ASP.NET Community
    Dienstag, 10. Januar 2012 11:16
  • Hallo Stefan,
    danke. Die Portnr-6201 ist selbstverständlich meine Absicht (Security-Maßnahme). Die dynamischen Ports wurden entfernt.
    Ich habe bereits mehrere Server so installiert (inkl. Alias, siehe Bild). Auf jedem anderem Server läuft das unproblematisch. Mein Ziel ist es, den Server von einem anderem Server mit SQL Management Console sowohl mit der Portangabe, als auch ohne anzusprechen, z. B. Server.domain.de\BBBB, oder Server.domain.de\BBBB, 6201.
    Jetzt funktioniert das nur mit der Portangabe. Wenn ich zusätzlich zu 6201 den Standartport 1433 bei den Aliases und TCP-Konfiguration eintrage, ändert sich nichts. Der Server reagiert dann auf Port 6201 oder 1433, ohne Portangabe bekomme ich den o. g. Fehler. Ich habe auch die Registry-Einträge zw. einem funktionierenden Server und dem "Problemkind" verglichen-sehen genauso aus.
    Ist vielleicht das TCP-Protokoll kaputt gegangen?


    Gruß P.

    Dienstag, 10. Januar 2012 12:11
  • Hallo Purclot !
    Läuft denn der Browser-Dienst?
    http://msdn.microsoft.com/de-de/library/ms181087.aspx

    Einen schönen Tag noch,
    Christoph
    --
    Microsoft SQL Server MVP
    www.insidesql.org/blogs/cmu

    Dienstag, 10. Januar 2012 13:02
  • Hallo Christoph,

    ja, er läuft.

    Gruß P.

    Dienstag, 10. Januar 2012 13:40