none
Internet Explorer 9 lässt sich nicht öffnen

    Frage

  • Hallo,
    über Windows Update kam letzte Woche der Internet Explorer 9 auf mein System. Seid dem funktioniert dieser nicht mehr.
    Es öffnen sich kurz die Umrisse eines Fenster und verschwinden dann sofort wieder. Im Taskmanager verschwindet die iexplore.exe nach 2 Sekunden sofort wieder.

    WENN ich jedoch explizit die Internet Explorer (64-bit) Anwendung starte öffnet sich der Explorer und bleibt auch offen. Leider funktionieren bisher noch nicht alle
    Anwendungen mit einem 64-bit Browser.

    Who can help?

    Grüße
    Andre 

    PS: Achja, deinstalliert und wieder installiert habe ich den IE9 schon. Und rebootet habe ich auch schon mehrmals ;-) 

    Montag, 27. Juni 2011 11:50

Alle Antworten

  • Hi Andre,

    über Windows Update kam letzte Woche der Internet Explorer 9 auf mein System. Seid dem funktioniert dieser nicht mehr.
    Es öffnen sich kurz die Umrisse eines Fenster und verschwinden dann sofort wieder. Im Taskmanager verschwindet die iexplore.exe nach 2 Sekunden sofort wieder.

    Gibt es im EventLog Hinweise auf einen Fehler?

    WENN ich jedoch explizit die Internet Explorer (64-bit) Anwendung starte öffnet sich der Explorer und bleibt auch offen. Leider funktionieren bisher noch nicht alle Anwendungen mit einem 64-bit Browser.

    Hast du denn die 64Bit-Version installiert und welches BS hast du?


    Viele Grüße
    Christian

    Montag, 27. Juni 2011 14:42
  • Hall Christian,

    sorry meine Spezifikationen hatte ich total vergessen.

    Windows 7 Prof. SP1 64Bit

    Das Eventlog ist sauber. Oder gibt es eine besondere Stelle, an der ich für den IE9 nachsehen muss?

    Grüße 


    • Bearbeitet AndreSchueltke Montag, 27. Juni 2011 17:07 Eventloghinweis vergessen
    Montag, 27. Juni 2011 16:49
  • Untersuche mal mit Autoruns von Sysinternals welche Browser-Erweiterungen du alle instlaliert hast. Versuche auch in der Systemsteuerung unter Internetoptionen -> Erweitert "Internet-Explorer Einstellungen zurücksetzen". Auch überprüfe mit "sfc /scannow" ob alle Systemdateien original sind. Da sich bei dir IE9 64bit öffnen läßt scheint das Problem mit der 32bit Version speziell zu sein was auf ein Fehlerhaftes Plugin z.B. deuten kann welches der IE9 32bit versucht zu laden. Auch Process Monitor von Sysinternals kann dir weiterhelfen indem du einen Procmon-Trace aufzeichnest und dann nach iexplore.exe filterst. Untersuche welche Dateien und Einstellungen der IE9 wirklich versucht zu laden und was das letzte ist bevor er sich wieder verabschiedet.

    http://www.sysinternals.com

    Montag, 27. Juni 2011 18:59
  • Hallo,

    ich beantworte mal kurz im Telegrammstil:

    1) sfc hat nichts gefunden

    2) autoruns: hier ein bild der aktivierten plugins. Ein deaktivieren aller Pflugins brachter leider nichts.
    Das zurücksetzen des IE9 brachte leider auch keine Veränderung

    3) Der ProcessMonitor hat mich regelrecht erschlagen. Da blicke ich nicht durch.
    Hier ein Link zu meinem PML-File natürlich nach iexplore.exe gefiltert 

    Beste Grüße
    Andre 

    Dienstag, 28. Juni 2011 08:23
  • Den ProcMon Trace solltest du nicht Public stellen. Auch mit dem angewandten Filter ist es eventuell möglich Dinge daraus auszulesen mit denen man gar nicht rechnet.

    Leider kann ich auch keinen direkten Fehler im ProcMon Trace erkennen. Ein paar Ideen habe ich aber:

    • Versuche mal im Startmenü "Internet Explorer (ohne Add-Ons)" zu starten. Mit diesem Link startet der 32Bit IE ohne jegliche externe Add-Ons zu starten.
    • Schalte in den Internetoptionen -> Erweitert das Software Rendering ein. Vielleicht gibt es ein Problem mit deinem Grafiktreiber. Aktiviere dort den Punkt "Software Rendering anstelle von GPU-Rerndering verwenden". Versuche dann nochmals den IE zu starten.
    • Mir ist aufgefallen dass sich dein Internet Explorer unter C:\Anwendungen anstatt C:\Program Files (x86) befindet. Eventuell gab es da ein Problem bei der Installation da du diesen alternativen Pfad verwendest.
    • Versuche IE9 erneut zu installieren. Dazu öffnest du "Windows Funktionen hinzufügen/entfernen" und entfernst den Haken bei "Internet Explorer". Die darauf folgende Warnung bestätigst du und startest danach dein System neu. Nun führe denselben Vorgang nochmals aus und aktiviere den Haken für Internet Explorer wieder. Nach der Änderung startest du wieder neu. Versuche nun ob sich das Problem gelöst hat.

    Mehr Ideen habe ich im Moment leider nicht. Eine Malware auf deinem System die stört könnte noch sein, aber mir wäre nichts dergleichen im ProcMon-Trace aufgefallen. Dies heisst nicht dass nicht trotzdem eine Malware (oder auch eine seltsame Antivirus/Firewall-Software) schuld sein kann, aber ich halte dies für eher unwahrscheinlich. Sollte mir noch etwas einfallen melde ich mich natürlich.

    Dienstag, 28. Juni 2011 17:41
    • Versuche mal im Startmenü "Internet Explorer (ohne Add-Ons)" zu starten. Mit diesem Link startet der 32Bit IE ohne jegliche externe Add-Ons zu starten. 
      Der gleiche Effekt wie bei der normalen 32bit Anwendung. Fensterumrisse sind kurz zusehen und dann ist wieder alles weg.
    • Schalte in den Internetoptionen -> Erweitert das Software Rendering ein. Vielleicht gibt es ein Problem mit deinem Grafiktreiber. Aktiviere dort den Punkt "Software Rendering anstelle von GPU-Rerndering verwenden". Versuche dann nochmals den IE zu starten.
      Leider keinen Erfolg
    • Mir ist aufgefallen dass sich dein Internet Explorer unter C:\Anwendungen anstatt C:\Program Files (x86) befindet. Eventuell gab es da ein Problem bei der Installation da du diesen alternativen Pfad verwendest.
      C:\Anwendungen ist mein std. Installationspfad, den ich so auch in der Registry gesetzt habe. Viele unserer Programme hier in der Firma kommen mit der Verzeichnisberechtigung in den "Program Files (x86)" und "Program Files" Ordnern nicht zu Recht, deswegen ändern wir das hier bei jedem Rechner ab. Bisher hatten wir auch nie Probleme.
    • Versuche IE9 erneut zu installieren. Dazu öffnest du "Windows Funktionen hinzufügen/entfernen" und entfernst den Haken bei "Internet Explorer". Die darauf folgende Warnung bestätigst du und startest danach dein System neu. Nun führe denselben Vorgang nochmals aus und aktiviere den Haken für Internet Explorer wieder. Nach der Änderung startest du wieder neu. Versuche nun ob sich das Problem gelöst hat.
      Leider keinen Erfolg. Der Effekt war das gleiche.
      Malware kann ich EIGENTLICH ausschliessen. Das System ist relativ frisch und hat mit AntiVir und allen Windowsupdates noch vor dem ersten Netzwerkkabel eigentlich alles was es braucht bekommen.

      Beste Grüße 
      Andre 
    Mittwoch, 29. Juni 2011 06:48
  • >       C:\Anwendungen ist mein std. Installationspfad, den ich so auch in
    >       der Registry gesetzt habe. Viele unserer Programme hier in der
     
    Hm - den IE9 gibt es 32- und 64-bit. Wie hast Du das mit Deinem
    "Standardpfad" gelöst? Anders gefragt: Wohin zeigt Dein %programfiles%
    und wohin zeigt %programfiles(x86)%? Wenn das das GLEICHE Verzeichnis
    ist, sind Probleme vorprogrammiert.
     
    mfg Martin
     

    Kein MVP, kein MCSE. Nur ein wenig Erfahrung.
    Mittwoch, 29. Juni 2011 07:37
  • Hallo Martin,

    da hab ich mich etwas unglücklich ausgedrückt. Wir "lotsen" nur den x86 Pfad um.
    %programfiles(x86)% = C:\Anwendungen
    %programfiles% = C:\program files

    Grüße
    Andre 

    Mittwoch, 29. Juni 2011 07:40