none
Outlook Verbindung zu Dynamics CRM Server schlägt fehl

    Frage

  • Hallo liebe Gemeinde,

    habe hier schon viel gestöbert unde gelesen. Auch wenn ich viel über Outlook Probleme gefunden habe, gab es leider keine richtige Lösung für mich.
    Hier mal die Facts:

    eine virtuelle Maschine
    SBS 2011 Standard 64bit
    Exchange 2010
    Sharepoint 2010
    MS SQL Server 2008
    MS Dynamics CRM 2011

    Als erstes muss ich sagen, dass Dynamics CRM für mich Neuland ist.
    Die Installation lief so gut wie ohne Probleme. als Website hab ich "neue Website" angegeben und einen Port 8064 über http. Es wurde alles schön eingerichtet. Auch im IIS ist die Seite erreichbar. Ich kann die Seite über http auch erreichen, egal ob ich der Bindung einen Namen hinzufüge oder einfach nur auf den Port gehe. Per IE geht alles.

    Nur suche ich jetzt schon seit einer Woche nach einer Lösung, den DCRM Outlook Client zum laufen zu bringen. Leider sagt mir dieser: " Problem bei der Kommunikation mit dem MS Dynamics Server. Der Server ist möglicherweise nicht verfügbar. Versuchen Sie es später erneut . Falls das Problem weiterhin besteht, wenden Sie sich an den Systemadministrator".
    Der Outlook Client läd mir nicht mal die Organisationen. Die Firewall ist aus. Im Webinterface habe ich den Account auf Outlook gestellt. Der Client hängt im selben Netz ( habe es auch schon mit einem VPN und einem anderen Client versucht ). Auf dem Server selbst funktioniert der Email Client auch nicht.

    Wireshark liefert mir zudem immer ein Problem wie z.B. HeaderChecksum: 0x0000 [incorrect, IP checksum offload?]

    Welche Einstellung habe ich übersehen?
    Gibt es spezielle Rechte für Outlook?
    Welche Einstellungen müssen für die Kommunikation von Outlook und Dynamics CRM getroffen werden?
    Wo finde ich die Ereignisse bei den Anmeldungen mit Outlook?


    Danke schonmal für eure Hilfe.

    Beste Grüße aus München,
    Pain

    • Bearbeitet Pain31 Montag, 13. Februar 2012 16:06
    Montag, 13. Februar 2012 15:31

Alle Antworten

  • Hallo Pain,

    damit der Outlook Client funktioniert, müssen folgende Bedingungen erfüllt sein.

    - Auf dem Server muss in der Firewall das CRM für den Port 8064 freigegeben werden, testweise würde ich einmal die Firewall auf dem Server ausschalten.

    - Der Benutzer, mit dem du den Outlook Client konfigurierst, muss im CRM als Benutzer angelegt worden sein. Dieser Benutzer benötigt eine Rolle aus dem CRM.

    - Der Name des CRM Servers muss von der Clientmaschiene aufgelöst werden können

    - Der Benutzer muss in derselben Domäne sein wie der CRM Server.

    Meine vermutung ist, das du die Firewall auf dem Client aber nicht auf dem Server ausgeschaltet hast.


    Viele Grüße

    Michael Sulz
    MVP für Microsoft Dynamics CRM
    Blog
    Website


    Montag, 13. Februar 2012 15:55
  • beide Firewalls sind aus. Ansonsten hängt auch keine Firewall mehr zwischen den VM´s. Bezüglich der Rolle für den Nutzer: Ist damit z.B die Adminrolle gemeint?

    Alle anderen Punkte habe ich kontrolliert und die sind in Ordnung....

    Montag, 13. Februar 2012 16:48
  • Das kann auch die Admin-Rolle sein, muss es aber nicht, jede andere Rolle im CRM funktioniert auch.

    Gerade Anfänger machen oft den Fehler, nur den Benutzer im CRM anzulegen, ihm dann aber keine Rolle zuzuweisen. Ohne zugewiesene Rolle kann er sich aber nicht anmelden.


    Viele Grüße

    Michael Sulz
    MVP für Microsoft Dynamics CRM
    Blog
    Website

    Dienstag, 14. Februar 2012 07:16
  • Also, der Benutzer hat Rollen zugewiesen, unter anderem auch die Admin Rolle. Über http klappt das ja auch alles wunderbar. Nur der Outlook Client lässt sich nicht mit dem Server verbinden. Nicht einmal auf dem Server selbst. Was kann ich noch tun damit ich das endlich zum laufen bekomme?
    Dienstag, 14. Februar 2012 07:43
  • Stimmt die Uhrzeit und das Länderschema zwischen Client und Server überein? Der OClient hängt stört sich gern mal an einer nicht synchronen Uhrzeit zwischen Client und Server, wenn diese in der gleichen Zeitzone sind. Prüfe auch die Zeitzone im WebClient, ob er hier schon die korrekte Zeitzone für den Client "gezogen" hat.

    Carsten Groth http://carstengroth.wordpress.com Microsoft Certified Technology Specialist

    Dienstag, 14. Februar 2012 10:45
  • ja, die Zeiten stimmen überein. Ich denke, es liegt an dem SBS 2011. Dort sind ja im Endeffekt zwei MS SQL Datenbanken am laufen. Einmal die vorinstallierte Express Version für Exchange und einmal der SQL Server 2008. Dort glaube ich, liegt das Problem.

    Ich installiere das ganze jetzt mal auf einen Server 2008 R2 Std. Als erstes Exchange 2010 drau, dieser bringt ja die sql Server 2005 mit. Kann ich diese Datenbank für Dynamics benutzen bzw. einbinden?

    Dienstag, 14. Februar 2012 13:17
  • CRM 2011 benötigt den SQL Serve 2008!

    Und wenn ich richtig informiert bin, dasf die mit dem Exchange Server mitgelieferte SQL-Version auch nur mit Exchange verwendet werden und nicht für andere Produkte.


    Viele Grüße

    Michael Sulz
    MVP für Microsoft Dynamics CRM
    Blog
    Website


    Dienstag, 14. Februar 2012 17:14
  • Also bis jetzt ist die Installation von SQL Server 2008 R2, Exchange 2010 und MS Dynamics CRM ohne Fehler verlaufen, Warnungen für die Dienstkonten wurden auch eingehalten und behoben. Das alles ist nun auf einem 2008 R2 Std. Morgen richte ich noch ein Exchange Konto ein. Mal schauen ob das dann klappt. Ich halte euch auf auf dem Laufenden!

    Lg,

    Pain

    Dienstag, 14. Februar 2012 17:33
  • Die Einrichtung auf dem R2 hat geklappt. Das CRM ist jetzt mit Outlook zu erreichen. Leider NUR vom Server aus. Wenn ich einen neuen Nutzer anlege, wie oben geschildert, liest das CRM den Servernamen und den Port ein, findet auch die Organisation, kann sich aber nicht verbinden....

    Wo liegt der Fehler?

    Gibt es noch bestimmte Gruppen und Rechte der Active Directory User bzw. der CRM User?

    Soweit ich weiss, müssen die User in der PrivUserGroup drin sein. Wo noch?

    • Bearbeitet Pain31 Mittwoch, 15. Februar 2012 17:49
    Mittwoch, 15. Februar 2012 10:38
  • Hallo,

    wenn du die Benutzer über die GUI des CRM hinzufügst, werden alle erforderlichen Rechte im AD automatisch gesetzt.

    Hast du dem Benutzer eine Rolle zugewiesen? Ist zum Test auf dem Client und dem Server die FW aus?

    Befindet sich die Website des CRM in den Vertrauenswürdigen Seiten des IE?

    Haben Server und Client die gleiche Zeitzone?

    Wenn diese Voraussetzungen alle erfüllt sind, sollte eine Verbindung zwischen CRM und dem Outlook Client möglich sein.


    Viele Grüße

    Michael Sulz
    MVP für Microsoft Dynamics CRM
    Blog
    Website

    Donnerstag, 16. Februar 2012 07:37
  • Hallo Pain31!

    Was hast du auf dem Client im Konfigurationsassistent bei Server-Url eingetragen? Hier kommt normalerweise nur http://<servername> rein.
    Funktioniert der Connection-Test?
    Kannst von diesen Client-Rechner das CRM über den IE erreichen?


    Ich hoffe das bringt weiter. Andreas(a)Donaubauer.com www.crmfaq.de

    Montag, 20. Februar 2012 14:04
  • So, es funktioniert jetzt auf dem normalen Windows Server soweit alles. Verbindung klappt vom Client aus per Browser und Outlook.

    Nun habe ich das Problem, dass ich ständig nach Benutzer und Passwort gefragt werde, egal ob Browser oder Outlook. Ich muss die Daten schon viermal eingeben um auf die Oberfläche zu kommen. Sobald ich dann einen neuen Reiter anklicke, dasselbe wieder von vorne.

    Was kann das denn noch sein? IIS Problem? Windows Authentifizierung ist aktiviert. Benutzer ist Domänenmitglied. Was nun?

    Donnerstag, 23. Februar 2012 13:57
  • Hi Pain,

    Kontrolle die Authentifizierung in den IE-Einstellungen für die Zone, in der deine CRM-Url liegt (Extras - Internetoptionen - Sicherheit - Stufe anpassen - Benutzerauthentifizierung (fast mittig) ). Hier sollte eines der "Automatisch anmelden..." aktiviert sein!

    Liebe Grüße,

    Andreas


    Andreas Buchinger
    Microsoft Dynamics Certified Technology Specialist
    MCPD: SharePoint Developer 2010

    Donnerstag, 23. Februar 2012 14:45
  • Hallo,

    ansonsten könnte auch noch folgender Artikel weiterhelfen:

    http://support.microsoft.com/kb/2593042


    Viele Grüße

    Michael Sulz
    MVP für Microsoft Dynamics CRM
    Blog
    Website

    Dienstag, 28. Februar 2012 12:14