none
CopyProfile in unattend xml

    Frage

  • Hallo zusammen,

    ich habe ein Windows7 Rechner installiert und nach meinem Einstellungen konfiguriert. Allerdings nicht im Auditmode.

    Wenn ich jetzt sysprep ausführe ohne Copyprofile funktioniert das ganze einwandfrei jedoch ohne einige Einstellungen die ich jedoch gerne behalten würde.

    Führe ich jetzt sysprep sysprep.exe /oobe /generalize /quit /quiet /unattend:d:\unattend.xml

    ?xml version="1.0" encoding="utf-8"?>
    <unattend xmlns="urn:schemas-microsoft-com:unattend">
        <settings pass="generalize">
            <component name="Microsoft-Windows-PnpSysprep" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <DoNotCleanUpNonPresentDevices>true</DoNotCleanUpNonPresentDevices>
                <PersistAllDeviceInstalls>true</PersistAllDeviceInstalls>
            </component>
        </settings>
        <settings pass="specialize">
            <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <CopyProfile>true</CopyProfile>
                <RegisteredOrganization />
                <RegisteredOwner />
            </component>
        </settings>
     </unattend>

    sysprep läuft durch und mit copyprofile können nach einem reboot neue Benutzer hinzugefügt werden die das richtige profil haben.

    jetzt wollte ich die user automatisch erstellen lassen und habe das ganze erweitert mit der oobe die ich erstellt habe.

    ?xml version="1.0" encoding="utf-8"?>
    <unattend xmlns="urn:schemas-microsoft-com:unattend">
        <settings pass="specialize">
            <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <OEMInformation>
                    <Logo />
                    <Manufacturer>test</Manufacturer>
                    <SupportHours>Mo - Do 8:00 - 17:00   Fr 8:00 - 15:00</SupportHours>
                    <SupportPhone>+49(0)</SupportPhone>
                    <SupportURL>http://www.test.com</SupportURL>
                    <HelpCustomized>false</HelpCustomized>
                </OEMInformation>
                <WindowsFeatures>
                    <ShowMediaCenter>false</ShowMediaCenter>
                    <ShowWindowsMail>false</ShowWindowsMail>
                    <ShowWindowsMediaPlayer>false</ShowWindowsMediaPlayer>
                    <ShowInternetExplorer>true</ShowInternetExplorer>
                </WindowsFeatures>
                <CopyProfile>true</CopyProfile>
                <ComputerName>*</ComputerName>
                <ShowWindowsLive>false</ShowWindowsLive>
                <TimeZone>W. Europe Standard Time</TimeZone>
                <RegisteredOwner>test</RegisteredOwner>
                <DoNotCleanTaskBar>true</DoNotCleanTaskBar>
            </component>
            <component name="Microsoft-Windows-Deployment" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <RunSynchronous>
                    <RunSynchronousCommand wcm:action="add">
                        <Credentials>
                            <Password>*test*</Password>
                            <Username>Administrator</Username>
                        </Credentials>
                        <Description>Administrator</Description>
                        <Order>1</Order>
                        <Path>net user Administrator /active:yes /passwordchg:no /expires:never</Path>
                    </RunSynchronousCommand>
                </RunSynchronous>
            </component>
            <component name="Microsoft-Windows-ErrorReportingCore" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <DisableWER>1</DisableWER>
                <DefaultConsent>1</DefaultConsent>
            </component>
            <component name="Microsoft-Windows-IE-InternetExplorer" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <SearchScopes>
                    <Scope wcm:action="add">
                        <ScopeDefault>true</ScopeDefault>
                        <ScopeDisplayName>Google</ScopeDisplayName>
                        <ScopeUrl>http://www.google.de</ScopeUrl>
                        <ShowSearchSuggestions>false</ShowSearchSuggestions>
                        <ShowTopResult>false</ShowTopResult>
                        <ScopeKey>Search1</ScopeKey>
                        <FaviconURL>http://www.google.com/favicon.ico</FaviconURL>
                    </Scope>
                </SearchScopes>
                <DisableFirstRunWizard>true</DisableFirstRunWizard>
                <DisableOOBAccelerators>true</DisableOOBAccelerators>
                <FavoritesDelete>true</FavoritesDelete>
                <BlockPopups>no</BlockPopups>
                <AllSitesCompatibilityMode>true</AllSitesCompatibilityMode>
                <GroupTabs>false</GroupTabs>
                <Home_Page>http://www.test.com</Home_Page>
                <ShowInformationBar>true</ShowInformationBar>
                <ShowMenuBar>true</ShowMenuBar>
                <SuggestedSitesEnabled>false</SuggestedSitesEnabled>
                <FilterLevel>High</FilterLevel>
                <PlaySound>false</PlaySound>
                <EnableLinksBar>false</EnableLinksBar>
            </component>
            <component name="Microsoft-Windows-International-Core" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <InputLocale>de-de</InputLocale>
                <SystemLocale>de-de</SystemLocale>
                <UILanguage>de-de</UILanguage>
                <UILanguageFallback></UILanguageFallback>
                <UserLocale>de-de</UserLocale>
            </component>
            <component name="Microsoft-Windows-Security-Licensing-SLC-UX" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <SkipAutoActivation>true</SkipAutoActivation>
            </component>
        </settings>
        <settings pass="oobeSystem">
            <component name="Microsoft-Windows-International-Core" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <InputLocale>de-de</InputLocale>
                <SystemLocale>de-de</SystemLocale>
                <UILanguage>de-de</UILanguage>
                <UILanguageFallback></UILanguageFallback>
                <UserLocale>de-de</UserLocale>
            </component>
            <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <OOBE>
                    <HideEULAPage>true</HideEULAPage>
                    <HideWirelessSetupInOOBE>true</HideWirelessSetupInOOBE>
                    <NetworkLocation>Work</NetworkLocation>
                    <ProtectYourPC>1</ProtectYourPC>
                    <SkipMachineOOBE>true</SkipMachineOOBE>
                    <SkipUserOOBE>true</SkipUserOOBE>
                </OOBE>
                <UserAccounts>
                    <AdministratorPassword>
                        <Value>KgBlAGMAYwBvAHMAKgBBAGQAbQBpAG4AaQBzAHQAcgBhAHQAbwByAFAAYQBzAHMAdwBvAHIAZAA=</Value>
                        <PlainText>false</PlainText>
                    </AdministratorPassword>
                    <LocalAccounts>
                        <LocalAccount wcm:action="add">
                            <Password>
                                <Value>cgBlAG0AbwB0AGUAUABhAHMAcwB3AG8AcgBkAA==</Value>
                                <PlainText>false</PlainText>
                            </Password>
                            <Description>test</Description>
                            <DisplayName>test</DisplayName>
                            <Group>Administrators</Group>
                            <Name>test</Name>
                        </LocalAccount>
                        <LocalAccount wcm:action="add">
                            <Password>
                                <Value>bQBhAGYAaQBzAFAAYQBzAHMAdwBvAHIAZAA=</Value>
                                <PlainText>false</PlainText>
                            </Password>
                            <Description>test</Description>
                            <DisplayName>test</DisplayName>
                            <Group>PowerUsers</Group>
                            <Name>test</Name>
                        </LocalAccount>
                    </LocalAccounts>
                </UserAccounts>
                <ShowWindowsLive>false</ShowWindowsLive>
                <TimeZone>W. Europe Standard Time</TimeZone>
                <DoNotCleanTaskBar>true</DoNotCleanTaskBar>
                <FirstLogonCommands>
                    <SynchronousCommand wcm:action="add">
                        <Order>1</Order>
                        <RequiresUserInput>false</RequiresUserInput>
                        <CommandLine>cscript //b c:\\windows\\system32\\slmgr.vbs -cpky</CommandLine>
                    </SynchronousCommand>
                    <SynchronousCommand wcm:action="add">
                        <Order>2</Order>
                        <CommandLine>cscript //b c:\\windows\\system32\\slmgr.vbs -upk </CommandLine>
                        <RequiresUserInput>false</RequiresUserInput>
                    </SynchronousCommand>
                </FirstLogonCommands>
                <RegisteredOwner>test</RegisteredOwner>
            </component>
        </settings>
        <settings pass="generalize">
            <component name="Microsoft-Windows-Security-SPP" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="NonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <SkipRearm>1</SkipRearm>
            </component>
            <component name="Microsoft-Windows-PnpSysprep" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <DoNotCleanUpNonPresentDevices>false</DoNotCleanUpNonPresentDevices>
                <PersistAllDeviceInstalls>true</PersistAllDeviceInstalls>
            </component>
        </settings>
    </unattend>

    Wird diese Datei jetzt dem WDS image hinzugefügt bekomme ich im spezialize den fehler das einige Angaben doppelt gemacht wurden

    Nehme ich die erweiterte unattend und starte sysprep erhalte ich den gleichen fehler.

    Führe ich sysprep ohne unattend zusatz aus. läuft alles nach plan bis auf einige einstellungen die ich nur mit copyprofile erhalte.

    Vielleicht hat jemand die Lösung für mich.

    Vielen Dank für die Hilfe im Voraus.

    Montag, 13. Februar 2012 19:05

Antworten

  • Hallo Paul,

    selbstverständlich.

    Das Problem lag an den Scope Einstellungen.

    <SearchScopes>
                    <Scope wcm:action="add">
                        <ScopeDefault>true</ScopeDefault>
                        <ScopeDisplayName>Google</ScopeDisplayName>
                        <ScopeUrl>http://www.google.de</ScopeUrl>
                        <ShowSearchSuggestions>false</ShowSearchSuggestions>
                        <ShowTopResult>false</ShowTopResult>
                        <ScopeKey>Search1</ScopeKey>
                        <FaviconURL>http://www.google.com/favicon.ico</FaviconURL>

    Es dürfen keine Einstellungen bei dem Befehl CopyProfile vorhanden sein. Dann läuft die unattended über WDS einwandfrei durch.

    Gruß

    Norbert

    Montag, 20. Februar 2012 15:13

Alle Antworten