none
Procv dentro de SE

    Frage

  • Boa tarde, o que eu estou tentando fazer é o seguinte:

    Eu tenho uma coluna com um valor, eu tenho que buscar em outra coluna para ver se o valor inicial pode ser encontrado nessa segunda coluna, se ele não for encontrado tenho que buscar em uma terceira coluna, se o valor não for encontrado em nenhuma das duas a formula retorna "não encontrado".

    Estou tentando fazer assim:

    =SE(PROCV(U2;G:G;7;FALSO);VERDADEIRO;SE(PROCV(U2;A:A;1;FALSO);VERDADEIRO;FALSO))

    Porem não estou tendo muito sucesso. Alguma dica?

    Observação, não consegui encontrar opção de postar no forum de excel =/

    • Verschoben AndreAlvesLimaMVP Montag, 20. Februar 2012 20:30 (De:Onde devo postar minha dúvida?)
    Dienstag, 14. Februar 2012 15:20

Antworten

  • Olá,

    Por favor, descreva qual a sua intenção com esta fórmula, pois fórmulas com argumentos lógicos (SE) são verdadeiras "pegadinhas".

    Olhando sua fórmula, eu vejo um pequeno problema inicial na parte do PROCV, pois você definiu como matriz de pesquisa a coluna G inteira (G:G), porém no terceiro argumento da função você especificou como índice coluna o número 7, o que somente é possível se você definir uma matriz de pesquisa com 7 colunas (A:G).

    Outra coisa, não se esqueça que o primeiro argumento da função SE é um argumento lógico (V ou F), e a função PROCV não retorna um valor lógico. Para usar a função PROCV como argumento lógico você precisa de uma função auxiliar (éerro, éerros, etc.).

    Vou dar um exemplo: quero retornar a frase "Não localizado" utilizando como referência a função procv, a fórmula poderia ser:

    =SE(ÉERROS(PROCV(U2;G:G;1;FALSO));"Não localizado";"Localizado")

    Esta fórmula procura na coluna G inteira se o valor definido na célula U2 existe, caso o valor não seja encontrado ("erro") retorna a frase "Não localizado"

    Como falei no começo, não sei qual sua necessidade ou qual lógica você está utilizando, se puder dar mais detalhes talvez fique mais fácil te auxiliar.

    Abraço!

    Fábio Brito.


    Fabio Brito

    Mittwoch, 22. Februar 2012 14:08

Alle Antworten

  • Prezado(a),
    Estou migrando seu post para o fórum de Office Geral.
    Por favor, das próximas vezes que tiver alguma dúvida relacionada a esse assunto, poste por lá.
    Outra opção seria postar no Microsoft Answers, categoria Office: http://answers.microsoft.com/pt-br/office
    Obrigado.


    André Alves de Lima
    Microsoft MVP - Client App Dev
    Visite o meu site: http://www.andrealveslima.com.br
    Me siga no Twitter: @andrealveslima

    Montag, 20. Februar 2012 20:30
  • Boa noite Cassio.

    Para facilitar poste um exemplo da tua planilha num site gratuito como:

    www.sendspace.com e depois cole o link aqui no fórum.

    Abraço.

    Montag, 20. Februar 2012 20:49
  • Olá,

    Por favor, descreva qual a sua intenção com esta fórmula, pois fórmulas com argumentos lógicos (SE) são verdadeiras "pegadinhas".

    Olhando sua fórmula, eu vejo um pequeno problema inicial na parte do PROCV, pois você definiu como matriz de pesquisa a coluna G inteira (G:G), porém no terceiro argumento da função você especificou como índice coluna o número 7, o que somente é possível se você definir uma matriz de pesquisa com 7 colunas (A:G).

    Outra coisa, não se esqueça que o primeiro argumento da função SE é um argumento lógico (V ou F), e a função PROCV não retorna um valor lógico. Para usar a função PROCV como argumento lógico você precisa de uma função auxiliar (éerro, éerros, etc.).

    Vou dar um exemplo: quero retornar a frase "Não localizado" utilizando como referência a função procv, a fórmula poderia ser:

    =SE(ÉERROS(PROCV(U2;G:G;1;FALSO));"Não localizado";"Localizado")

    Esta fórmula procura na coluna G inteira se o valor definido na célula U2 existe, caso o valor não seja encontrado ("erro") retorna a frase "Não localizado"

    Como falei no começo, não sei qual sua necessidade ou qual lógica você está utilizando, se puder dar mais detalhes talvez fique mais fácil te auxiliar.

    Abraço!

    Fábio Brito.


    Fabio Brito

    Mittwoch, 22. Februar 2012 14:08