none
Windows Server 2012 RemoteApp requires NLA to XP SP3 clients

    Frage

  • Hi all,

    I've deployed an RDS farm with all rolesi implemented (3 session hosts, 2 connection brokers, 2 gateways, 2 rd web access). I've a strange behaviour from Windows XP Workstation:

    scenario A

    I can successfully connect to a remote desktop in my farm fromthe internet via the gateways

    scenario B

    If I try to launch a remote app trough my rd web access server, I get an error: "The remote computer requires Network Level Authentication, which your computer does not support. For assistance, contact system administrator or technical support."

    I've disabled NLA in my deployment so, I can't figure out what's the trouble

    Freitag, 21. Juni 2013 19:27

Antworten

  • Hi,

    On your two RD Connection Broker servers, please go to System Properties, Remote tab and make sure that Allow connections only from computers running Remote Desktop with Network Level Authentication is unchecked.

    On your XP SP3 clients I recommend you install Remote Desktop Client 7 (6.1.7600) if you have not already.  You will likely need to enable CredSSP if you experience problems authenticating (example: endless prompts for credentials).  Instructions for enabling CredSSP are in this article:

    http://support.microsoft.com/kb/951608

    Once you have the RDP 7.0 client and CredSSP enabled the client will be able to use NLA when connecting.

    Please note that with Server 2012 RDS you should use clients that support RDP 8.0 protocol for best results and support of the latest features.  Unfortunately there is no RDP 8.0 client for XP so you may run into some limitations that you will need to work around and the features will be limited.

    Thanks.

    -TP

    Samstag, 22. Juni 2013 06:44

Alle Antworten

  • Hi,

    On your two RD Connection Broker servers, please go to System Properties, Remote tab and make sure that Allow connections only from computers running Remote Desktop with Network Level Authentication is unchecked.

    On your XP SP3 clients I recommend you install Remote Desktop Client 7 (6.1.7600) if you have not already.  You will likely need to enable CredSSP if you experience problems authenticating (example: endless prompts for credentials).  Instructions for enabling CredSSP are in this article:

    http://support.microsoft.com/kb/951608

    Once you have the RDP 7.0 client and CredSSP enabled the client will be able to use NLA when connecting.

    Please note that with Server 2012 RDS you should use clients that support RDP 8.0 protocol for best results and support of the latest features.  Unfortunately there is no RDP 8.0 client for XP so you may run into some limitations that you will need to work around and the features will be limited.

    Thanks.

    -TP

    Samstag, 22. Juni 2013 06:44
  • thanks, disabling NLA on my connection brokers worked!

    So when I disable NLA in my collection, the settings is not applied to the connection brokers.

    Samstag, 22. Juni 2013 08:23