none
Routing Group Connectoren Ex2003 zu Ex2010

    Frage

  • Guten Tag

    Wir haben vor, eine Exchange 2003 SP2 auf Exchange 2010 SP2 zu migrieren.
    Die Server liegen nicht im gleichen Subnet, die Firewall ist dazwischen aber komplett offen.
    Über Telnet kann ich jeden Port testen (zB. "telnet srvname.domain.local 25")

    Das Problem, welches wir nun haben liegt bei den Routing Group Connectoren. Wir können keine E-Mails von einem Konto auf dem Exch03 zu einem Konto auf Exch10 oder umgekehrt senden.

    Auf dem Exch10 habe ich über erweitertes Logging folgende Fehlermeldungen erhalten:

    2012-03-27T08:55:10.082Z,08CEDA0A62857D04,SMTP,"cn=erste routinggruppe,cn=routing groups,cn=erste administrative gruppe,cn=administrative groups,cn=domain,cn=microsoft exchange,cn=services,cn=configuration,dc=domain,dc=local",+,SmtpRelayToTiRg 446e78ca-4b71-4b2c-ad11-e4dc7ec38328;QueueLength=3
    2012-03-27T08:55:10.097Z,08CEDA0A62857D04,SMTP,"cn=erste routinggruppe,cn=routing groups,cn=erste administrative gruppe,cn=administrative groups,cn=domain,cn=microsoft exchange,cn=services,cn=configuration,dc=domain,dc=local",>,exch03.domain.local[***.***.***.***]
    2012-03-27T08:55:10.113Z,08CEDA0A62857D04,SMTP,"cn=erste routinggruppe,cn=routing groups,cn=erste administrative gruppe,cn=administrative groups,cn=domain,cn=microsoft exchange,cn=services,cn=configuration,dc=domain,dc=local",>,Established connection to ***.***.***.***
    2012-03-27T08:55:10.222Z,08CEDA0A62857D04,SMTP,"cn=erste routinggruppe,cn=routing groups,cn=erste administrative gruppe,cn=administrative groups,cn=domain,cn=microsoft exchange,cn=services,cn=configuration,dc=domain,dc=local",-,Messages: 0 Bytes: 0 (Retry : Cannot achieve Exchange Server authentication)

    Bereits kontrolliert habe ich die Einstellungen des virtuellen SMTP Server auf dem Exch03. Diese sollten in Ordnung sein (Integrierte Windows Authentifizierung aktiv)

    Die Routing Group Connectoren habe ich auch bereits neu erstellt.

    Hat jemand noch eine Idee, woran dieser Fehler noch liegen könnte?




    Dienstag, 27. März 2012 09:03

Antworten

  • Hallo Timo

    Ich habe die Lösung gefunden.
    Folgenden Fehler haben wir beim Exchange Troubleshooter erhalten:

    Eine SMTP Verbindung zwischen den beiden Exchange Servern konnte immer aufgebaut werden über telnet. Aber es wurden keine SMTP Befehle erkannt. Ständig kam folgende Fehlermeldung beim Absetzen von SMTP Befehlen über die Telnet Verbindung:
    500 Command   unrecognized
    Zudem sah die Titelzeile der SNMP Verbindung immer so aus:
    220********************************************************************************

    Unser Netzwerk Techniker hat nachher folgende Lösung von Microsoft angewendet:

    To turn off the Mailguard feature of the PIX or ASA firewall:  
    1. Log on to the PIX or ASA firewall by establishing a telnet session or by using the console.
    2. Type enable, and then press ENTER.
    3. When you are prompted for your password, type your password, and then press ENTER.
    4. Type configure terminal, and then press ENTER.
    5. Type no fixup protocol smtp 25, and then press ENTER.
    6. Type write memory, and then press ENTER.
    7. Restart or reload the PIX or ASA firewall.

    Quelle: http://support.microsoft.com/kb/320027/en-us?fr=1

    Dannach konnten beide Server über SMTP miteinander kommunizieren und die E-Mails wurden zwischen den Postfächern der beiden Exchange Server hin und her gesendet.

    Trotzdem vielen Dank für deine schnelle Hilfe. :-)
    Und einen schönen Abend.

    Liebe Grüsse
    Fabian Kessler

    Dienstag, 27. März 2012 17:58

Alle Antworten

  • Hallo Fabian,

    hast Du auf dem Exchange 2010 evtl. noch einen weiteren (außer dem Client- und Default-) Receive-Connector, der in den Remote-Adressen evtl. das Subnetz bzw. die IP des Exchange 2003 Servers beinhaltet?

    Viele Grüße

    Timo


    Dienstag, 27. März 2012 09:09
    Moderator
  • Hallo Timo

    Folgende Receive Connectoren setzen wir ein:

    Exch03:

    • Virtueller Standard Server für SMTP:
      Erlaubte IP: Gateway des Subnet, IP Exch03, IP Exch10

    Exch10:

    • Default Receive Connector:
      Erlaubter IP Bereich: Alles

    Auf dem Exch10 ist noch der Receive Connector Client. Der ist aber nicht für Exchange Server Kommunikation von Bedeutung.
    Oder irre ich mich? :-)

    Dienstag, 27. März 2012 09:25
  • Ok, d.h. einen dritten Konnektor hast Du auf dem 2010 nicht, oder?

    Kannst Du mal die Ausgabe von "Get-ReceiveConnector *default* | FL" hier posten?

    Viele Grüße

    Timo

    Dienstag, 27. März 2012 09:29
    Moderator
  • Nein, einen dritten gibt es nicht.

    Folgende Ausgabe erhalte ich für den Get Befehl:

    RunspaceId                              : 8146c20d-a65f-4aaa-b72f-ef5122730fc1
    AuthMechanism                           : Tls, Integrated, BasicAuth, ExchangeServer
    Banner                                  :
    BinaryMimeEnabled                       : True
    Bindings                                : {0.0.0.0:25}
    ChunkingEnabled                         : True
    DefaultDomain                           :
    DeliveryStatusNotificationEnabled       : True
    EightBitMimeEnabled                     : True
    BareLinefeedRejectionEnabled            : False
    DomainSecureEnabled                     : False
    EnhancedStatusCodesEnabled              : True
    LongAddressesEnabled                    : False
    OrarEnabled                             : False
    SuppressXAnonymousTls                   : False
    AdvertiseClientSettings                 : False
    Fqdn                                    : exch10.domain.local
    Comment                                 :
    Enabled                                 : True
    ConnectionTimeout                       : 00:10:00
    ConnectionInactivityTimeout             : 00:05:00
    MessageRateLimit                        : unlimited
    MessageRateSource                       : IPAddress
    MaxInboundConnection                    : 5000
    MaxInboundConnectionPerSource           : 20
    MaxInboundConnectionPercentagePerSource : 100
    MaxHeaderSize                           : 64 KB (65,536 bytes)
    MaxHopCount                             : 60
    MaxLocalHopCount                        : 12
    MaxLogonFailures                        : 3
    MaxMessageSize                          : 10 MB (10,485,760 bytes)
    MaxProtocolErrors                       : 5
    MaxRecipientsPerMessage                 : 200
    PermissionGroups                        : AnonymousUsers, ExchangeUsers, ExchangeServers, ExchangeLegacyServers
    PipeliningEnabled                       : True
    ProtocolLoggingLevel                    : Verbose
    RemoteIPRanges                          : {0.0.0.0-255.255.255.255}
    RequireEHLODomain                       : False
    RequireTLS                              : False
    EnableAuthGSSAPI                        : False
    ExtendedProtectionPolicy                : None
    LiveCredentialEnabled                   : False
    TlsDomainCapabilities                   : {}
    Server                                  : EXCH10
    SizeEnabled                             : EnabledWithoutValue
    TarpitInterval                          : 00:00:05
    MaxAcknowledgementDelay                 : 00:00:30
    AdminDisplayName                        :
    ExchangeVersion                         : 0.1 (8.0.535.0)
    Name                                    : Default
    DistinguishedName                       : CN=Default,CN=SMTP Receive Connectors,CN=Protocols,CN=EXCH10,CN=Servers,CN=
                                              Exchange Administrative Group (FYDIBOHF23SPDLT),CN=Administrative Groups,CN=domain,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=domain,DC=local
    Identity                                : EXCH10\Default
    Guid                                    : f007e02a-bf18-452d-b011-34a0e388e1bc
    ObjectCategory                          : domain.local/Configuration/Schema/ms-Exch-Smtp-Receive-Connector
    ObjectClass                             : {top, msExchSmtpReceiveConnector}
    WhenChanged                             : 27.03.2012 10:18:11
    WhenCreated                             : 26.02.2012 10:32:27
    WhenChangedUTC                          : 27.03.2012 08:18:11
    WhenCreatedUTC                          : 26.02.2012 09:32:27
    OrganizationId                          :
    OriginatingServer                       : DCSRV.domain.local
    IsValid                                 : True

    Grüsse
    Fabian

    Dienstag, 27. März 2012 09:48
  • Hallo Fabian,

    das hat ja schon irgendwer dran rumgedreht. Standard ist:

    Viele Grüße

    Timo

    Dienstag, 27. März 2012 10:50
    Moderator
  • Ähm, hast Du den Default Connector mal gelöscht und neu angelegt?
    Dienstag, 27. März 2012 10:52
    Moderator
  • Hallo Timo

    Ich habe den Receive Connector neuangelegt. Zudem habe ich genau geschaut, dass ich die Defautl Einstellungen verwende. Leider immer noch das gleiche Ergebniss.

    Ich lasse mal noch die Exchange internen Test Tools laufen (Exchange Practice Analyzer und den Troubleshooting Assistent.

    Dienstag, 27. März 2012 13:21
  • Hallo Timo

    Ich habe die Lösung gefunden.
    Folgenden Fehler haben wir beim Exchange Troubleshooter erhalten:

    Eine SMTP Verbindung zwischen den beiden Exchange Servern konnte immer aufgebaut werden über telnet. Aber es wurden keine SMTP Befehle erkannt. Ständig kam folgende Fehlermeldung beim Absetzen von SMTP Befehlen über die Telnet Verbindung:
    500 Command   unrecognized
    Zudem sah die Titelzeile der SNMP Verbindung immer so aus:
    220********************************************************************************

    Unser Netzwerk Techniker hat nachher folgende Lösung von Microsoft angewendet:

    To turn off the Mailguard feature of the PIX or ASA firewall:  
    1. Log on to the PIX or ASA firewall by establishing a telnet session or by using the console.
    2. Type enable, and then press ENTER.
    3. When you are prompted for your password, type your password, and then press ENTER.
    4. Type configure terminal, and then press ENTER.
    5. Type no fixup protocol smtp 25, and then press ENTER.
    6. Type write memory, and then press ENTER.
    7. Restart or reload the PIX or ASA firewall.

    Quelle: http://support.microsoft.com/kb/320027/en-us?fr=1

    Dannach konnten beide Server über SMTP miteinander kommunizieren und die E-Mails wurden zwischen den Postfächern der beiden Exchange Server hin und her gesendet.

    Trotzdem vielen Dank für deine schnelle Hilfe. :-)
    Und einen schönen Abend.

    Liebe Grüsse
    Fabian Kessler

    Dienstag, 27. März 2012 17:58