none
regedit Eintrag ändern

    Frage

  • Hallo zusammen,

    Um einen Fehler in SBS 2011 zu beheben sollte ich einen Schlüssel in der Regedit ändern. Das misslang mir bis anhin. Regedit meldet, dass mir die nötigen Rechte dazu fehlen. 

    Der Versuch regedit.exe als angemeldeter Admin auszuführen misslang ebenso wie auch die Ausführung "als Administrator ausführen" funktionierte nicht. Kann auch keinen normalen User am Server hinzufügen um dann regedit zu starten  und dann während des Starts den Admin auszuwählen.

    Was mache ich falsch?

    Besten Dank für die Inputs.

     


    Sonntag, 17. Juli 2011 12:06

Antworten

Alle Antworten

  • Hallo,

    ist der User mit dem du regedit starten willst tatsächlich Mitglied der Gruppe "Administratoren" auf dem SBS?
    Um welchen Registry Schlüssel handelt es sich?

    Funktionieren anderen administrative Aktionen auf dem Server?
    Kannst du dich mit einem lokalem Account an dem Server Anmelden (der administrative Berechtigungen besitzt)?

    Sonntag, 17. Juli 2011 12:23
  • Hi,

    der User ist Mitglied der Administratoren.

    Ich versuche den VSS-Fehler wie unter http://social.technet.microsoft.com/Forums/en-US/smallbusinessserver/thread/7d6fd770-945c-4120-8607-f61813ba4fcd beschrieben zu beheben. Folgendes sollte ich tun:

    1. Click Start , click Run , type Regedit on the Open box, and then click OK .
    2. Navigate to the following registry key: HKEY_CLASSES_ROOT\AppID\{61738644-F196-11D0-9953-00C04FD919C1}
    3. Right click on the key {61738644-F196-11D0-9953-00C04FD919C1} and choose permissions
    4. Grant the Administrators group Full Control
    5. ...

    Leider bislang ohne Erfolg.
    Sonntag, 17. Juli 2011 12:34
  • Diese Schlüssel ist im Besitz des TrustedInstaller.

    Du musst also (wenn überhaupt möglich) erst einmal den Besitz des Schlüssels übernehmen.

    Dann sollte es auch mit dem Ändern klappen ;)

     

     

    Sonntag, 17. Juli 2011 14:57
  • Besitz des Schlüssels übernehmen? Hast du mir ein Tipp wie ich das mache?
    Sonntag, 17. Juli 2011 15:33
  • Moin,

    rechte Maustaste auf den betreffenden Registryschlüssel, Berechtigungen, Erweitert und dann den Reiter Besitzer aufrufen. Dort kannst Du den Besitzer ändern.

     

    Gruß

    Uwe

    Sonntag, 17. Juli 2011 15:47
  • Funktioniert leider nicht. Egal was ich anklicke > Zugriff verweigert.
    Auch neuer Admin hinzufügen und irgendwelche Rechte zuweisen wird verweigert.
    Sonntag, 17. Juli 2011 16:16
  • >Auch neuer Admin hinzufügen und irgendwelche Rechte zuweisen wird verweigert.

    Du meinst einen anderen Admin-Account zu den Berechtigungen dieses Schlüssels hinzufügen?

    Kennst du den betreffenden Artikel?

    http://support.microsoft.com/default.aspx?scid=kb;en-US;2483007

     

    Sonntag, 17. Juli 2011 20:44
  • Das wars! Jetzt klappt's.

    Besten Dank!

    Montag, 18. Juli 2011 13:58