none
Gesendete E-Mail wird im CRM 2011 als MSG-Datei gespeichert

    Frage

  • Hallo,

    folgendes Problem tritt hin und wieder auf.

    Aus dem MS CRM 2011 Outlook Client wird eine E-Mail mit Anhängen an einen CRM Kontakt gesendet. Gleichzeitig wird ein Bezug zur CRM Firma des Kontaktes hergestellt.

    Nach dem die E-Mail gesendet ist, ist im CRM eine entsprechende geschlossene E-Mail Aktivität vorhanden.

    Das Problem ist, dass die gesendete E-Mail und deren Anhänge in der E-Mail Aktivität als MSG-Datei im Anhang der E-Mail Aktivität gespeichert wird.

    MfG
    Roland Rattay

    Donnerstag, 10. Mai 2012 08:31

Antworten

  • Hallo Roland,

    wir hatten ein ähnliches Phänomen bei einem Kunden. In dem Fall hängt es vom Format ab. Gesendete E-mails im

    • Rich Text mit Attachment werden als .msg Datei im CRM gespeichert
    • HTML und Plain Text mit Attachment funktionieren normal
    • ohne Anhang werden unabhängig vom Format richtig im CRM dargestellt

    Ich konnte die Ursache noch nicht ermitteln, da wir bei uns im Haus dieses Verhalten nicht feststellen konnten. Wir haben bei diesem Kunden allerdings auch eine spezielle Umgebung, da sie zB. alle ausgehenden Kunden E-Mails unabhängig vom verwendeten Format in Plain Text umwandeln und als Standard Rich-Text eingestellt haben.

    Wir haben ausserdem eine ziemliche zeitliche Verzögerung festgestellt, wenn eine E-Mail beim Versenden bereits getracket wird und bis sie im Outlook sauber aufgelöst ist (bis zu 10 Sek). Wir müssen jetzt erst mal feststellen ob der Exchange Server da den Flaschenhals spielt.

    Vielleicht hilft dir das weiter.

    SG

    Thomas Lampert

    • Als Antwort markiert RRATC Montag, 30. Juli 2012 06:58
    Donnerstag, 19. Juli 2012 07:24

Alle Antworten

  • Hallo Roland!

    Tritt das Problem nur bei bestimmten Benutzern oder bei allen Benutzern auf?
    Welches Format haben die Anhänge, wenn das Problem auftritt?


    Ich hoffe das bringt weiter. Andreas(a)Donaubauer.com www.crmfaq.de

    Freitag, 11. Mai 2012 10:57
  • Hallo Andreas,

    das Problem tritt nur bei einigen Benutzern auf.

    Ich habe z.B. ca. 50 E-Mails mit Anhängen (DOC, DOCX, PDF, EXCEL) gesendet und keine Probleme gehabt.

    Bei den Anhängen hat es sich um PDF Dateien gehandelt.

    MfG
    Roland Rattay

    Freitag, 11. Mai 2012 11:27
  • Hallo Roland!

    Welches RU hast du aktuell. Installiere RU 7. Tritt der Fehler dannach noch auf?

    http://www.dynamicsconsulting.de/2012/03/23/microsoft-dynamics-crm-2011-update-rollup-7-for-microsoft-dynamics-crm-2011-kb-2600643/


    Ich hoffe das bringt weiter. Andreas(a)Donaubauer.com www.crmfaq.de

    Montag, 14. Mai 2012 08:27
  • Hallo Andreas,

    Das UR 7 ist leider bereits installiert.

    MfG
    Roland Rattay

    Montag, 14. Mai 2012 08:33
  • Hallo Roland,

    Vielleicht eine überflüssige Frage, aber: Laufen rund um die E-Mail-Aktivität irgendwelche Logiken (Workflows, Plugins, Scripts)? Haben diese Benutzer, wo das Problem auftritt evtl. irgendeine Gemeinsamkeit (Rolle, Outlook-Konfiguration, etc.)?

    Liebe Grüße,

    Andreas


    Andreas Buchinger
    Microsoft Dynamics Certified Technology Specialist
    MCPD: SharePoint Developer 2010

    Dienstag, 15. Mai 2012 09:02
  • Hallo Andreas,

    bzgl. E-Mail Aktivitäten gibt es keine Workflows, Plugins und Scripte.

    Die Benutzer haben teils unterscvhiedliche Rollen.
    Die Outlook-Konfiguration sollte bei allen gleich sein (Outlook 2010 32-Bit; Office 365 Exchange Server; MS CRM 2011 Outlook Client UR7).

    MfG
    Roland Rattay

    Dienstag, 15. Mai 2012 09:13
  • Hallo Roland!

    Welche Größe haben die PDF-Dateien, die als MSG-Dateien im Anhang gespeichert werden.
    Gibt es hier Unterschiede zu den Dateien bei denen es keine Probleme gab?


    Ich hoffe das bringt weiter. Andreas(a)Donaubauer.com www.crmfaq.de

    Mittwoch, 16. Mai 2012 10:49
  • Hallo Andreas,

    entschuldige die Verspätung, ich hatte ein paar Tage frei. Auf Grund deiner Frage habe ich mir die letzten E-Mails in Ruhe angeschaut und analysiert.

    Ich musste dabei leider feststellen, dass man die Antworten der Benutzer leider immer hinterfragen sollte.

    Das Ergebnis meiner Analyse ist folgendes.

    Es handelt sich nicht nur um PDF Anhänge. Es gibt auch DOC Anhänge und es sind auch E-Mails ohne Anhänge betroffen.
    Die Größe der Anhänge schwang. Es gibt Anhänge welche 70 KB groß sind und Anhänge mit einer Größe von 3 MB.

    MfG
    Roland Rattay

    Donnerstag, 24. Mai 2012 08:50
  • Hallo Roland!

    Überprüfe die Weiterleitungsregel zum Email-Router-Weiterleitungspostfach.
    Wenn diese falsch eingestellt ist, entstehen Emails mit der E-Mail als Anhang selbst.


    Ich hoffe das bringt weiter. Andreas(a)Donaubauer.com www.crmfaq.de

    • Als Antwort vorgeschlagen Andreas Donaubauer Freitag, 25. Mai 2012 06:46
    • Nicht als Antwort vorgeschlagen RRATC Freitag, 25. Mai 2012 10:56
    Freitag, 25. Mai 2012 06:46
  • Hallo Andreas,

    wir verwenden keinen E-Mail-Router, sondern den CMR Outlook Client und den Exchange-Server von Office 365.

    MfG
    Roland Rattay

    Freitag, 25. Mai 2012 10:58
  • Hallo Roland!

    Es kann eventeuell jemand die Weiterleitungsregel verwendet haben.
    Diese ist unabhängig vom e-mail router und befindet sich im Postfach des Benutzers.


    Ich hoffe das bringt weiter. Andreas(a)Donaubauer.com www.crmfaq.de

    Freitag, 25. Mai 2012 12:38
  • Hallo Andreas,

    ich bin aktuell in einem anderen Projekt mehr als zu 100% involviert und muss deshalb leider dieses Problem erst einmal zurückstellen.

    Danke und mit freundlichen Grüßen
    Roland Rattay

    Mittwoch, 30. Mai 2012 07:18
  • Hallo Andreas,

    ich bin endlich dazu gekommen auf deine Antwort zu reagieren.

    Der Benutzer hat leider keine Weiterleitungsregel eingerichtet.

    Weiterhin musste ich aber auch noch feststellen, dass das Problem nicht nur bei gesendeten E-Mails auftritt.

    Ich habe jetzt auch einige E-Mails gefunden, welche empfangen wurden sind und als MSG-Datei im Anhang gespeichert wurden.

    Trotzdem Danke und Gruß
    Roland Rattay

    Freitag, 22. Juni 2012 07:27
  • prbiere mal den key:

    HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Outlook\Preferences

    DWORD= DisableTNEF 1


    gruss Daniel Ovadia MBSS - Microsoft Dynamics CRM MCNPS

    Freitag, 22. Juni 2012 10:01
  • Hallo Daniel,

    laut meinen Recherchen hilft der Key DisableTNEF beim Problem, dass der Empfänger einer Outlook Nachricht im Anhang eine Winmail.dat bekommt.

    Dies ist hier aber nicht der Fall. Die gesendeten und empfangenen Nachrichten sind in Ordnung.

    Das Problem sind die im CRM erzeugten E-Mails bzw. die in Outlook korrekt empfangenen E-Mails, welche dann einem Datensatz im CRM zugeordnet werden.

    MfG
    Roland Rattay

    Freitag, 22. Juni 2012 10:22
  • Hallo Roland,

    wir hatten ein ähnliches Phänomen bei einem Kunden. In dem Fall hängt es vom Format ab. Gesendete E-mails im

    • Rich Text mit Attachment werden als .msg Datei im CRM gespeichert
    • HTML und Plain Text mit Attachment funktionieren normal
    • ohne Anhang werden unabhängig vom Format richtig im CRM dargestellt

    Ich konnte die Ursache noch nicht ermitteln, da wir bei uns im Haus dieses Verhalten nicht feststellen konnten. Wir haben bei diesem Kunden allerdings auch eine spezielle Umgebung, da sie zB. alle ausgehenden Kunden E-Mails unabhängig vom verwendeten Format in Plain Text umwandeln und als Standard Rich-Text eingestellt haben.

    Wir haben ausserdem eine ziemliche zeitliche Verzögerung festgestellt, wenn eine E-Mail beim Versenden bereits getracket wird und bis sie im Outlook sauber aufgelöst ist (bis zu 10 Sek). Wir müssen jetzt erst mal feststellen ob der Exchange Server da den Flaschenhals spielt.

    Vielleicht hilft dir das weiter.

    SG

    Thomas Lampert

    • Als Antwort markiert RRATC Montag, 30. Juli 2012 06:58
    Donnerstag, 19. Juli 2012 07:24
  • Hallo Thomas,

    danke für die Antwort. Ich selbst hatte bis heute keine Probleme gehabt.

    Habe jetzt mal Rich Text genommen und danach eine msg Datei im CRM gehabt.

    Gruß

    Roland Rattay

    Montag, 30. Juli 2012 06:58
  • Hallo Roland,

    konntest du zwischenzeitlich eine Lösung finden? Wir sind immer noch auf der Suche und ich habe es bei zweien meiner Kunden feststellen können. Bei uns wie bereits erwähnt tritt dieser Umstand nicht auf.

    Grüße

    Thomas


    Thomas Lampert

    Mittwoch, 19. September 2012 09:01
  • Hallo Thomas,

    eine Lösung habe ich leider nicht.

    Ich habe den Kollegen gesagt, dass Sie als Workaround bei Senden der E-Mails kein Rich Text mehr verwenden sollen.

    Gruß
    Roland Rattay

    Mittwoch, 19. September 2012 11:09
  • Hallo Roland,

    danke für die Antwort. Bin mittlerweile zum selben Ergebnis angekommen. In unserem Fall ist es etwas schwieriger, da bislang alle E-Mails per RTF versendet wurden. Extern ist es eigentlich egal, da diese sowieso in Plain Text konvertiert werden aber intern gab es halt das Problem.

    Werden wir damit leben lernen müssen bzw. auf HTML umstellen :)

    Grüße

    Thomas


    Thomas Lampert

    Mittwoch, 19. September 2012 11:13