none
Changing Task forms in Workflow.xml is not reflected in the site.

    Frage

  • I have One workflow X. I deployed the same X workflow as two features named as 'WF_WithDesign' and 'WF_WithoutDesign' just by changing the GUID and Name of the feature.xml.

    I have 2 different set of info path forms with same set of fields but different UI design.

    The first set of forms are in 'WF_WithDesign' feature folder and the second set of forms in 'WF_WithoutDesign' feature folder. For both the features I associated the task forms in workflow.xml file as shown below.


    Feature 1:

     <MetaData>
      <Association_FormURN>urn:schemas-microsoft-com:office:infopath:InitiationTemplate3:-myXSD-2010-11-20T12-28-34</Association_FormURN>
      <Instantiation_FormURN>urn:schemas-microsoft-com:office:infopath:InitiatorDueDate3:-myXSD-2010-11-20T12-28-34</Instantiation_FormURN>
      <Task0_FormURN>urn:schemas-microsoft-com:office:infopath:InitiatorDueDate3:-myXSD-2010-11-20T12-28-34</Task0_FormURN>
      <Task1_FormURN>urn:schemas-microsoft-com:office:infopath:RecommenderForm3:-myXSD-2010-11-20T12-28-34</Task1_FormURN>
      <Task2_FormURN>urn:schemas-microsoft-com:office:infopath:ReviewerForm3:-myXSD-2010-11-20T12-28-34</Task2_FormURN>
      <Task3_FormURN>urn:schemas-microsoft-com:office:infopath:ApprovedForm3:-myXSD-2010-11-20T12-28-34</Task3_FormURN>
      <StatusPageUrl>_layouts/WrkStat.aspx</StatusPageUrl>
     </MetaData>

    Feature 2:

     <MetaData>
      <Association_FormURN>urn:schemas-microsoft-com:office:infopath:InitiationTemplate3:-myXSD-2010-11-20T12-28-34</Association_FormURN>
      <Instantiation_FormURN>urn:schemas-microsoft-com:office:infopath:InitiatorDueDate3:-myXSD-2010-11-20T12-28-34</Instantiation_FormURN>
      <Task0_FormURN>urn:schemas-microsoft-com:office:infopath:InitiatorDueDate3:-myXSD-2010-11-20T12-28-34</Task0_FormURN>
      <Task1_FormURN>urn:schemas-microsoft-com:office:infopath:RecommenderForm4:-myXSD-2010-11-20T12-28-34</Task1_FormURN>
      <Task2_FormURN>urn:schemas-microsoft-com:office:infopath:ReviewerForm4:-myXSD-2010-11-20T12-28-34</Task2_FormURN>
      <Task3_FormURN>urn:schemas-microsoft-com:office:infopath:ApprovedForm4:-myXSD-2010-11-20T12-28-34</Task3_FormURN>
      <StatusPageUrl>_layouts/WrkStat.aspx</StatusPageUrl>
     </MetaData>

    When I try to view the feature 2('WF_WithoutDesign') forms, it is always showing me the feature 1('WF_WithDesign') forms only.

    Can you help me in finding out as to what I am missing?


    • Bearbeitet Nithya N Donnerstag, 23. Februar 2012 11:52
    Donnerstag, 23. Februar 2012 11:51

Alle Antworten

  • Hi Nithya,

    I am trying to involve someone familiar with this topic to further look at this issue. There might be some time delay. Appreciate your patience.

    Thanks


    Daniel Yang

    TechNet Community Support

    Dienstag, 28. Februar 2012 11:32
    Moderator
  • Hi Nithya N,

    I know this is going to be a basic question but we need to be sure: did you actually "re-publish" the InfoPath forms to get the difference form ID values?

    Thanks,

    Scott


    Scott Heim - Microsoft Office InfoPath and SharePoint Designer Online Community Support

    Mittwoch, 7. März 2012 16:18