none
Default Policy not applying

    Frage

  • Hi All

    My Default email address policy is not applying.

    Upgraded from 2003 -> 2007,

    Have upgraded email address policy and address lists as per this article:
    http://www.fots.nl/index.php/archive/update-legacy-email-address-policies-and-address-lists/

    If I edit the default policy I am unable to change any settings, however it does allow me to add email addresses, click next and schedule to apply immediately, next, next..

    I then get this error:
    --------------------------------------------------------------
    Summary: 2 item(s). 0 succeeded, 1 failed.
    Elapsed time: 00:00:00


    Edit Default Policy
    Failed

    Error:
    The operation cannot be completed on the default e-mail address policy.

    Exchange Management Shell command attempted:
    set-EmailAddressPolicy -Instance 'Default Policy'

    Elapsed Time: 00:00:00


    Apply Default Policy
    Cancelled
    --------------------------------------------------------------

    and the changes I have made, such as adding a email address do not apply and are not saved in the policy, IE: Are not there when I edit the policy again.


    The policy is also not automatically applying to new users, and so I have to manually add email addresses to there accounts, which then work ..

    If I run:
    set-EmailAddressPolicy -Instance 'Default Policy'

    in powershell I get the below

    ---------------------------------------------------------------

    [PS] C:\Windows\system32>set-EmailAddressPolicy -Instance 'Default Policy'
    Set-EmailAddressPolicy : Cannot bind parameter 'Instance'. Cannot convert the "Default Policy" valu
    e of type "System.String" to type "Microsoft.Exchange.Data.Directory.SystemConfiguration.EmailAddre
    ssPolicy".
    At line:1 char:33
    + set-EmailAddressPolicy -Instance <<<< 'Default Policy'
    + CategoryInfo : InvalidArgument: (:) [Set-EmailAddressPolicy], ParameterBindingExcep
    tion
    + FullyQualifiedErrorId : CannotConvertArgumentNoMessage,Microsoft.Exchange.Management.SystemC
    onfigurationTasks.SetEmailAddressPolicy


    ---------------------------------------------------------------

    If I Apply the policy i get

    -------------------------------------------------------------------

    Summary: 1 item(s). 1 succeeded, 0 failed.
    Elapsed time: 00:00:02


    Apply Default Policy
    Completed

    Exchange Management Shell command completed:
    update-EmailAddressPolicy -Identity 'Default Policy'

    Elapsed Time: 00:00:02

     ----------------------------------------------------------------------

    However the policy  still does not apply to new users (or old)..

    any ideas??

    Many Thanks

    Steve

    Montag, 20. Februar 2012 12:34

Antworten

Alle Antworten

  • Forgot to say.. If I run 'Set-EmailAddressPolicy "Default Policy" -IncludedRecipients AllRecipients' I get this

    [PS] C:\temp>Set-EmailAddressPolicy "Default Policy" -IncludedRecipients AllRecipients

    Set-EmailAddressPolicy : The operation cannot be completed on the default e-mail address policy.
    At line:1 char:23
    + Set-EmailAddressPolicy <<<<  "Default Policy" -IncludedRecipients AllRecipients
        + CategoryInfo          : InvalidOperation: (Default Policy:ADObjectId) [Set-EmailAddressPolic
       y], InvalidOperationException
        + FullyQualifiedErrorId : 77E2CDDB,Microsoft.Exchange.Management.SystemConfigurationTasks.SetE
       mailAddressPolicy

    Montag, 20. Februar 2012 13:10
  • Hi dreams3577,

    If you run the 'Set-EmailAddressPolicy "Default Policy" -IncludedRecipients AllRecipients' second time, the cmdlet will fail.

    Please run the following cmdlet and post the result here.

    Get-EmailAddressPolicy | Format-List Name,*RecipientFilter*,ExchangeVersion

    By the way, I found you asked the same question ago:

    Default Policy not applying

    http://social.technet.microsoft.com/Forums/en-US/exchangesvrtransport/thread/14c4d6a7-42a6-4c72-b84e-3eddd1654f3c


    Frank Wang

    TechNet Community Support

    • Als Antwort markiert Frank.Wang Montag, 27. Februar 2012 02:10
    Dienstag, 21. Februar 2012 08:37
  • Hi dreams3577,

    Any updates?


    Frank Wang

    TechNet Community Support

    Donnerstag, 23. Februar 2012 03:27