none
Trusted Connection deaktivieren

    Frage

  • Hallo @all!

    vorab: Ich bin ein absoluter Laie mit SQL! :-)

    Also, ich möchte den BCM vom Outlook 2010 auf 3 PC's nutzen. Die Freigabe der Datenbank klappt überhaupt nicht. Es kommt immer die Meldung, dass auf dem Computer XXX keine freigegebene Datenbank vorhanden ist. Hab ich also mal Google befragt, mir das SQL Management Studio 2008 R2 installiert und nun hänge ich.

    Mit zwei Dingen komme ich nicht weiter:

    1.

    In Tabelle dbo.Orgtable Spalte LocaleID soll der Wert für die Sprache auf de-DE geändert werden. Ich finde aber kein Feld, wo ich das eingeben könnte. Wie macht man das?

    2.

    Ich habe mir mal die Protokolle angeschaut. Da tauchen 2 Probleme während der Verbindung auf:

    "SSPI handshake failed with error code 0x8009030c while establishing a connection with integrated security; the connection has been closed. [CLIENT: 192.168.178.6]"

    "Login failed. The login is from an untrusted domain and cannot be used with Windows authentication. [CLIENT: 192.168.178.6]"

    Ich habe mir schon die Finger wund gesucht, aber nichts gefunden, mit dem ich als Laie etwas anfangen könnte.

    Situation mit den PC's:

    PC A hat die Datenbank, Win 7 Prof, Outlook 2010, Freigabe über BCM-Datenbanktool.

    PC B soll Zugriff bekommen, Win 8 Prof, Outlook 2010, Zugriff auf PC A über Netzwerk und RDP möglich

    PC C soll Zugriff bekommen, Win 7 Prof, Outlook 2010, Zugriff auf PC A über Netzwerk und RDP möglich

    (alle in einer Heimnetzgruppe, A + B sind in einer Arbeitsgruppe, C ist in einer anderen Domäne)

    Bisher habe ich probiert:

    - alle Firewalls aus

    - Freigabe über Studio für alle Heimnetzgruppenuser

    - SQL-Anmeldung auf Mischmodus

    Bitte HILFE. Danke Euch!!!

    Jens

    Samstag, 26. Januar 2013 18:17

Antworten

  • Okay, also nach ewigem googeln und abwägen aller Pro´s und Kontra´s habe ich kurzerhand folgenden Weg beschritten:

    Auf dem Windows 8 PC das LIVE-Konto in ein lokales Konto geändert. Und schon klappt alles. Ich hoffe doch sehr, das Microsoft irgendwann die Anmeldung mit einer LiveID an einem SQL Server ermöglichen wird.

    Übrigends ist tatsächlich das Problem, dass derzeit die Anmeldung mit einer LiveID an einer SQL-Datenbank nicht vorgesehen ist - so zumindest die Aussagen von MS-Mitarbeitern in einigen Foren.
    Finde ich sehr traurig. Windows 8 wird auf den Markt geworfen und damit auch die Möglichkeit, seine LiveID als Benutzer zu verwenden, was ich übrigends echt Klasse finde - und dann sowas.

    Hoffe auf baldige Änderung!!! Solange muss ich eben auf ein wenig Komfort verzichten. :-(

    Danke Euch trotzdem für´s Lesen und Antworten.

    Jens

    • Als Antwort markiert JensMatthey Sonntag, 27. Januar 2013 19:50
    Sonntag, 27. Januar 2013 19:50

Alle Antworten

  • 2.

    Ich habe mir mal die Protokolle angeschaut. Da tauchen 2 Probleme während der Verbindung auf:

    "SSPI handshake failed with error code 0x8009030c while establishing a connection with integrated security; the connection has been closed. [CLIENT: 192.168.178.6]"

    "Login failed. The login is from an untrusted domain and cannot be used with Windows authentication. [CLIENT: 192.168.178.6]"

    [...]

    Situation mit den PC's:

    PC A hat die Datenbank, Win 7 Prof, Outlook 2010, Freigabe über BCM-Datenbanktool.

    PC B soll Zugriff bekommen, Win 8 Prof, Outlook 2010, Zugriff auf PC A über Netzwerk und RDP möglich

    PC C soll Zugriff bekommen, Win 7 Prof, Outlook 2010, Zugriff auf PC A über Netzwerk und RDP möglich

    (alle in einer Heimnetzgruppe, A + B sind in einer Arbeitsgruppe, C ist in einer anderen Domäne)


    hallo Jens,

    die Login Fehlermeldung wird dadurch verursacht, dass Deine 3 Computer in unterschiedlichen  Workgruppe/Heimnetzgruppe resp. Domain  sind und Du versuchst mit einem lokalen Account des einen Computers auf die DB auf einem anderen Computer zu zugreifen.

    Da die Computer nicht in der gleichen Domain sind, kannst Du nicht mit dem Account von Computer 1 auf Computer 2 zugreifen ausser Du hast sogenannte Shadow Accounts eingerichtet.

    Du koenntest alle 3 Computer & Accounts in die gleiche Domain verschieben, dann sollte der Zugriff auf die DB klappen sofern die Domain Accounts Zugriff auf die DB haben

    oder Du erstellst Shadow Accounts auf dem Computer welcher die DB enthaelt und erlaubst diesen den Zugriff auf die DB.

    Da BCM defaultmaessig SQL Express installiert und diese ebenfalls defaultmaessig keine Remote Verbindung zu laesst, musst Du noch die Option "Allow Remote Connection" auf der SQL Server Instanz des BCM setzen

    Starte dazu SSMS, verbinde zur BCM DB Server, oeffne den Eigenschaftsdialog fuer den SQL Server und schalte "Allow Remote connection" ein.

    Ueberdies empfehle ich Dir den Artikel http://office.microsoft.com/en-us/outlook-help/manage-your-business-contact-manager-database-on-a-server-HA101810395.aspx zu lesen- er beschreibt wie BCM geshared werden kann.


    Please use Mark as Answer if my post solved your problem and use Vote As Helpful if a post was useful.



    Samstag, 26. Januar 2013 21:20
  • Danke Daniel,

    den Artikel von MS kannte ich schon.

    Ich glaube es liegt an etwas anderem. PC A+B sind ja schon in einer gemeinsamen Arbeitsgruppe. Die Domäne von PC C kann ich nicht ändern, weil es ein Firmenlaptop ist und ich sonst keine Zugriffe in der Firma mehr habe.

    Ich habe aber mal ausprobiert und auf PC B einen neuen Benutzer (lokales Konto) angelegt. Diesen Benutzer habe ich mit dem BCM Datenbanktool freigegeben. Und schon klappt es ohne irgendwas anderes ändern zu müssen.

    Der normale Benutzer auf PC B ist ein WindowsLive-Konto. Hier ist m.E. das Problem. Der Name des Kontos scheint wohl irgendwie mit der Domäne "live.de" verknüpft zu sein. An manchen Stellen steht auch die Domäne "MicrosoftAccount". Meine Live-Kennung lautet aaa.bbb@live.de. In den Benutzerkonten heißt der Benutzer aber "Vorname Nachname". Und genau dieser Benutzer ist auch auf PC A angelegt. Die Passwörter sind identisch. Testweise habe ich den Benutzer "aaa.bbb" mit dem Datenbanktool freiegegeben. Ohne Erfolg.

    PC C kann ich momentan leider nicht testen.

    Hat jemand eine Idee? Ich kann ja nirgends die Domäne zusammen mit dem Benutzer eintragen - unzulässige Zeichen.

    Achso, wie lege ich Shadow Accounts an? Google hat mir nicht geholfen...

    Danke Euch

    Jens

    Sonntag, 27. Januar 2013 12:52
  • Okay, also nach ewigem googeln und abwägen aller Pro´s und Kontra´s habe ich kurzerhand folgenden Weg beschritten:

    Auf dem Windows 8 PC das LIVE-Konto in ein lokales Konto geändert. Und schon klappt alles. Ich hoffe doch sehr, das Microsoft irgendwann die Anmeldung mit einer LiveID an einem SQL Server ermöglichen wird.

    Übrigends ist tatsächlich das Problem, dass derzeit die Anmeldung mit einer LiveID an einer SQL-Datenbank nicht vorgesehen ist - so zumindest die Aussagen von MS-Mitarbeitern in einigen Foren.
    Finde ich sehr traurig. Windows 8 wird auf den Markt geworfen und damit auch die Möglichkeit, seine LiveID als Benutzer zu verwenden, was ich übrigends echt Klasse finde - und dann sowas.

    Hoffe auf baldige Änderung!!! Solange muss ich eben auf ein wenig Komfort verzichten. :-(

    Danke Euch trotzdem für´s Lesen und Antworten.

    Jens

    • Als Antwort markiert JensMatthey Sonntag, 27. Januar 2013 19:50
    Sonntag, 27. Januar 2013 19:50