none
DNS Aussetzer

    Frage

  • Hi Community,

    wir haben im November einen neuen W2K8R2 DC in betrieb genommen und in diesem Zusammenhang den DNS ins AD integriert. Seitdem haben wir sporadische Aussetzer in der Namensauflösung, was uA dadurch auswirkt, dass diverse Webseiten plötzlich nicht mehr gefunden werden oder nur zT geladen werden oder zB Entourage 2008 die Verbindung zum Exchange Server verliert. Zwei, drei Minuten später ist der Spuk wieder vorbei und alles funktioniert so, wie es sein soll. Die Logfiles der DNS Server sind diesbzgl. unauffällig...

    ...was kann ich tun, um die Sache weiter einzugrenzen?

    Thx & Bye Tom

    Mittwoch, 23. Januar 2013 12:51

Alle Antworten

  • Network-Trace sowohl auf dem betroffenen Client und dem Ziel-DNS Server erstellen und die Netzwerkpakete und deren Laufzeiten auf Auffälligkeiten hin untersuchen. Dazu die Debug-Options in den DNS-Logfile aktivieren und analysieren:

    Using server debug logging options
    http://technet.microsoft.com/en-us/library/cc776361.aspx

    Meine Vermutung: Eine Komponenten zwischen dem Client und dem DNS-Dienst (also Router, Firewall, Netzwerk- bzw. Filter-Treiber, AntiMaleware-Software usw.) verschluckt sich hin und wieder.

    --

    Tobias Redelberger
    StarNET Services (HomeOffice)
    Frankfurter Allee 193
    D-10365 Berlin
    Tel: +49 (30) 86 87 02 678
    Mobil: +49 (163) 84 74 421
    Mittwoch, 23. Januar 2013 13:28
  • Servus,

    das kann jeder Client sein, da gibt es keine speziellen Kandidaten. Die Netzwerktrace Geschichte wird recht aufwändig werden aber wenn es sich nicht vermeiden lässt, werde ich das wohl auch noch machen. Ich habe jetzt mal noch woanders nachgefragt und der Kollege meinte, die IPv6 Adresse als abzuhörende Adresse aus der DNS Konfiguration zu nehmen. Das habe ich jetzt mal gemacht und schaue wie sich das ganze danach verhält.

    Thx & Bye Tom

    Mittwoch, 23. Januar 2013 14:23
  • Servus,

    scheint noch aktuell sein. Irgendwas scheint noch nicht zu stimmen. Von den Entourage Aussetzern habe ich erst mal nichts mehr gehört aber das (Web-) Seitenladeproblem habe ich immer noch...

    Thx & Bye Tom

    Samstag, 26. Januar 2013 12:30
  • Deswegen:

    Network-Trace sowohl auf dem betroffenen Client und dem Ziel-DNS Server erstellen und die Netzwerkpakete und deren Laufzeiten auf Auffälligkeiten hin untersuchen. Dazu die Debug-Options in den DNS-Logfile aktivieren und analysieren:

    Using server debug logging options
    http://technet.microsoft.com/en-us/library/cc776361.aspx

    Meine Vermutung: Eine Komponenten zwischen dem Client und dem DNS-Dienst (also Router, Firewall, Netzwerk- bzw. Filter-Treiber, AntiMaleware-Software usw.) verschluckt sich hin und wieder.

    --

    Tobias Redelberger
    StarNET Services (HomeOffice)
    Frankfurter Allee 193
    D-10365 Berlin
    Tel: +49 (30) 86 87 02 678
    Mobil: +49 (163) 84 74 421
    Montag, 28. Januar 2013 09:32
  • Servus,

    so komisch es auch klingen mag aber es könnten in der Tat mehrere Probleme sein. Das Problem mit den Entourages, welche die Verbindung verlieren, scheint sich wohl erledigt zu haben. Das war definitiv ein DNS Problem, weil zum Zeitpunkt wo keine Verbindung bestand auch eine nslookup Abfrage ins Leere gelaufen ist.

    Die Geschichte mit den Seitenladeproblemen könnte aber durchaus, wie du bereits angemerkt hast, ein Peripherie Problem sein. Wir hatten vor drei Wochen ein Problem im TMG, der hatte seine Arbeit mit einem Fehler 500 [1] eingestellt. Ein Neustart hat das dann wieder gerade gebogen aber evtl. sollte ich das vermeintlich gelöste Problem noch mal neu bewerten.

    [1] Kein Pufferspeicher unterstützt. Die WinSock Implementierung konnte keinen zusätzlichen Arbeitsspeícher für die Funktionsanweisung zuweisen (10055)

    Thx & Bye Tom

    Montag, 28. Januar 2013 10:18
  • Hallo Thomas,

    Sie dir mal den genauen DNS Chart von Extern an, löst der Server zu einer Zeiteinheit den DNS namen anders auf und verliert vermutlich daher kurz die Verbindung. Den genauen DNS Chart kannst Du über die DNS ToolBox live analysieren.

    Liebe Grüße aus Wien,

    Andreas


    • Bearbeitet netvance Donnerstag, 13. Juni 2013 08:27
    Donnerstag, 13. Juni 2013 08:26
  • Hallo,

    hast Du schonmal mit EDNS 0 getestet? http://support.microsoft.com/kb/832223 http://weblogs.asp.net/owscott/archive/2009/09/15/windows-server-2008-r2-dns-issues.aspx


    Best regards

    Meinolf Weber
    MVP, MCP, MCTS
    Microsoft MVP - Directory Services
    My Blog: http://msmvps.com/blogs/mweber/

    Disclaimer: This posting is provided AS IS with no warranties or guarantees and confers no rights.

    Donnerstag, 13. Juni 2013 09:24
  • Falls Du es nicht sowieso schon so gemacht hast, könnte ein scheduled job, der den dnscache regelmäßig leert, abhilfe schaffen. manchmal bleibt ein nicht erfolgreicher lookup im cache als "gibts nicht" hängen, was dann zu solchen problem führen kann. Zwar banal, aber schon oft gehört. ;)

    Stephan Ertel - MCITP/MCSA -

    Dienstag, 13. August 2013 10:33
  • Servus,

    wir haben den Fehler (bzw. das Problem) schon gefunden. Wir haben hier eine Bintec als Borderrouter stehen, welcher zugleich das Weiterleitungsziel des DC DNS ist. Mit Inbetriebnahme des ersten W2K8R2 DC ging das Problem los und eskalierte mit Inbetriebnahme des zweiten und zugleicher Abschaltung des letzten W2K3 DC.

    Offensichtlich vertragen sich die beiden nicht. Wir haben dann an den DCs einen externen DNS eingerichtet und eine bedingte Weiterleitung aller internen FQDNs auf die Bintec eingerichtet. Seitdem sind wir dieses (und noch andere) Probleme wieder los. Solange wir die Bintec als äußeren Router haben (ein TMG steht noch als interner Router in die DMZ da) müssen wir dieses Provisorium beibehalten. Mal schauen ob wir die Bintec gegen was moderneres tauschen können. Einen TMG möchte ich aber auf keinen Fall als äußeren Router verwenden.

    Thx & Bye Tom

    Dienstag, 13. August 2013 13:18