none
Exchange 2010 Datenbankfehler

    Frage

  • Hallo,
    ich habe gestern folgende Fehler auf meinem Exchange 2010 MB Server erhalten:

    Protokollname: Application
    Quelle:        ESE
    Datum:         25.01.2013 20:02:03
    Ereignis-ID:   508
    Aufgabenkategorie:Leistung
    Ebene:         Warnung
    Schlüsselwörter:Klassisch
    Benutzer:      Nicht zutreffend
    Computer:      W8KNKN01.schaefernk.local
    Beschreibung:
    Information Store (5496) MB01-W8KNKN01: Eine Anforderung für das Schreiben in die Datei "D:\Exchange Server\V14\Mailbox\MB01\Log\E00.log" bei Offset 99328 (0x0000000000018400) von 4096 (0x00001000) Bytes war erfolgreich, aber die Bearbeitung durch das Betriebssystem dauerte sehr lange (42 Sekunden). Dieses Problem wurde wahrscheinlich durch fehlerhafte Hardware verursacht. Wenden Sie sich an den Hardwarehersteller, um Hilfe bei der Problemdiagnose zu erhalten.

    Weitere Informationen erhalten Sie unter http://www.microsoft.com/contentredirect.asp.
    Ereignis-XML:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="ESE" />
        <EventID Qualifiers="0">508</EventID>
        <Level>3</Level>
        <Task>7</Task>
        <Keywords>0x80000000000000</Keywords>
        <TimeCreated SystemTime="2013-01-25T19:02:03.000000000Z" />
        <EventRecordID>836095</EventRecordID>
        <Channel>Application</Channel>
        <Computer>W8KNKN01.schaefernk.local</Computer>
        <Security />
      </System>
      <EventData>
        <Data>Information Store</Data>
        <Data>5496</Data>
        <Data>MB01-W8KNKN01: </Data>
        <Data>D:\Exchange Server\V14\Mailbox\MB01\Log\E00.log</Data>
        <Data>99328 (0x0000000000018400)</Data>
        <Data>4096 (0x00001000)</Data>
        <Data>42</Data>
      </EventData>
    </Event>

    Protokollname: Application
    Quelle:        ExchangeStoreDB
    Datum:         25.01.2013 20:02:03
    Ereignis-ID:   218
    Aufgabenkategorie:Database recovery
    Ebene:         Fehler
    Schlüsselwörter:Klassisch
    Benutzer:      Nicht zutreffend
    Computer:      W8KNKN01.schaefernk.local
    Beschreibung:
    25.01.2013 20:02:03: Für die Kopie der Datenbank 'MB01-W8KNKN01' auf diesem Server ist ein Leistungsproblem aufgetreten. Der Failover hat den Fehler 'Es ist nur eine Kopie der Postfachdatenbank (MB01-W8KNKN01) vorhanden. Es ist keine automatische Wiederherstellung verfügbar.' zurückgegeben. Überprüfen Sie das Ereignisprotokoll auf dem Server hinsichtlich anderer Speicher- und "ExchangeStoreDb"-Ereignisse, um detailliertere Informationen zu dem Fehler zu erhalten.
    Ereignis-XML:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="ExchangeStoreDB" />
        <EventID Qualifiers="49156">218</EventID>
        <Level>2</Level>
        <Task>1</Task>
        <Keywords>0x80000000000000</Keywords>
        <TimeCreated SystemTime="2013-01-25T19:02:03.000000000Z" />
        <EventRecordID>836097</EventRecordID>
        <Channel>Application</Channel>
        <Computer>W8KNKN01.schaefernk.local</Computer>
        <Security />
      </System>
      <EventData>
        <Data>MB01-W8KNKN01</Data>
        <Data>71cdf70e-191f-433e-bb19-529bf361401b</Data>
        <Data>Ese</Data>
        <Data>Performance</Data>
        <Data>MB01-W8KNKN01</Data>
        <Data>
        </Data>
        <Data>Es ist nur eine Kopie der Postfachdatenbank (MB01-W8KNKN01) vorhanden. Es ist keine automatische Wiederherstellung verfügbar.</Data>
        <Data>25.01.2013 20:02:03</Data>
        <Data>Write</Data>
        <Data>D:\Exchange Server\V14\Mailbox\MB01\Log\E00.log</Data>
        <Data>99328</Data>
        <Data>4096</Data>
      </EventData>
    </Event>

    Protokollname: Application
    Quelle:        ESE
    Datum:         25.01.2013 20:03:35
    Ereignis-ID:   531
    Aufgabenkategorie:Datenbankbeschädigung
    Ebene:         Warnung
    Schlüsselwörter:Klassisch
    Benutzer:      Nicht zutreffend
    Computer:      W8KNKN01.schaefernk.local
    Beschreibung:
    Information Store (5496) Das Datenbankmodul hat versucht, einen bereinigenden Schreibvorgang für die Seite 2719411 der Datenbank 'D:\Exchange Server\V14\Mailbox\MB01\MB01W8KNKN01.edb' auszuführen. Auf diese Weise sollte ein vorheriges Problem behoben werden, das beim Lesen der Seite aufgetreten ist.

    Weitere Informationen finden Sie unter 'http://www.microsoft.com/contentredirect.asp'.
    Ereignis-XML:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="ESE" />
        <EventID Qualifiers="0">531</EventID>
        <Level>3</Level>
        <Task>12</Task>
        <Keywords>0x80000000000000</Keywords>
        <TimeCreated SystemTime="2013-01-25T19:03:35.000000000Z" />
        <EventRecordID>836106</EventRecordID>
        <Channel>Application</Channel>
        <Computer>W8KNKN01.schaefernk.local</Computer>
        <Security />
      </System>
      <EventData>
        <Data>Information Store</Data>
        <Data>5496</Data>
        <Data>
        </Data>
        <Data>2719411</Data>
        <Data>D:\Exchange Server\V14\Mailbox\MB01\MB01W8KNKN01.edb</Data>
      </EventData>
    </Event>

    Protokollname: Application
    Quelle:        ESE
    Datum:         25.01.2013 20:03:23
    Ereignis-ID:   533
    Aufgabenkategorie:General
    Ebene:         Warnung
    Schlüsselwörter:Klassisch
    Benutzer:      Nicht zutreffend
    Computer:      W8KNKN01.schaefernk.local
    Beschreibung:
    Information Store (5496) MB01-W8KNKN01: Eine Anforderung zum Schreiben in die Datei "D:\Exchange Server\V14\Mailbox\MB01\MB01W8KNKN01.edb" bei Offset 89109626880 (0x00000014bf590000) von 262144 (0x00040000) Byte wurde 68 Sekunde(n) lang nicht abgeschlossen. Dieses Problem wird wahrscheinlich durch fehlerhafte Hardware verursacht. Wenden Sie sich an den Hardwarehersteller, um Hilfe bei der Problemdiagnose zu erhalten

    Weitere Informationen finden Sie unter 'http://www.microsoft.com/contentredirect.asp'.
    Ereignis-XML:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="ESE" />
        <EventID Qualifiers="0">533</EventID>
        <Level>3</Level>
        <Task>1</Task>
        <Keywords>0x80000000000000</Keywords>
        <TimeCreated SystemTime="2013-01-25T19:03:23.000000000Z" />
        <EventRecordID>836102</EventRecordID>
        <Channel>Application</Channel>
        <Computer>W8KNKN01.schaefernk.local</Computer>
        <Security />
      </System>
      <EventData>
        <Data>Information Store</Data>
        <Data>5496</Data>
        <Data>MB01-W8KNKN01: </Data>
        <Data>D:\Exchange Server\V14\Mailbox\MB01\MB01W8KNKN01.edb</Data>
        <Data>89109626880 (0x00000014bf590000)</Data>
        <Data>262144 (0x00040000)</Data>
        <Data>68</Data>
      </EventData>
    </Event>

    Der Postfächer war da auch für ca. 30 Minuten nicht mehr erreichbar.
    Die Meldungen hören nach ca. 2 Stunden auf.
    Zu dieser Zeit läuft eine Sicherung via ArcServe Backup Agent.
    Die Meldungen sehe ich das erste mal.

    Kann mir jemand sagen was zu tun ist?

    Danke
    Dennis

    Samstag, 26. Januar 2013 10:35

Alle Antworten

  • Hört sich nach Storage Problemen an. Cache und BBU des Raid Controllers ok? Oder Probleme mit dem SAN? Gruß Jörg
    Samstag, 26. Januar 2013 23:34
  • Hallo,

    das ganze ist ziemlich interessant, mir wurden ähnliche Probleme in völlig verschiedenen Umgebungen berichtet.

    Bei einem Kunden - der sichert mit Veeam - ist das nachweislich erst seit dem RU5v2.

    Mit RU4 war das nicht.

    Habt ihr schon einen Case bei MS oder ArcServ aufgemacht?

    :-o


    Gruß Norbert

    Sonntag, 27. Januar 2013 11:43
  • Storage hat scheinbar keine Probs.
    Werde das jetzt mal weiter beobachten bevor ich einen Call aufmache.
    RU5v2 wurde vor kurzem eingespielt.
    Montag, 28. Januar 2013 09:38
  • Hallo Dennis,

    die Fehlermeldungen sagen hier ja schon das irgendwas mit dem Storage zu dem Zeitpunkt nicht so lief, wie es hätte sein sollen. Kannst Du uns mehr zu Deiner Storage Konfiguration verraten? Ist das ein virtueller oder physiklischer Server, lokaler Storage oder SAN, welche RAID Konfiguration, wie viele Postfächer, etc.?

    Viele Grüße

    Timo

    Montag, 28. Januar 2013 20:20
    Moderator
  • Hallo,
    ist ein virt. Server unter Server 2008 R2 mit Exchange 2010 SP2, RUP5.
    Partition C:\ (System und Programme) in einem Raid 6, Partition D:\ (DB) in einem Raid 10.
    C:\ und D:\ liegen in einem SAN.
    Postfächer ca. 400.

    Hab eben nochmal die Logs gecheckt.
    Bisher nicht mehr solche Fehler gehabt.

    Dienstag, 29. Januar 2013 10:01