none
WinRM aus einer anderen Domain

    Frage

  • Hallo,

    wir haben grade in unserer Testdomäne unsere ersten drei Windows 2012 Server installiert. Nun versuche ich per ServerManager diese per WinRM zu verwalten. Über DNS finde ich meine Server und binde sie ein. Natürlich schlägt zunächst die Authentifizierung fehl, also "verwalten als" angeklickt und als Admin der Domäne authentifiziert. Danach kann ich die Server problemlos verwalten. Wenn ich aber am nächsten Morgen den ServerManager öffne, empfängt mich das Dashboard mit der Meldung "Verwaltbarkeit" in rot.  Die Meldung für alle drei Server lautet "Fehler bei Kerberos-Authentifizierung". Die detaillierte Meldung spricht davon, das die Metadaten nicht abgerufen werden konnten, weil der WinRM Dienst die Anforderung nicht verarbeiten konnte. Als Ursache wird ein falscher Benutzername oder Passwort genannt. Weiter steht dort das Kerberos nur verwendet wird, wenn kein Benutzername oder Passwort angegeben wurde. Da am Tag zuvor ja alles funktionierte (ich habe auch das Häckhen bei "Anmeldedaten speichern" gesetzt) wundert mich das Ganze doch ein wenig.
    An welcher Stelle mache vermutlich ich einen Fehler ?
    Vielen Dank im voraus.

    MfG

    Sven 

    Freitag, 30. November 2012 07:57

Alle Antworten

  • Joar, ich würd sagen, du bist schlicht nicht Authentifiziert. Die zu managenden Server wieder löschen (evtl. noch rechner neustarten??, maybe) und neu anfügen... Also eine Vertrauensstellung ist unbedingt erforderlich im AD. Es gibt noch einen Weg, dass sich Computer Manuell gegenseitig vertrauen.

    Google mal nach: winrm trusted Hosts   (funzt aber eher, naja) - oder ne AD-Vertrauensstellung, wenn dein Management unbedingt außerhalb der zu managenden Struktur sein soll.

    Grüße


    Stephan Ertel - MCITP/MCSA -

    Samstag, 26. Januar 2013 08:34