none
Outlook keeps asking for password on exchange account

    Question

  • Hello:

    I have a Small Business Server 2011 standard running exchange 2010 with clients using Outlook 2007 and 2010 on both XP and Win 7. The issue is that when outlook is first opened a Windows Security window pops up trying to connect to the end users Email address and it is asking for the user name and password, it is pre-populated with the end users Email address. in order to get the window to close and Outlook to send and receive, you must change the user name to their windows account name, enter the password, and check remember my credentials box. In looking at the account settings the box to use HTTP for outlook Anywhere is checked, and if you uncheck it, it always gets rechecked after you close and open outlook. I know this is the culprit, because if i change the proxy settings, i receive an error message once the credentials are entered. Since these PC's never leave the office, I do not want them to use HTTP, how can this setting be turned off Permanently?

    I should add that this is occurring at three separate clients with Small Business Server 2011, I have a client with just exchange 2010 and this is not an issue there.

    Any help would be greatly appreciated

    Monday, November 21, 2011 7:27 PM

Answers

  • Hi,

     

    From the problem description, I understand that you would like to disable checking “Connect to Microsoft Exchange using HTTP” since the PCs never leave the office.

     

    Generally, we could disable this option on the internal Outlook client by Group Policy, please download the GPO file from the following link of KB 961112.


    http://download.microsoft.com/download/F/B/C/FBC43645-89EA-4FB4-828C-DFE27C360233/article-961112.adm

     

    After adding the GPO template (article-961112.adm) to the group policy object editor:

     

    ·         Browse to “Article 961112 Policy Settings” | “Outlook Anywhere (RPC/HTTP)

    ·         Open the “RPC/HTTP Connection flags”.

    ·         Choose “Enabled”, select “No flags” from the drop-down box, “Apply” and “Ok” your way out from the GPO.

    ·         Test Microsoft Outlook; "Connect to Microsoft Exchange using HTTP" should now be disabled/Grayed out, and the checkbox should be unchecked.

     

    For more detailed information, please refer to the KB 961112:

     

    Title: You cannot use Group Policy settings to configure Outlook Anywhere (RPC/HTTP) settings

    URL: http://support.microsoft.com/kb/961112

     

    Regards,

    James
    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Wednesday, November 23, 2011 9:34 AM
    Moderator

All replies

  • To do a test, try creating a new profile using the mail control panel item. Create the profile, add the exchange account and load up this new profile. See if the same thing happens. If it's constantly resetting your Outlook info, then it's the configuration of Exchange.
    Monday, November 21, 2011 9:30 PM
  • I have already tried that, I think it is a policy setting from SBS, I am just not able to find the particular setting to change it, hoping someone on here has ran in to this before.

    Monday, November 21, 2011 10:17 PM
  • I'm pretty sure it's Exchange that configures this. Someone will need to confirm though. We had the same issue with our Exchange which isn't part of SBS. 
    Monday, November 21, 2011 11:01 PM
  • Check settings according to following blog post:

    http://blogs.technet.com/b/sbs/archive/2010/08/19/a-guide-to-troubleshooting-outlook-certificate-warnings-authentication-prompts-in-sbs-2008.aspx

    [SSL settings and authentication settings]

     

    Then install latest Update Rollup for Exchange 2010 SP1:

    http://www.microsoft.com/download/en/details.aspx?id=27849

     

    Then restart exchange service's.

     

    Monday, November 21, 2011 11:12 PM
  • By default you should not be getting a password prompt.  The very first thing to check is if you have your Outlook in RPC / HTTPS Mode - Connect on Fast link.  Make sure that is not enabled. 

    Next right click on the outlook icon by the clock, and choose "test email autoconfiguration" Unchck "use guesssmart" and run the test. You should not get any errors here.

    As this is an SBS server, you can re-run the "connect to internet" and "set up your internet address" wizard.  Most likely these two wizards will fix your issue. 

     


    Jeremy
    Tuesday, November 22, 2011 7:09 AM
  • Hi,

     

    From the problem description, I understand that you would like to disable checking “Connect to Microsoft Exchange using HTTP” since the PCs never leave the office.

     

    Generally, we could disable this option on the internal Outlook client by Group Policy, please download the GPO file from the following link of KB 961112.


    http://download.microsoft.com/download/F/B/C/FBC43645-89EA-4FB4-828C-DFE27C360233/article-961112.adm

     

    After adding the GPO template (article-961112.adm) to the group policy object editor:

     

    ·         Browse to “Article 961112 Policy Settings” | “Outlook Anywhere (RPC/HTTP)

    ·         Open the “RPC/HTTP Connection flags”.

    ·         Choose “Enabled”, select “No flags” from the drop-down box, “Apply” and “Ok” your way out from the GPO.

    ·         Test Microsoft Outlook; "Connect to Microsoft Exchange using HTTP" should now be disabled/Grayed out, and the checkbox should be unchecked.

     

    For more detailed information, please refer to the KB 961112:

     

    Title: You cannot use Group Policy settings to configure Outlook Anywhere (RPC/HTTP) settings

    URL: http://support.microsoft.com/kb/961112

     

    Regards,

    James
    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Wednesday, November 23, 2011 9:34 AM
    Moderator
  • Hi,

    Any Update?

    James


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Sunday, November 27, 2011 11:34 AM
    Moderator