none
SharePoint 2013 - Event 5187

    Question

  • Hi,

    if i try to create a MySite i get following Error:

    My Site creation failure for user 'XY\SY' for site url 'http://sharepoint.foo.bar.net:7777/my/Domain_User'. The exception was: Microsoft.Office.Server.UserProfiles.PersonalSiteCreateException: A failure was encountered while attempting to create the site. ---> Microsoft.SharePoint.SPException: Failed to compare two elements in the array. ---> System.Runtime.InteropServices.COMException: <nativehr>0x8107058a</nativehr><nativestack></nativestack>Failed to compare two elements in the array.

    After a "gooogle-Session" i found:

    MSDN

    and villpates.blogspot.de

    Nothing helps ....

    FeatureAdmin Tool (2.3) - No Faulty Feature was found in the farm!

    Active Features:

    And i get:

    I don't use customized code anywhere.

    Re-installation don't solve the problem.

    I'm frustrated ....

    Tuesday, September 10, 2013 9:30 AM

Answers

  • Hi,

    I agree with you. Generally, the issue can be caused by some broken features. Also, I would verify if the issue only happens on certain user accounts.  

    If no progress, post the SharePoint ULS logs for further research.

    Thanks.


    Tracy Cai
    TechNet Community Support

    Thursday, September 12, 2013 3:26 AM
    Moderator

All replies

  • Hi again,

    i think it is possible that a MySite Feature is broken at my SharePoint.

    Now i try to reinstall the howl system. Maybe it helps.

    Tuesday, September 10, 2013 1:09 PM
  • Hi,

    I agree with you. Generally, the issue can be caused by some broken features. Also, I would verify if the issue only happens on certain user accounts.  

    If no progress, post the SharePoint ULS logs for further research.

    Thanks.


    Tracy Cai
    TechNet Community Support

    Thursday, September 12, 2013 3:26 AM
    Moderator