none
Deploy an MSI for Terminal server users

    Question

  • Hello,

    I have faced with the issue which I can't resolve on my own - the MSI is not run when the user logs on. Moreover, I don't see the GPO applied in the Group Policy Results for the user:

     

    Here is what I did on the server side:

    1. Created a separate OU for testing (actually, it doesn't work if I apply a policy at the domain level).

    2. Created a test user account.

    3. Created a shared folder (Read for everyone). Made sure that an user can read files from that folder.

    4. Placed the msi file in the shared folder. Before doing that, I tested the installer in the fields running the "msiexec.exe /i /s" command.

    5. Created a new Group Policy object where I added a new software installation at the User Configuration node. I specified the filepath in the following format - \\server\folder\msifile . Assigned. Chose the Install this application at logon. Maximum (User Interface).

    6. Linked the GPO to the OU where the user resides.

    7. The Settings in the GPO apply only for the specified user. Also I checked permissions on the Delegation tab for the user - Read / Apply Group Policy are selected.

    Here is how it looks like:

    Most probably I tried to adjust some properties for troubleshooting. But nothing helped.

    When I logon as a domain user I see that the GPO was applied successfully (gpresult.exe confirms). But I don't see any installation wizard, nor MSI installed. The result is shown on the first screenshot.

    I even don't get any errors in the Group Policy log. I have a feeling that user settings in my GPO are ignored by the system. Why does it happen? Is there any setting I missed setting up a new GPO?

    P.S. I have tried turning on various Group Policy settings located in the Administrative Templates / System / Group Policy.

    Sunday, April 06, 2014 6:37 PM

All replies

  • Hi Eugene,

    Based on your description, to make sure that this is not caused by fast logon optimization feature, we can enable the following setting:
    Computer Configuration\Administrative Templates\System\Logon\ Always wait for the network at computer startup and logon

    After enabling this setting and updating the policy, we can try logging off and logging on again to see if it works.

    Regarding fast logon optimization, the following article can be referred to for more information.

    Description of the Windows Fast Logon Optimization feature

    http://support.microsoft.com/kb/305293/en-us

    Hope it helps.

    Best regards,

    Frank Shen
    Tuesday, April 08, 2014 9:01 AM
    Moderator
  • Hello Frank,

    I have already tried to enable that setting in the domain policy and actually it is enabled now:

    Any thoughts?


    Tuesday, April 08, 2014 3:29 PM