none
The Terminal Services Gateway service has been stopped.

    Question

  • Please help the e-mail is filling up my mailbox. 

    • The problem is similar to The Network Policy Server Service (IAS) Fails to Start or be
    • I have checked the registrey.  The entry is 1.
    • clip_image006
    • The service does seem to be running.  I can login to the owa.
    • This issue started after a virus was cleaned.
    • The IAS service doesn't seem to appear in the services at all.
    • It said it was running in Task Manager.
    • It appears to be fine under the role.
    • Please help me to stop it.  It is driving me crazy. 
    • I do get error 1075 When I try to start the gateway manager.

    Tank you,

    Bonnie


    Bonnie Whalon


    • Edited by bwhalon Friday, February 17, 2012 5:08 AM
    Friday, February 17, 2012 5:04 AM

Answers

  • Did you add the key yet?

    Robert Pearman SBS MVP (2011) | www.titlerequired.com | www.itauthority.co.uk

    • Marked as answer by bwhalon Monday, March 26, 2012 1:28 AM
    • Unmarked as answer by bwhalon Monday, March 26, 2012 1:28 AM
    • Marked as answer by bwhalon Monday, March 26, 2012 1:30 AM
    Thursday, March 08, 2012 9:45 PM

All replies

  • Can you post the exact error you see, or a screen shot of what happens when you start the service?

    Robert Pearman SBS MVP (2011) | www.titlerequired.com | www.itauthority.co.uk

    Friday, February 17, 2012 11:53 AM

  • Bonnie Whalon

    Friday, February 17, 2012 4:47 PM
  • The dependency that does not appear in the service list is IAS. 

    Bonnie Whalon

    Friday, February 17, 2012 4:50 PM
  • IAS Shows up in Services.msc as 'Network Policy Server' - you dont have that?

    Look in REGEDT32 - HKLM>System>Services>CCC>IAS

    Do you have IAS there?

    What errors do you get in the event logs when trying to start the RDP Gateway service?


    Robert Pearman SBS MVP (2011) | www.titlerequired.com | www.itauthority.co.uk

    Saturday, February 18, 2012 8:37 PM
  • I apologize for the delay.  I will log onto the server tomorrow to report the information.  The e-mails are very annoying but I figure as long as I get them I will continure to look for an answer.

    Thank you,

    Bonnie


    Bonnie Whalon

    Friday, February 24, 2012 4:39 AM
  • I looked in regedt32-HKLM>system>

    There was no subheading Services. 


    Bonnie Whalon

    Tuesday, February 28, 2012 12:51 PM
  • Sorry i had it round the wrong way..

    HKLM > SYSTEM > Current Control Set (CCC) > Services


    Robert Pearman SBS MVP (2011) | www.titlerequired.com | www.itauthority.co.uk

    Tuesday, February 28, 2012 1:25 PM
  • There is an IAStore but no IAS

    It appears that Network Services is not installed since the virus.


    Bonnie Whalon

    Tuesday, February 28, 2012 2:03 PM
  •   How do I get it reinstalled??   Can it be there and be hidden? 

    Bonnie Whalon

    Friday, March 02, 2012 3:15 AM
  • Have a look under Current Control Set 1 or 2 and see if you have one there, export that key out to a file, then you can import it into the correct place.

    Once you have exported the key, you will need to edit the .reg file so that when it is imported you import to the correct location.


    Robert Pearman SBS MVP (2011) | www.titlerequired.com | www.itauthority.co.uk

    Friday, March 02, 2012 10:44 AM
  • Thank you, I'll try it in the morning.  Can you tell me how to edit the .reg file?

    Bonnie Whalon

    Monday, March 05, 2012 3:43 AM
  • Hi Robert,

    I looked under Current Control Set 1 and 2 no IAS only IAStor?

    I did see IAS under one of the hexadecmial keys.


    Bonnie Whalon

    Monday, March 05, 2012 10:06 PM
  • I forgot to ask isn't there a patch that I could install or reinstall the service?  This has been going on for a long while, I need to get it resolved.

    Bonnie Whalon

    Monday, March 05, 2012 10:07 PM
  • I would see if you can get a copy of that key from another SBS 2011 server.

    Robert Pearman SBS MVP (2011) | www.titlerequired.com | www.itauthority.co.uk

    Monday, March 05, 2012 10:07 PM
  • Hi ,

    When was it last working , if you can load the software hive from a time when it was working correctly you can export the required registry entry then do the following:-

    1. Export the registry from the loaded hive which has the entry.

    2. Open the exported registry on a notepad.

    3. Correct the path . e.g. it may read as HKLM>SYSTEM> Ccs003 >services > IAS rectify it to current location , like HKLM>SYSTEM>CCS>Services>IAS .

    4. Save the file .

    5. Take a backup of the current services (Just incase anything goes wrong)

    6. Double click on the exported registry and merge the registry.

    This should take care of the issue for you.

    Thanks

    SID

    Wednesday, March 07, 2012 11:44 AM
  • Hi

    I have download the key from another clients server.  Is this key the same on all 2011 SBS servers?

    Thank you for your help.

    Bonnie


    Bonnie Whalon

    Wednesday, March 07, 2012 2:13 PM
  • It should be the same key yes.

    Robert Pearman SBS MVP (2011) | www.titlerequired.com | www.itauthority.co.uk

    Wednesday, March 07, 2012 2:43 PM
  • Thank you,  as soon as I get my nerve up I'm going to try it.   I'm a little nervous.

    Bonnie Whalon

    Wednesday, March 07, 2012 2:52 PM
  • If you import they key, and try to start the service, it will either start, or not.

    If you are worried, run an export of the Registry first.

    You can also do a system state backup or a full server backup before you start.


    Robert Pearman SBS MVP (2011) | www.titlerequired.com | www.itauthority.co.uk

    Wednesday, March 07, 2012 3:25 PM
  • Thank you.  I'll try it.

    Bonnie Whalon

    Wednesday, March 07, 2012 3:31 PM
  • The NPS does not seem to be configured.  I do not see it under services.  I typed Network Policy Services in the Search bar and it came right up.  There are some red x's.

    The Terminal Server Gateway Manager did not start.

    Thank you for your help.


    Bonnie Whalon

    Thursday, March 08, 2012 2:14 AM
  • I would added the key nothing happened.  I was reading something about roles trying to diagnose this problem.  I went into the Server Management and saw NPS was not completely configured.

    I configured it.

    The IAS server has a explanation mark on the IAS Display name Status is not availalbe.  How do add the Display name of the service.


    Bonnie Whalon

    Thursday, March 08, 2012 7:33 PM
  • Did you add the key yet?

    Robert Pearman SBS MVP (2011) | www.titlerequired.com | www.itauthority.co.uk

    • Marked as answer by bwhalon Monday, March 26, 2012 1:28 AM
    • Unmarked as answer by bwhalon Monday, March 26, 2012 1:28 AM
    • Marked as answer by bwhalon Monday, March 26, 2012 1:30 AM
    Thursday, March 08, 2012 9:45 PM