none
Windows Update não atualiza

    Question

  • O windows update do meu windows 7 não executa masi atualizações.

    Quando executo manualmente tenho a seguinte mensagem:

    "O Windows Update não pode procurar atualizações no momento porque o serviço não está em execução. Talvez seja necessário reiniciar o cumputador."

    Acontece que acesso o services e ele está sendo executado em modo automático e o serviço não está parado.

    Alguem pode me ajudar?

    Wednesday, May 23, 2012 3:56 PM

Answers

All replies

  • Não aparece nenhum número de erro? do tipo 0x800e... as vezes aparece, mas já tentou deixar em MANUAL e dar um INICIAR?
    Wednesday, May 23, 2012 4:14 PM
  • Caro Marcos,

    experimente resetar as configurações/componentes do Windows Update usando esse fix da Microsoft.

    http://support.microsoft.com/kb/971058

    []s

    Wednesday, May 23, 2012 5:27 PM
  • O windows update do meu windows 7 não executa masi atualizações.

    Quando executo manualmente tenho a seguinte mensagem:

    "O Windows Update não pode procurar atualizações no momento porque o serviço não está em execução. Talvez seja necessário reiniciar o cumputador."

    Acontece que acesso o services e ele está sendo executado em modo automático e o serviço não está parado.

    Alguem pode me ajudar?

    Caro Marco,

    exatamente o mesmo problema que estou tendo. Ja tentei a dica do professor Akira abaixo, sem resultados.

    O windows update esta "congelado".

    Murilo

    Wednesday, May 30, 2012 2:40 AM
  • Cara,

    Eu passei por esse mesmo problema em um computador de um amigo e resolvi verificando os logs do sistema (cultura adquirida por ser um usuário Linux). Ao consultar esses logs vi a msg abaixo:

    wuaueng.dll (940) SUS20ClientDataStore: Erro -1811 (0xfffff8ed) ao abrir o arquivo de log C:\windows\SoftwareDistribution\DataStore\Logs\edb.log.

    Visualizei que se tratava de um arquivo de log corrompido e então deletei para que o sistema criasse outro. Logo em seguida mandei checar o windows update e tudo funcionou perfeitamente.

    Att.

    Michel Peterson

    • Proposed as answer by Mario877 Saturday, June 16, 2012 7:18 PM
    Tuesday, June 05, 2012 2:39 PM
  • Cara,

    Eu passei por esse mesmo problema em um computador de um amigo e resolvi verificando os logs do sistema (cultura adquirida por ser um usuário Linux). Ao consultar esses logs vi a msg abaixo:

    wuaueng.dll (940) SUS20ClientDataStore: Erro -1811 (0xfffff8ed) ao abrir o arquivo de log C:\windows\SoftwareDistribution\DataStore\Logs\edb.log.

    Visualizei que se tratava de um arquivo de log corrompido e então deletei para que o sistema criasse outro. Logo em seguida mandei checar o windows update e tudo funcionou perfeitamente.

    Att.

    Michel Peterson

    Funcionou para mim.

    Bastou deletar todos os arquivos de log, e voltou a funcionar.

    Obrigado.

    • Proposed as answer by lac10 Saturday, August 04, 2012 3:09 PM
    Monday, July 23, 2012 9:52 AM
  • OK! pessoal funcionou perfeitamente, estava com esse problema alguns meses e não sabia o que fazer, boa dica!
    • Proposed as answer by CRLSGST Wednesday, September 19, 2012 8:12 PM
    Saturday, August 04, 2012 3:11 PM
  • Michel, bom dia

    funcionou comigo também, valeu!!!

    Muito obrigado mesmo!

    Monday, August 13, 2012 3:41 PM
  • Valeu Michel,

    Sua dica foi perfeita! É a cultura Linux resolvendo os problemas do Windows.

    Evilson

    Monday, September 24, 2012 5:23 PM
  • Comigo não resolveu... ao deletar os arquivos .log, na instalação e reinicio de maquina, o windows cria-os novamente, e novamente pára nos 15% e reinicia sozinho, e não instala porra nenhuma.

    já fiz de tudo, já usei o fix da microsoft, ja desisntalei anti-virus e malware bit, ja configurei no msconfig para inicializar com as opcoes minimas e nada, nada!

    como dizem, microsoft não presta!  o jeito vai ser guardar dinheiro e comprar um imac.

    Monday, October 01, 2012 2:49 PM
  • O Windows Update é um mecanismo deveras idiota.

    Eu não entendo o porquê de você instalar dez updates da mesma natureza. Não faz sentido.

    Se você instala o Windows XP com o Explorer 6, o WU atualiza o IE 6, depois instala o IE7, depois atualiza o IE7 e depois instala o IE8. Ao invés de instalar o IE8 direto, já com todas as atualizações, temos que esperar a atualização de todos os programas obsoletos.

    Daí vão dizer "por que não baixa o instalador do IE8 e pula as atualizações"? Tudo bem, até pode ser... Mas e como faço com o dot net? Tem como instalar o 4 com todas as atualizações? Não tem! Você instala o 4 (que já demora pra caramba) e depois tenho que esperar os trocentos updates...

    No Linux, se você faz uma atualização, ele já instala a última versão do que quer que seja. Se você instala uma distribuição com o Kernel 2.0, ele não atualiza para o 2.1, depois pro 2.2. Ele já atualiza para a última versão e ponto. E tudo em poucos minutos.

    A MS realmente está piorando a cada dia que passa. Acho que o Ballmer fez um pacto com a Apple e o Google para afundar o Windows. Eu estou usando o Windows 8 agora, porque estou instalando no PC de um cliente. O Windows Update até agora não deu tanto problema, porque o Windows 8 não tem tantos updates assim pra fazer.

    Mas esse mecanismo é realmente uma vergonha. Chega a insultar a inteligência de quem possui QI superior a de um chimpanzé retardado.

    Wednesday, December 05, 2012 3:19 PM
  • Cara hoje mais de 1 ano depois me deparei com este problema e graças a deus achei sua dica.. perfeita.. foi apenas deletar os logs que o Windows update voltou a funcionar.

    obrigado pela dica.

    abs

    Saturday, November 09, 2013 10:22 PM
  • Marco Torsone, boa tarde

    Executei o procedimento mencionado acima, mas antes eu fui até o painel de controle > ferramentas administrativas > serviços e desliguei o serviço Update antes de realizar o procedimento abaixo:

    Fui até o caminho abaixo:

    C:\windows\SoftwareDistribution\DataStore\Logs\edb.log.

    Funcionou normalmente na atualização de teste que realizei, como haviam mais 67, o equipamento ficou fazendo as atualizações. Postarei posteriormente se solucionou totalmente.

    Marcos Arley

    Analista de Suporte

    Friday, January 17, 2014 4:00 PM
  • Cara,

    Eu passei por esse mesmo problema em um computador de um amigo e resolvi verificando os logs do sistema (cultura adquirida por ser um usuário Linux). Ao consultar esses logs vi a msg abaixo:

    wuaueng.dll (940) SUS20ClientDataStore: Erro -1811 (0xfffff8ed) ao abrir o arquivo de log C:\windows\SoftwareDistribution\DataStore\Logs\edb.log.

    Visualizei que se tratava de um arquivo de log corrompido e então deletei para que o sistema criasse outro. Logo em seguida mandei checar o windows update e tudo funcionou perfeitamente.

    Att.

    Michel Peterson

    funcionou valeu.
    Monday, February 03, 2014 2:49 AM
  • Cara,

    Eu passei por esse mesmo problema em um computador de um amigo e resolvi verificando os logs do sistema (cultura adquirida por ser um usuário Linux). Ao consultar esses logs vi a msg abaixo:

    wuaueng.dll (940) SUS20ClientDataStore: Erro -1811 (0xfffff8ed) ao abrir o arquivo de log C:\windows\SoftwareDistribution\DataStore\Logs\edb.log.

    Visualizei que se tratava de um arquivo de log corrompido e então deletei para que o sistema criasse outro. Logo em seguida mandei checar o windows update e tudo funcionou perfeitamente.

    Att.

    Michel Peterson

    Funcionou para mim.

    Bastou deletar todos os arquivos de log, e voltou a funcionar.

    Obrigado.


    Vlw, funcionou perfeitamente aqui.
    Thursday, February 20, 2014 10:51 PM
  • Cara,

    Eu passei por esse mesmo problema em um computador de um amigo e resolvi verificando os logs do sistema (cultura adquirida por ser um usuário Linux). Ao consultar esses logs vi a msg abaixo:

    wuaueng.dll (940) SUS20ClientDataStore: Erro -1811 (0xfffff8ed) ao abrir o arquivo de log C:\windows\SoftwareDistribution\DataStore\Logs\edb.log.

    Visualizei que se tratava de um arquivo de log corrompido e então deletei para que o sistema criasse outro. Logo em seguida mandei checar o windows update e tudo funcionou perfeitamente.

    Att.

    Michel Peterson

    Perfeito man!

    Aqui bastou deletar o arquivo edb.log, reiniciar o windows, e problema resolvido. WU funcionando normalmente agora. :)
    Saturday, February 22, 2014 1:06 PM
  • Isso mesmo, estava com este problema , removi o log  e funcionou perfeitamente.
    Sunday, March 16, 2014 2:44 PM