none
Can not delete file. Error is "Could not find this item".

    Question

  • I get the following error when trying to delete a file:  "Item not found".  This is a Word 2007 document that would not save properly so I saved it with a different name.  Now I can't delete the original file.

    The body of the error states "Could not find this item.  This is no longer located in... . Verify the item's location and try again.
    Monday, January 11, 2010 4:03 PM

Answers

  • Ok, but this isn't a Windows 7 problem. Where are you originally opening the document from? From Outlook that you received from another email user by chance? Be a little more specific pleaase. thanks
    Or maybe it IS a Win7 problem ... By chance, the file MIGHT already be deleted, but Windows Explorer may have failed to refresh the panel (this has been a noted new feature of Win7 if you search around the forums).  If you can SEE the file you're trying to delete in a WinExplore panel, try first hitting F5 to refresh the screen.  This might show you it's already been deleted (it'll disappear).  This happens to me on occasion, too. 

    At any rate, yeah ... cdobbs' suggestion is on the mark, tho ... we need more specifics.

    Good luck in resolving this issue.
    • Marked as answer by MCSE Student Monday, January 11, 2010 7:19 PM
    Monday, January 11, 2010 7:10 PM
  • Well I found something interesting but one user said this "Just wanted to comment that deleting the iconcache.db worked for me"  From this thread (very long)  http://social.technet.microsoft.com/Forums/en/w7itproui/thread/8afb8b65-900c-4f42-b1df-3c2394417b6e   It took me a while to read through the whole thing, it seems to be a bug with the numerous complaints at that link. That same issue also occurred in XP early on and if memory serves me right it was fixed in sp1. I didn't play with Vista very long (just long enough to get certs in it) and we only have 2 or 3 at work (legacy apps prevent up from moving until vendors upgrade the software packages we use). Very interesting stuff ;) So MCSE Student, I believe your problem will again rear its ugly head again soon enough.
    MCSE, MCSA, MCDST [If this post helps to resolve your issue, please click the "Mark as Answer" or "Helpful" button at the top of this message. By marking a post as Answered, or Helpful you help others find the answer faster.]
    • Marked as answer by MCSE Student Monday, March 15, 2010 9:26 PM
    Monday, January 11, 2010 11:39 PM

All replies

  • Ok, but this isn't a Windows 7 problem. Where are you originally opening the document from? From Outlook that you received from another email user by chance? Be a little more specific pleaase. thanks
    MCSE, MCSA, MCDST [If this post helps to resolve your issue, please click the "Mark as Answer" or "Helpful" button at the top of this message. By marking a post as Answered, or Helpful you help others find the answer faster.]
    Monday, January 11, 2010 6:58 PM
  • Ok, but this isn't a Windows 7 problem. Where are you originally opening the document from? From Outlook that you received from another email user by chance? Be a little more specific pleaase. thanks
    Or maybe it IS a Win7 problem ... By chance, the file MIGHT already be deleted, but Windows Explorer may have failed to refresh the panel (this has been a noted new feature of Win7 if you search around the forums).  If you can SEE the file you're trying to delete in a WinExplore panel, try first hitting F5 to refresh the screen.  This might show you it's already been deleted (it'll disappear).  This happens to me on occasion, too. 

    At any rate, yeah ... cdobbs' suggestion is on the mark, tho ... we need more specifics.

    Good luck in resolving this issue.
    • Marked as answer by MCSE Student Monday, January 11, 2010 7:19 PM
    Monday, January 11, 2010 7:10 PM
  • Ok ... after pressing F5 the file disappeared.  I’m well aware of  the refresh option but I had rebooted the computer a few times so I assumed the reboots completed the refresh for me.

    Thanks
    Monday, January 11, 2010 7:19 PM
  • Ok ... after pressing F5 the file disappeared.  I’m well aware of  the refresh option but I had rebooted the computer a few times so I assumed the reboots completed the refresh for me.

    Thanks
    Hmmmm ... yeah, I would've thought a reboot should solve it, too.  That is VERY weird.  I guess we really need to learn to use that F5 key in Win7, eh?

    At any rate, I'm glad you've gotten it sorted for now.
    Monday, January 11, 2010 7:29 PM
  • that is weird, a reboot should have cleared the cache, I'll have to research that a little more. Now that I think about it, I seem to recall a long time ago someone else (at work) had this very similar problem, but old age makes forget what we did to fix it   ;)  (as it would reappear like a bad penny)
    MCSE, MCSA, MCDST [If this post helps to resolve your issue, please click the "Mark as Answer" or "Helpful" button at the top of this message. By marking a post as Answered, or Helpful you help others find the answer faster.]
    Monday, January 11, 2010 11:29 PM
  • Well I found something interesting but one user said this "Just wanted to comment that deleting the iconcache.db worked for me"  From this thread (very long)  http://social.technet.microsoft.com/Forums/en/w7itproui/thread/8afb8b65-900c-4f42-b1df-3c2394417b6e   It took me a while to read through the whole thing, it seems to be a bug with the numerous complaints at that link. That same issue also occurred in XP early on and if memory serves me right it was fixed in sp1. I didn't play with Vista very long (just long enough to get certs in it) and we only have 2 or 3 at work (legacy apps prevent up from moving until vendors upgrade the software packages we use). Very interesting stuff ;) So MCSE Student, I believe your problem will again rear its ugly head again soon enough.
    MCSE, MCSA, MCDST [If this post helps to resolve your issue, please click the "Mark as Answer" or "Helpful" button at the top of this message. By marking a post as Answered, or Helpful you help others find the answer faster.]
    • Marked as answer by MCSE Student Monday, March 15, 2010 9:26 PM
    Monday, January 11, 2010 11:39 PM
  • My desktop is now literally clogged with folders I cannot delete. There is perhaps one thing in common with the files affected: They had each contained pdfs or folders where I had converted the pdfs into jpegs or word documents (I refuse to use adobe and no, I am not an apple fanboy because I hate them too).

    They display the same "cannot find this item".

     

    I am running Windows 7 Ultimate x64.

    Sunday, May 02, 2010 6:36 PM
  • You can go to CMD window and type dir /x (will give you another column with the files shot filenames) and then do del [short filename]. I had this one file that even THAT didn't work so I found my own SIMPLE solution that worked great.

    I just created a new directory, moved the bogus file into it (I didn't think it would move it but it did!) then in the new directory, the file got a new icon and then I just deleted the new directory and it was gone.
    • Proposed as answer by JapJay619 Monday, August 23, 2010 6:25 AM
    Thursday, July 01, 2010 11:17 AM
  • I get the same issue with a file I have. This file apparently has 0kb in it, although it is a copy (at least in name and file type) of a downloaded excel file. I can get the phantom file to go away if I redownload the original file, then delete the 0kb file. When I hit f5 to refresh, my file reappears.

    Sorry for being a bit of a noob, Zvi, but when you say "to create a new directory", do you mean to create a new file folder? The file I'm having troubles with is on my desktop. I can't create any file folders that will accept the phantom file either on my desktop or in the explorer.Can you walk me through this?

    When I go in through dir /x command, the column with the short file names is blank for the item in question and the long file name is "." or ".." (there are two files with the proper date).

    Thanks

    Wednesday, July 14, 2010 8:52 PM
  • You can go to CMD window and type dir /x (will give you another column with the files shot filenames) and then do del [short filename]. I had this one file that even THAT didn't work so I found my own SIMPLE solution that worked great.

    I just created a new directory, moved the bogus file into it (I didn't think it would move it but it did!) then in the new directory, the file got a new icon and then I just deleted the new directory and it was gone.


    I signed up and am posting just to let you all know that the above worked for me when nothing else did. I tried all manner of application and registry edits and nothing else worked.

    Here's my step by step, spelled out:

    So, my file was on the desktop. I typed in CMD in the Start menu, and got the DOS prompt. Typed in dir /x, which listed all the directories for the c:/ drive, I believe. typed in "cd desktop", to change the directory to the Desktop. It now reads c:\users\XXX\desktop\. where XXX is my user account. I then typed dir /x again, which listed all of the files on my desktop, which is also where the undeletable file is. The screen shows from lesft to right: file date, file time/whatever, file size, file short name, file actual/long name. So, the last step is to delete, by typing del "file shortname". In my case, it was "del gigiri~2" and it was gone, verified both by typing dir /x again and checking the desktop. You may have to include the filetype extension for your file but my didn't actually have one. And poof, that annoying issue and its "non-existent" file are finally gone.

    Thanks, Zvi_Twersky

    • Proposed as answer by NishantGogna Monday, December 24, 2012 7:50 PM
    Monday, August 23, 2010 6:25 AM
  • Deleting the file via the file shortname worked like a charm. I had no luck deleting it any other way.

     

    Thanks! :D

    Tuesday, October 12, 2010 8:31 PM
  • Well I will tell you how I just solved my problem. I had an mp3 icon on my desktop that I could not get rid of because "the file could not be found".  I created a shortcut. Then right clicked on the shortcut to locate the file deleted the short cut I had just created and both icons were gone problem solved.

     

    Hope this helps.

     

    Steve Shoemaker

    http://steveshoemaker.info

    Wednesday, October 27, 2010 12:05 AM
  • This is explorer's error. I just installed the free version of total commander and tried to delete it but again "could not find this file". I tried to rename it and delete the space which causes the error. Suddenly the file appeared with its icon and just i deleted it.

    Everything is fine know!

    (p.s. I also tried any possible solution with cmd and del, or rename without success.)

    Wednesday, November 03, 2010 8:59 PM
  • TRY THIS:


    I really sought out many versions of help with removing folders that were not found in my C:/ Drive and found a much simpler way, of course with the help of other postings...

    Now, I don't know if it will work for everybody but it certainly worked for me. What I did was very simple.

    I created a new folder (did not named it) and just dragged it over to the trouble folder.

    Now this part can be very tricky because a duplicate folder may apprear. If this happens delete the old folder and keep the new one that appears.

    Then create a new folder (no need to name it) and drag it over to the "New" Trouble Folder.

    Then you'll notice that it will accept the un-named drop in folder and Whalla.....Now You Can Delete The Folder And No More Nightmares..!!!!

    BODA...

     

    • Proposed as answer by BODAZAFFA Monday, November 08, 2010 6:22 AM
    Monday, November 08, 2010 6:22 AM
  • Hi,

     

    I'm having exact the same problem with a file with a long name, to delete, move, rename, attribute change, etc. I deleted the file, which I receive the confirmation. However, the file is still there, with zero bytes and no extension. When I try to delet, move or change the file, I get the error "Could not find this item, This is no longer located in xxx. Verify the item's location and try again."

    I tryed everything: Using DOS, there's no 8.3 name format; In safe mode; chkdsk and sfc. Nothing worked.

    I also tryed the tricks in http://www.sevenforums.com/general-discussion/27924-could-not-find-item-when-deleting-files-3.html

    http://forums.techarena.in/vista-help/1038943.htm

    Without success.

    I took some more time and found this tool on the net "DelinvFile". It works perfectly, after trying EVERYTHING!!!.

    I Have Windows 7 professional 64bits and NTFS.

    Thank you very much.

    • Proposed as answer by galmeida Monday, January 17, 2011 12:46 AM
    Sunday, January 16, 2011 10:39 PM
  • Fix is here

    http://www.techjawa.com/wp-content/uploads/2010/05/FolderFix.zip

    No thanks to microsoft

    Monday, November 21, 2011 10:17 AM
  • Hi,

     

    I'm having exact the same problem with a file with a long name, to delete, move, rename, attribute change, etc. I deleted the file, which I receive the confirmation. However, the file is still there, with zero bytes and no extension. When I try to delet, move or change the file, I get the error "Could not find this item, This is no longer located in xxx. Verify the item's location and try again."

    I tryed everything: Using DOS, there's no 8.3 name format; In safe mode; chkdsk and sfc. Nothing worked.

    I also tryed the tricks in http://www.sevenforums.com/general-discussion/27924-could-not-find-item-when-deleting-files-3.html

    http://forums.techarena.in/vista-help/1038943.htm

    Without success.

    I took some more time and found this tool on the net "DelinvFile". It works perfectly, after trying EVERYTHING!!!.

    I Have Windows 7 professional 64bits and NTFS.

    Thank you very much.


    Thankyou Thankyou Thankyou Thankyou......... We are almost bald tearing our hair out over this issue and how to fix it.     Delin File WORKS...... At the cost of about 28 bucks well worth it.............. Good onya mate............
    • Proposed as answer by mossbank Thursday, February 16, 2012 11:47 AM
    Thursday, February 16, 2012 11:47 AM
  • Fix is here

    http://www.techjawa.com/wp-content/uploads/2010/05/FolderFix.zip

    No thanks to microsoft

    YOU SIR ARE THE MAN.
    Sunday, May 13, 2012 5:19 PM
  • Brilliant! After trying many other solutions proposed by various contributors, this finally was the one that solved my problem. Thanks!
    Saturday, May 19, 2012 2:55 AM
  • Thank you very much :) :) :)
    Monday, May 28, 2012 3:29 AM
  • what do u do with these when u downloaded them???

    Thursday, June 28, 2012 9:42 PM
  • Dear Bodazaffa,

    You are the men. I simply fixed the problem by just following your suggestion. It was simple, easy, and even fun!!! God bless to Bodazaffa!

    Sincerely,

    Ken.

    Thursday, July 12, 2012 2:11 AM
  • I keep having this problem -- it is not a problem with F5, and the command window didn't show the file. I get directories that appear in Windows Explorer but don't appear in the command window and cannot be deleted.

    However, I found an easy fix based on the above -- just drag a file into the directory. Somehow this makes the directory "OK". It can then be deleted. 

    • Proposed as answer by Qeta Friday, January 04, 2013 1:07 AM
    Monday, December 03, 2012 7:10 PM
  • I signed up and am posting just to let you all know that the above worked for me when nothing else did. I tried all manner of application and registry edits and nothing else worked.

    Here's my step by step, spelled out:

    So, my file was on the desktop. I typed in CMD in the Start menu, and got the DOS prompt. Typed in dir /x, which listed all the directories for the c:/ drive, I believe. typed in "cd desktop", to change the directory to the Desktop. It now reads c:\users\XXX\desktop\. where XXX is my user account. I then typed dir /x again, which listed all of the files on my desktop, which is also where the undeletable file is. The screen shows from lesft to right: file date, file time/whatever, file size, file short name, file actual/long name. So, the last step is to delete, by typing del "file shortname". In my case, it was "del gigiri~2" and it was gone, verified both by typing dir /x again and checking the desktop. You may have to include the filetype extension for your file but my didn't actually have one. And poof, that annoying issue and its "non-existent" file are finally gone.

    Thanks, Zvi_Twersky

    This worked for me too! Thank you so much!!! 

    Monday, December 24, 2012 7:50 PM
  • I keep having this problem -- it is not a problem with F5, and the command window didn't show the file. I get directories that appear in Windows Explorer but don't appear in the command window and cannot be deleted.

    However, I found an easy fix based on the above -- just drag a file into the directory. Somehow this makes the directory "OK". It can then be deleted. 

    I can verify that your suggestion worked for me.

    So anyone with this problem try this simple fix  before you do the fix with the registry changes.

    Friday, January 04, 2013 1:09 AM
  • You can go to CMD window and type dir /x (will give you another column with the files shot filenames) and then do del [short filename]. I had this one file that even THAT didn't work so I found my own SIMPLE solution that worked great.

    I just created a new directory, moved the bogus file into it (I didn't think it would move it but it did!) then in the new directory, the file got a new icon and then I just deleted the new directory and it was gone.


    I signed up and am posting just to let you all know that the above worked for me when nothing else did. I tried all manner of application and registry edits and nothing else worked.

    Here's my step by step, spelled out:

    So, my file was on the desktop. I typed in CMD in the Start menu, and got the DOS prompt. Typed in dir /x, which listed all the directories for the c:/ drive, I believe. typed in "cd desktop", to change the directory to the Desktop. It now reads c:\users\XXX\desktop\. where XXX is my user account. I then typed dir /x again, which listed all of the files on my desktop, which is also where the undeletable file is. The screen shows from lesft to right: file date, file time/whatever, file size, file short name, file actual/long name. So, the last step is to delete, by typing del "file shortname". In my case, it was "del gigiri~2" and it was gone, verified both by typing dir /x again and checking the desktop. You may have to include the filetype extension for your file but my didn't actually have one. And poof, that annoying issue and its "non-existent" file are finally gone.

    Thanks, Zvi_Twersky


    This also helped me out just now! Those two pesky files were the culprit... I was able to delete everything after following your steps. Thanks!
    Friday, May 17, 2013 11:10 PM
  • One of the common error messages is "COULD NOT FIND THIS ITEM"  It can be 
    easily fix. Download and use “LongPathTool” guaranteed fix for your problem.
    Wednesday, July 17, 2013 7:34 PM
  • Hi, 

    I have a same issue like you. My OS Windows 7 64bit

    Solution solved:

    1. Open cmd.

    2. Change to directory where the file has issue.

    3. List your file by command: dir /x

    4. Use 'del' command to delete your file, use the short name: such like

    del TRANSP~1.MKV

    Regards,


    • Edited by Boychinakm Tuesday, October 15, 2013 2:09 AM
    Tuesday, October 15, 2013 2:08 AM
  • thanks so much, this one worked for me.
    Wednesday, November 20, 2013 7:21 AM
  • deleting the folder using its short file name as shown with the DIR /X command (using CMD window) did the trick for me.
    Sunday, January 26, 2014 5:19 PM
  • You can go to CMD window and type dir /x (will give you another column with the files shot filenames) and then do del [short filename]. I had this one file that even THAT didn't work so I found my own SIMPLE solution that worked great.

    I just created a new directory, moved the bogus file into it (I didn't think it would move it but it did!) then in the new directory, the file got a new icon and then I just deleted the new directory and it was gone.

    Thanks a lot it solve my problem .

    I tried chkdsk /f /r and a lot of stuff without success but you gave me solution . Thnks

    Thursday, March 20, 2014 7:33 PM