none
W32tm still states source is local cmos clock even though have specified external source - SBS2011

    Question

  • Hi,

    I have a Windows SBS 2011 server which I am trying to configure to gets its time from an external source (uk.pool.ntp.org). I have ran the command:

    w32tm.exe /config /manualpeerlist:"uk.pool.ntp.org" /syncfromflags:manual /reliable:yes /update

    I then restarted the w32time service using 'net stop w32time && net start w32time" but this has made no difference. When running the 'w32tm /query /source' command it still specifies the Local CMOS clock as being the source. I've also checked the registry featured within http://support.microsoft.com/kb/816042 and these are in place but the time is still wrong.

    Please could anyone provide some assistance?

    Thanks

    Ed

    Wednesday, May 23, 2012 12:09 PM

Answers

  • My only other thought was that maybe the time protocol was being blocked at your firewall. Does w32tm drop back to the hardware clock if the specified server(s) are not contactable? Sorry, I don't know.
    Thursday, May 24, 2012 11:54 PM

All replies

  • 1st thing I'm gonna suggest is trying the 2nd MR Fixit from http://support.microsoft.com/kb/816042
    Wednesday, May 23, 2012 12:28 PM
  • I dont like to use the Fix Its, Im more then capable of completing the steps manually which I have done as explained in my 1st post.

    Any further advise please?

    Wednesday, May 23, 2012 12:30 PM
  • I suggest that if you're so darn capable you could give the fixit a go and override what it does with your own preferences should it fix the problem.
    Wednesday, May 23, 2012 12:35 PM
  • Have ran the Fix It and checked settings within reg but still the source is showing as using Local CMOS clock.
    Wednesday, May 23, 2012 1:43 PM
  • Please could I have an update on this one, its still unresolved..

    Thursday, May 24, 2012 2:49 PM
  • My only other thought was that maybe the time protocol was being blocked at your firewall. Does w32tm drop back to the hardware clock if the specified server(s) are not contactable? Sorry, I don't know.
    Thursday, May 24, 2012 11:54 PM
  • Hmmm.....

    Which clock is the leader and which the follower?  If you once correct the time in Windows, will it stay corrected until you are able to sort out the reason for the server not contacting the internet time servers?

    Try inet search for "verify nntp servers" or such to find the correct proceedure to test the connection:

    http://technet.microsoft.com/en-us/library/cc773263(v=ws.10).aspx

    for example.


    Larry Struckmeyer[SBS-MVP]

    Friday, May 25, 2012 12:48 AM
    Moderator
  • Thanks for this, turns out UDP port 123 (NTP) was being blocked on the Firewall. Thanks for your help.
    Friday, May 25, 2012 2:02 PM
  • The default domain policy GPO may have time.windows.com configured in computer config\admin templates\windows components\windows time server, I set all to not configured and it sorted it for me.
    Thursday, June 05, 2014 9:28 AM