none
OWA Calendar not showing month view in non-IE browsers

    Question

  • I've got a user who can't see the Month view on his OWA calendar. He's the only user complaining - Month view loads fine on my Exchange account across all browsers and operating systems.

    I can see the Month view on his account when I log in with IE, but not with any other browser, Windows and Mac.

    Any ideas? I'm at a total loss here, I've been in and deleted recurring appointments, but nothing else looks out of the ordinary. Everything else works, it just won't load the month view in non-IE browsers and he's the only one affected.

    Any clues appreciated, thank you!

    Wednesday, September 18, 2013 6:21 PM

All replies

  • Hi, 

    The Microsoft OWA web interface has two versions: OWA Premium and OWA Light. OWA Premium which can achieve calendar month view is only accessible when using Microsoft’s Internet Explorer browser. 

    If you’re using any other browser, we can use OWA Light. In light version, the OWA feature is not rich like OWA Premium. As for Calendar view, there is only daily view in OWA light.

    About Calendar view in third-party browser, please contact the third-party browser support for more helps.

    About Microsoft Outlook Web Access Light 2007, please refer to:

    http://blogs.technet.com/b/exchange/archive/2006/09/13/3394870.aspx

    Thanks,

    Winnie

    Saturday, September 21, 2013 6:45 PM
  • I don't think that's the correct answer. You don't have to settle for the light version with Exchange 2010 just because you don't use IE.

    I can use Firefox and see the "Month view" just fine.


    --- Rich Matheisen MCSE&I, Exchange MVP

    Sunday, September 22, 2013 2:09 AM
  • So the icons at the top of the calendar are only "Day view", "Work Week view", and "Week view"? The "Month view" icon isn't there? Or is the icon there but clicking on it doesn't work?

    I wonder if it has anything to do with web parts?

    I tried this and got only the "Weekly" view, even though clicking on the "Monthly view" icon produces the correct view:

    https://<SERVER>/owa/?cmd=contents&fpath=Calendar&view=Monthly

    If I used this I got the correct weekly view:

    https://<SERVER>/owa/?cmd=contents&fpath=Calendar&view=Weekly


    --- Rich Matheisen MCSE&I, Exchange MVP

    Sunday, September 22, 2013 2:54 AM
  • Hi,

    What I means is that OWA Light is certainly supported by third-party browsers. But OWA Premium maybe not.

    There are also some Web browsers that are supported for Outlook Web App, just like:

    1. Internet Explorer 7 and later versions.

    2. Firefox 3.0.1 and later versions.

    3. Chrome 3.0.195.27 and later versions.

    For more information about it, please refer to:

    Web browsers that are supported for Outlook Web App when it runs on Exchange Server 2010

    http://support.microsoft.com/kb/2572191/en-us

    Thanks,

    Winnie


    Tuesday, September 24, 2013 12:38 PM
  • I'm having this exact same problem in Internet Explorer 11 (via Windows 8.1 Pro).

    I can only get OWA light to load and there's no monthly view.

    Am I missing something obvious?

    Richard

    Tuesday, October 22, 2013 12:29 PM