none
Windows 2012 R2/Windows 8.1 GPO Folder Redirection Woes

    Question

  • So now I am starting to use windows 8.1 and Windows 2012 R2.  DCs are 2012R2, Forest Level 2012 R2, Domain Level 2012 R2. Folder Redirection works for Windows 7, Windows 8, 2008, 2008 R2, 2012. Does not work for Windows 8.1/2012R2. No errors are logged in event viewer, says completed successfully. GPResult /v only says:

     Folder Redirection
    ------------------
        N/A

    Group Policy Results Wizard says:

    Component Name Status Time Taken Last Process Time Event Log
    Group Policy Infrastructure Success 218 Millisecond(s) 11/9/2013 12:28:30
    PM
    View
    Log
    ConfigMgr User State Management Extension. Success 32 Millisecond(s) 11/9/2013 12:28:30
    PM
    View
    Log
    Folder Redirection Success 31 Millisecond(s) 11/9/2013 12:28:30
    PM

    View Log

    I have tried disabling all other policies (computer and User) except the one that has the folder redirection with no luck. I have tried putting Folder redirection in its own GPO, no luck.

    NONE of the following are checked in the Folder redirection (but I have tried it both ways for each):

    1. Grant the User exclusive rights to ....
    2. Move the contents of ....... to the new location
    3. Also apply redirection policy to windows 2000, Windows 2000 Server, Windows XP, and Windows Server 2003 operating systems.

    DCDiag returns no errors. Sysvol is replicating properly between both DCs

    Everything else EXCEPT Folder redirection applies properly.

    Thanks!


    • Edited by shaggy11101 Saturday, November 09, 2013 5:51 PM
    Saturday, November 09, 2013 5:50 PM

Answers

  • So I got Folder redirection working properly. Not really positive if it will work for you, but I found 2 ways to make it work. here is what I did:

    Option 1: Instead of a clean install on one  computer I installed 8 then logged on and verified folder redirection worked. I did an upgrade from 8 to 8.1. folder redirection seemed to still work for the same use. I then verified it worked with another user.

    Option 2: I did a RSOP on an affected computer. Under user details I noticed it was applying a GPO that only had computer policies and no user policies. That policy was linked to the forest level and had a trusted root certificate and 2 code signing certificates in it unser "Computer\Security Settings\Public Key". I removed that from the Root of the domain to the OU where computer accounts are kept. GPOs are working for all windows 8 workstations. I will to a clean install of windows 8.1 to verify and will post the results. Hope this helps you all.

    • Marked as answer by shaggy11101 Friday, November 22, 2013 3:37 AM
    Thursday, November 21, 2013 11:48 PM

All replies

  • Hi,

    Before going further, I want to confirm with you what folder we redirected. Besides, for folder redirection is a user setting, I want to confirm whether it doesn’t work for all domain user accounts when they log on to Windows 8.1 or Windows Server 2012 R2.

    In addition, to test out whether the issue is related to the fast logon optimization feature, we can try enabling the following setting:

    Computer Configuration\Administrative Templates\System\Logon\ Always wait for the network at computer startup and logon

    Best regards,

    Frank Shen

    Monday, November 11, 2013 3:04 PM
    Moderator
  • changing that setting was one of the first things I tried with no luck. I have tried redirecting to a remote server to user folder under: \\server\Profiles

    for documents, appdata, music, videos, pictures, desktop, etc...

    I also tried it to a local location C:\Folder\%username%

    this affects all users whether just a domain user or domain admin. I have verified permissions. to the profile share the following share permissions exist:

    Everyone full

    following NTFS security permissions:

    Authenticated  read,list

    creator owner full

    system full

    domain admins full

    Each user folder has the following permissions:

    %username% full

    creator owner full

    domain admins full

    each user folder has the related user as owner.

    Thanks

    justin

    Tuesday, November 12, 2013 2:46 AM
  • Please post if you find the solution as I am seeing the same thing.  My users have a GPO configured for them.  In Windows 7 and 8 this caused their Documents folder to redirect to the configured network share.  When they sign into a windows 8.1 their documents folder is not redirecting.  I have not seen an error, yet to indicate why.

    Fred Zilz

    Monday, November 18, 2013 5:56 PM
  • so solution yet, once I figure it out I will let you know.
    • Edited by shaggy11101 Monday, November 18, 2013 7:39 PM
    Monday, November 18, 2013 7:39 PM
  • I can confirm same problem on Windows 8.1 Enterprise, x64. It worked normally on Windows 8 Enterprise, x64.

    -- Hrvoje Kusulja

    Wednesday, November 20, 2013 9:37 AM
  • So I got Folder redirection working properly. Not really positive if it will work for you, but I found 2 ways to make it work. here is what I did:

    Option 1: Instead of a clean install on one  computer I installed 8 then logged on and verified folder redirection worked. I did an upgrade from 8 to 8.1. folder redirection seemed to still work for the same use. I then verified it worked with another user.

    Option 2: I did a RSOP on an affected computer. Under user details I noticed it was applying a GPO that only had computer policies and no user policies. That policy was linked to the forest level and had a trusted root certificate and 2 code signing certificates in it unser "Computer\Security Settings\Public Key". I removed that from the Root of the domain to the OU where computer accounts are kept. GPOs are working for all windows 8 workstations. I will to a clean install of windows 8.1 to verify and will post the results. Hope this helps you all.

    • Marked as answer by shaggy11101 Friday, November 22, 2013 3:37 AM
    Thursday, November 21, 2013 11:48 PM
  • I did a clean install (through SCCM 2012 R2) to verify my folder redirection was still working and it is. hope this helps someone else out there!
    Friday, November 22, 2013 3:37 AM
  • Hi,

    I am glad to hear that you have solved the issue, and thank you very much for sharing your solution with us.

    Best regards,

    Frank Shen

    Friday, November 22, 2013 7:26 AM
    Moderator
  • Hi,

    i have done clean installation on about 5 pc-s. 3 of them does not have folder redirection, and 2 of them are working fine. We have several GPO's for computer policy in several places (OU, domain level etc.), and only one User policy. All of GPO's were applied successfully and rsop.msc shows all (computer and user settings), however only Folder redirection is missing.

    We do not have SCCM at all.

    We do not have GPO's with deploying certificates.

    I can reinstall windows 8.1 pcs wich does not work, however, this is not a solution, it is more random() function, will it work or not.

    I did not find any error in event log, or somewhere else about this.

    Configuration is the same as with Windows 8, and users are the same.

    I believe that this issue is not solved, and need more help what to check and how to solve this problem.


    -- Hrvoje Kusulja

    Friday, November 22, 2013 9:25 AM
  • Do a resultant set of policies on an affected computer and look at your user results to see if it is applying one of the computer policies that has no user policies on your user. ultimately that is what mine was doing. it was inheriting it from a parent ou.
    Friday, November 22, 2013 9:58 PM
  • yes, on client Windows 8.1, the rsop is showing all computer and user policies, except folder redirection setting which is missing there, all other settings are fine.

    Of course, AD / GPO settings are on correct place


    -- Hrvoje Kusulja


    Saturday, November 23, 2013 10:14 AM
  • Anyone made any progress on this? i'm having the same problem but only on some of our Windows 8.1 machines. all ones upgrade from 8 to 8.1 work fine but some of our fresh installs of 8.1 don't do all of the user policies from GP including folder redirection. I can't find any errors on the PC's why the policies aren't applying.

    Thanks 

    Wednesday, November 27, 2013 10:39 PM
  • I have not had any more problems since I fixed the Computer Group Policy that (mentioned above) was trying to apply on users. It is now working for upgrades and clean installs.
    Wednesday, November 27, 2013 11:21 PM
  • Ok Cool, seems to be working in our test environment now too.

    Thanks

    Thursday, November 28, 2013 12:56 AM
  • Hi,

    Before going further, I want to confirm with you what folder we redirected. Besides, for folder redirection is a user setting, I want to confirm whether it doesn’t work for all domain user accounts when they log on to Windows 8.1 or Windows Server 2012 R2.

    In addition, to test out whether the issue is related to the fast logon optimization feature, we can try enabling the following setting:

    Computer Configuration\Administrative Templates\System\Logon\ Always wait for the network at computer startup and logon

    Best regards,

    Frank Shen

    This fixed it for me, by enabling this my problems have now gone.
    Thursday, November 28, 2013 12:59 AM
  • I confirm that this does not solve the problem in my case.

    Also, in my case, network is instantly available, and we tried by ping, and all other settings were applied.

    also, in description is written:

    If a user with a roaming profile, home directory, or user object logon script logs on to a computer, computers always wait for the network to be initialized before logging the user on. If a user has never logged on to this computer before, computers always wait for the network to be initialized.

    Also it passed few days, and logins, and reboots, still we have problem with some users.


    -- Hrvoje Kusulja

    Thursday, November 28, 2013 5:54 PM
  • Also if using SCCM there is a setting that can be turned on that will make Folder Redirection use WMI which will break it in Windows 8 / 8.1

    http://www.blackforce.co.uk/2014/01/18/windows-8-8-1-folder-redirection-not-applying-working

    • Proposed as answer by jamicon Friday, April 04, 2014 7:25 PM
    Saturday, January 18, 2014 6:00 PM
  • I just ran into this issue. Although I found that a GPO was created to allow loopback processing of the GPO in merge mode at a higher level. Desktop Redirection was configured and working fine, but stopped in Windows 8.1. After some searching I found this Microsoft article (http://support.microsoft.com/kb/953768/en-gb). It was written for Windows 7, but it worked. I added the computer account to the security of the GPO and set it for read access and I got my desktop redirection. I hope this helps.

    Wednesday, March 19, 2014 6:56 PM
  • I just ran into this issue. Although I found that a GPO was created to allow loopback processing of the GPO in merge mode at a higher level. Desktop Redirection was configured and working fine, but stopped in Windows 8.1. After some searching I found this Microsoft article (http://support.microsoft.com/kb/953768/en-gb). It was written for Windows 7, but it worked. I added the computer account to the security of the GPO and set it for read access and I got my desktop redirection. I hope this helps.
    Wednesday, March 19, 2014 6:57 PM