none
SSIS OLEDB Data Source do not refresh automatically

    Question

  • Hello!

    I am facing an issue with my OLEDB data source in the DFT

    Issue

    We are using procedures as data source in the DFT. Initially we did not have mapping for all the columns in the SP to the destination table. So we selected NULL for such missing mappings. Later point we got this mapping and we replaced NULL with the column name. But, this data type of the new column is not refreshing in the data source. I tried clicking the Refresh button in the advanced editor, in vain. Any help is appreciated on this. thanks!


    Tiffosi!

    Tuesday, July 30, 2013 5:45 AM

Answers

All replies

  • If you change the data type of an existing source query then you have to uncheck and check the column in the source component to refresh the meta data.

    Please mark the post as answered if it answers your question | My SSIS Blog: http://microsoft-ssis.blogspot.com | Twitter

    • Proposed as answer by Koen Verbeeck Tuesday, July 30, 2013 6:24 AM
    • Marked as answer by Tiffosi Tuesday, July 30, 2013 8:18 AM
    Tuesday, July 30, 2013 6:02 AM
  • Thanks for the reply!!! it works...thanks!

    Tiffosi!

    Tuesday, July 30, 2013 8:18 AM
  • HI ,

    AS LLIONIX said try uncheck and check the columns in source component if it still doesnt work.Try this.

     simply delete the flow pipe (red and green), and re-add them.

    Tuesday, July 30, 2013 8:54 AM