none
Error: An unexpected error has occurred

    Question

  • Hi,

     

    I have two server, one with sharepoint and the Dashboard Viewer for sharepoint services , the other with the monitoring server. When i deploy the dashboard in the sharepoint site it gives me a error: An unexpected error has occurred

     

    I use the account network service in the application pool of the sharepoint site.

     

    Can anybody help me?

     

    Thanks

    Wednesday, June 04, 2008 2:20 PM

Answers

  • Hello Alexandre Albuquerque Rodrigues,

     

    Ok now that you have a domain account running the SharePoint application pool, that account is being used to access the data source. The next thing I would check is to make sure your domain account has been given permissions to the data source.

     

    Is this error a SharePoint page error? If so then you will need to grant your domain account permissions to the SharePoint site collection, specifically rights to be able to view the document library where the dashboard is deployed.

     

    If it isn't a SharePoint page error, does the page load and then the PPS report error out? If so, what kind of report is throwing this error? Is it an Analytic Grid or Chart? Your account will need to be given access to the cube.

     

    Thanks,

    Jon Thomas

    Wednesday, June 04, 2008 5:38 PM
    Moderator
  • Hi Alexandre Albuquerque Rodrigues,

     

    Please make sure PPSMonitoringWebService Application Pool user is site collection Administrator of the SharePoint Site

     

    Thank you,

    Sundar - MSFT

    Wednesday, June 11, 2008 5:09 PM

All replies

  • Hello Alexandre Albuquerque Rodrigues,

     

    Which machine is the SQL Server on? Also what machine is the data source on?

     

    If either of these are on a seperate machine then SharePoint, you will need to use a domain account for the SharePoint application pool.

     

    Thanks,

    Jon Thomas

    Wednesday, June 04, 2008 4:12 PM
    Moderator
  • Hi Jon

     

    The Sharepoint and the SQL Server are in separate machine. I tried your sugestion putting my domain account (who is administrator in both machine) in the application pool of the sharepoint site, but now an error of the iis appear:

    You are not authorized to view this page

     

    I dont understand much about the configuration of the application pool...I made a quick search in the google but nothing came up....Any idea?

    Wednesday, June 04, 2008 5:33 PM
  • Hello Alexandre Albuquerque Rodrigues,

     

    Ok now that you have a domain account running the SharePoint application pool, that account is being used to access the data source. The next thing I would check is to make sure your domain account has been given permissions to the data source.

     

    Is this error a SharePoint page error? If so then you will need to grant your domain account permissions to the SharePoint site collection, specifically rights to be able to view the document library where the dashboard is deployed.

     

    If it isn't a SharePoint page error, does the page load and then the PPS report error out? If so, what kind of report is throwing this error? Is it an Analytic Grid or Chart? Your account will need to be given access to the cube.

     

    Thanks,

    Jon Thomas

    Wednesday, June 04, 2008 5:38 PM
    Moderator
  • Hi Jon

     

    Is not a Sharepoint error, neither a PPS error. My account have access to the cube. Now the full error is

     

    You are not authorized to view this page

    You do not have permission to view this directory or page using the credentials that you supplied.


    Please try the following:

    • Contact the Web site administrator if you believe you should be able to view this directory or page.
    • Click the Refresh button to try again with different credentials.

    HTTP Error 401.1 - Unauthorized: Access is denied due to invalid credentials.
    Internet Information Services (IIS)

     

    It tells me that i haven't permissions... its strange... I'm lost...

     

    Thanks!

    Wednesday, June 04, 2008 5:48 PM
  • Hi Alexandre Albuquerque Rodrigues,

     

    Please make sure PPSMonitoringWebService Application Pool user is site collection Administrator of the SharePoint Site

     

    Thank you,

    Sundar - MSFT

    Wednesday, June 11, 2008 5:09 PM