none
Network characteristics detection function

All replies

  • These ones may help.

    http://social.technet.microsoft.com/wiki/contents/articles/16652.remotefx-vgpu-setup-and-configuration-guide-for-windows-server-2012.aspx

     

    http://technet.microsoft.com/en-us/library/ff817580(v=ws.10).aspx

     

     


    Regards, Dave Patrick ....
    Microsoft Certified Professional
    Microsoft MVP [Windows]

    Disclaimer: This posting is provided "AS IS" with no warranties or guarantees , and confers no rights.


    Saturday, November 09, 2013 9:35 PM
  • Didn't lead to anything, thanks though.

    Bryan

    Sunday, November 10, 2013 3:48 PM
  • Hi,

    Network characteristics detection is included in the newest update for RDP 8.0 of [MS-RDPBCGR]

    http://msdn.microsoft.com/en-us/library/cc240445.aspx

    2.2.14 Network Characteristics Detection:

    2.2.14 Network Characteristics Detection 

    2.2.14.1 Server Auto-Detect Request PDU

    2.2.14.1.1 RTT Measure Request (RDP_RTT_REQUEST)

    2.2.14.1.2 Bandwidth Measure Start (RDP_BW_START)

    2.2.14.1.3 Bandwidth Measure Payload (RDP_BW_PAYLOAD)

    2.2.14.1.4 Bandwidth Measure Stop (RDP_BW_STOP)

    2.2.14.2 Client Auto-Detect Response PDU 

    2.2.14.2.1 RTT Measure Response (RDP_RTT_RESPONSE) 

    2.2.14.2.2 Bandwidth Measure Results (RDP_BW_RESULTS)

    Please make sure that you use RDP 8.0 to connect a remote Windows 8 or Windows Server 2012.

    If issue persists, please provide us the complete event log and let us more details what you are doing.

    Hope this helps.


    Jeremy Wu

    TechNet Community Support



    Tuesday, November 12, 2013 10:21 AM
  • I'm connecting using RDP 8.1 and all settings on the client are set to enable remotefx and allow automatic network detection. I can connect to a 2012 server and not get the message below. It only happens on the 2012 R2 server and both servers are using the same group policy.

    Log Name:      Microsoft-Windows-RemoteDesktopServices-RdpCoreTS/Operational
    Source:        Microsoft-Windows-RemoteDesktopServices-RdpCoreTS
    Date:          11/15/2013 2:39:30 AM
    Event ID:      101
    Task Category: RemoteFX module
    Level:         Warning
    Keywords:     
    User:          NETWORK SERVICE
    Computer:      xx.xx.com
    Description:
    The network characteristics detection function has been disabled because of Reason Code: 2(Server Configuration)..
    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="Microsoft-Windows-RemoteDesktopServices-RdpCoreTS" Guid="{1139C61B-B549-4251-8ED3-27250A1EDEC8}" />
        <EventID>101</EventID>
        <Version>0</Version>
        <Level>3</Level>
        <Task>4</Task>
        <Opcode>16</Opcode>
        <Keywords>0x4000000000000000</Keywords>
        <TimeCreated SystemTime="2013-11-15T08:39:30.650329300Z" />
        <EventRecordID>6062</EventRecordID>
        <Correlation ActivityID="{F420884F-9CA8-42B5-AC6D-6E034F330000}" />
        <Execution ProcessID="2172" ThreadID="2680" />
        <Channel>Microsoft-Windows-RemoteDesktopServices-RdpCoreTS/Operational</Channel>
        <Computer>xx.xx.com</Computer>
        <Security UserID="xxx" />
      </System>
      <EventData>
        <Data Name="ReasonString">Reason Code: 2(Server Configuration).</Data>
      </EventData>
    </Event>

    Friday, November 15, 2013 8:48 AM
  • Hi,

    Thank you for the reply.

    I am trying to involve someone to further look at this issue. There might be some time delay. Appreciate your patience.

    Thank you for your understanding and support.


    Jeremy Wu

    TechNet Community Support

    Saturday, November 16, 2013 8:28 AM
  • Would you please perform the following steps and see if the issue can be resolved?

    1. Change the target resoltion.

    2. Remove the group policy assigned.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Monday, November 18, 2013 12:32 PM
  • No change.

    I've disjoined it from the domain and connected at a 1366x768 resolution. I was connecting at a 1024x768 previously.

    Bryan

    Monday, November 18, 2013 2:17 PM
  • Would you please disable Firewall to see if the issue can be resolved?


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Thursday, November 21, 2013 2:47 PM
  • I disabled the firewall completely and the issue still exists.

    Bryan

    Friday, November 22, 2013 4:14 AM
  • To such  issue, it is not an efficient way to work in this community since we may need more resources, for example memory (application) dump or ETL trace, which is not appropriate to handle in community. I’d like to suggest that you submit a service request to MS Professional tech support service so that a dedicated Support Professional can further assist with this request. 

    Please visit the below link to see the various paid support options that are available to better meet your needs. http://support.microsoft.com/default.aspx?id=fh;en-us;offerprophone



    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Monday, December 09, 2013 12:26 PM
  • Hi bryans2k,

    As Susie suggested, you may need to submit a service request. Therefore, may I obtain your permission to temporary archive this case?

    If there is any question, please feel free to let us know.

    Thanks.


    Jeremy Wu

    TechNet Community Support

    Thursday, December 12, 2013 9:21 AM
  • hi all ,

    Were you able to solve the problem...I'm experiencing the same issue: W2k12R2 connecting by using a RDP8.1 client:

    The network characteristics detection function has been disabled

    Thx

    Dimi

    Thursday, December 26, 2013 4:22 PM
  • No because they wanted me to submit a ticket which I don't currently have time for as it was just a test system.

    Thanks,

    Bryan

    Friday, January 17, 2014 8:50 PM
  • Just an update, I was able to get it to stop appearing when I used group policy to force network detection to be enabled.

    Saturday, January 25, 2014 5:38 PM
  • So my conclusion is that network detection is some how broken in R2. I have Windows 8 Pro clients that work fine with server 2012 and don't with 2012 R2. When I disable network detection they begin to half way work again but are still not performing at server 2012's level. The network detection seems to also break other clients that run on thin clients such as Wyse.
    Wednesday, February 19, 2014 9:45 PM
  • Just an update, I was able to get it to stop appearing when I used group policy to force network detection to be enabled.

    Hi Bryan

    Could you provide details on how you accomplished this?

    I'm running Hyper-V 2012 R2 (workgroup mode), trying to connect from Win8.1 Pro. Same trouble.

    Thanks,
    Jeff Bowman
    Fairbanks, Alaska

    Thursday, April 17, 2014 2:53 AM
  • Just an update, I was able to get it to stop appearing when I used group policy to force network detection to be enabled.

    Hi Bryan

    I'm still looking for a way to do this. I'm spelunking through GPOs but I'm not finding anything that looks like this.

    Also, I don't know whether you're talking about the client, the server or both.

    It'd be really great to hear from you on this.

    Thanks,
    Jeff Bowman
    Fairbanks, Alaska

    Thursday, April 24, 2014 11:40 PM
  • Hi!

    Did you apply GPO to server or clients connecting to it?

    Thanks!

    Gunars

    Tuesday, May 13, 2014 12:11 PM
  • Did you apply GPO to server or clients connecting to it?

    Hi Gunars

    I've been hoping for a reply from Bryan as to how exactly he resolved this by "[using] group policy to force network detection to be enabled." He doesn't appear to be subscribed to this thread anymore, however, as he hasn't replied.

    As I've mentioned, I'm very interested in learning what folks (including yourself) mean by "applying GPO." How does one do this? To which GPO object are you referring?

    Could you provide some more detail? I'm familiar with how to access the GPO store, but not much further than that. Also, how does one access GPO on Hyper-V Server 2012 R2, which is in essence a Core edition?

    Thanks,
    Jeff Bowman
    Fairbanks, Alaska

    Wednesday, May 14, 2014 12:02 AM
  • In Active Directory (if you have implemented that) Group Policy Management chose new group policy

    For servers I found this GPO: Computer Configuration->Windows Settings->Adm Templates -> Windows components -> Remote Desktop Session Host -> Connection -> Select network detection on server

    Couldn't find any client configuration in GPO.

    Gunārs

    Wednesday, May 14, 2014 8:05 AM
  • For servers I found this GPO: Computer Configuration->Windows Settings->Adm Templates -> Windows components -> Remote Desktop Session Host -> Connection -> Select network detection on server

    Hi Gunārs

    I found that setting, albeit under a slightly different path:


    Server Policy
    \Computer Configuration
     \Administrative Templates
      \Windows Components
       \Remote Desktop Services
        \Remote Desktop Session Host
          \Connections
           =>Select network detection on the server

    The change worked briefly on one of our servers, but not the other. Then it suddenly didn't work on either of them.

    I applied the latest round of updates to both servers and it started working reliably and consistently on both, no matter what the GPO setting.

    I can't be sure, but I suspect it might have been this update. The deadlock description seems to fit the symptom.

    Nevertheless, I very much appreciate your advice on how to find the RDP GPOs. I'll be able to use them in the future.

    Thanks,
    Jeff Bowman
    Fairbanks, Alaska



    Friday, May 16, 2014 6:17 AM
  • Server Policy
    \Computer Configuration
     \Administrative Templates
      \Windows Components
       \Remote Desktop Services
        \Remote Desktop Session Host
          \Connections
           =>Select network detection on the server

    That is the option I used. I just tested again and it does indeed force network detection. I still don't know why it's displayed by default though.

    Bryan

    Tuesday, July 22, 2014 3:03 PM
  • That is the option I used. I just tested again and it does indeed force network detection. I still don't know why it's displayed by default though.

    Yes indeed. I can now reliably connect to Hyper-V 2012 R2 from Win8.1 clients. (Note: a reboot is required after setting the GPO.)

    Thank you for your assistance.

    Thanks,
    Jeff Bowman
    Fairbanks, Alaska




    16 hours 14 minutes ago
  • Hi Bryan,

    The 101 warning event is normal for Server 2012 R2 since Connect Time Detection is disabled by default and Continuous Network Detection is enabled by default.  For Server 2012 (non R2) both are enabled by default.

    The problems you are seeing from Windows 8 and Wyse thin clients may be caused by a network issue specific to your environment and/or some sort of compatibility issue between the client versions and the server.  In general I have not had any problems connecting from Windows 8 and Windows 8.1 to Server 2012 R2 via LAN and over the Internet via RDG with the default detection setting.

    As a rule I would always recommend you use RDP 8.1 clients to connect to Server 2012 R2 if possible.

    -TP

    15 hours 34 minutes ago