none
Calculo de Horas Negativas e que excedem 24 horas

    Question

  • Galera,

    Será que alguém consegue resolver um problema no excel de calculo de horas negativas e que excedem 24h?
    Coloquei um modelo de planilha no link representando o que preciso:

    http://www.sendspace.com/file/j54e55

    obrigado.

    Friday, April 26, 2013 5:21 PM

Answers

  • Olá Junior.

    Não consegui entender sua dúvida. Seus comentários na planilha estão confusos. Explique melhor pra ver se consigo te ajudar.

    De qualquer forma, vai uma dica: O Excel não exibe datas/horas negativas, mas consegue trabalhar normalmente com esses valores! Para contornar o problema de exibição, sugiro que você utilize uma célula oculta para os resultados das fórmulas e uma célula visível apenas para mostrar os valores de forma "amigável", através da construção de uma string (nenhuma fórmula pode referenciar a esta célula, senão ocorrerá erro. Referencie sempre à célula que você ocultou). Por exemplo, se a sua célula oculta for B2 (que pode conter horas negativas) escreva na célula que ficará visível:

    =SE(B2<0;"-"&TEXTO(-B2;"[h]:mm");B2)
    Espero que ajude.


    Filipe Magno

    Monday, April 29, 2013 1:26 AM

All replies

  • Olá Junior, boa tarde.

    Não tenho como acessar a sua planilha no momento. No entanto, você já chegou a realizar o cálculo das horas com base nesses critérios disponibilizados nestes tutoriais.

    http://office.microsoft.com/pt-br/excel-help/calcular-a-diferenca-entre-duas-horas-HP003056108.aspx

    Espero ter ajudado.


    Obrigado por contactar o fórum Microsoft Technet!

    Friday, April 26, 2013 6:47 PM
  • Já sim. Tentei e não resolveu não.

    Friday, April 26, 2013 7:25 PM
  • Olá Junior.

    Não consegui entender sua dúvida. Seus comentários na planilha estão confusos. Explique melhor pra ver se consigo te ajudar.

    De qualquer forma, vai uma dica: O Excel não exibe datas/horas negativas, mas consegue trabalhar normalmente com esses valores! Para contornar o problema de exibição, sugiro que você utilize uma célula oculta para os resultados das fórmulas e uma célula visível apenas para mostrar os valores de forma "amigável", através da construção de uma string (nenhuma fórmula pode referenciar a esta célula, senão ocorrerá erro. Referencie sempre à célula que você ocultou). Por exemplo, se a sua célula oculta for B2 (que pode conter horas negativas) escreva na célula que ficará visível:

    =SE(B2<0;"-"&TEXTO(-B2;"[h]:mm");B2)
    Espero que ajude.


    Filipe Magno

    Monday, April 29, 2013 1:26 AM