none
Remote Desktop disabled, Remote Desktop configuration options greyed out

    Question

  • Hello,

    I'm having problems with some of my servers, so far Windows Server 2008 and Windows Server 2008 R2. I tried to connect to a Domain Controller with RDP (as I usually do) but the connection failed.

    I logged in locally to the Domain Controller to find out that Remote Desktop is disabled. Then I opened the Remote Desktop options window to try to enable it, to find out that all options are greyed out (so I'm not able to re-enable it).

    This is a domain environment and I'm a Domain Admin. I checked for viruses and I couldn't find any. All Terminal Services/Remote Desktop services are enabled and started.

    I think it could be related to a group/local policy, but checked the policies that I know and they were the way they should be.

    Any other ideas would be greatly appretiated.

    Monday, November 25, 2013 4:25 PM

Answers

  • Hi,

    You may check which Group Policy Object is affecting your server using gpresult.  On a problem server, please open an administrator command prompt and enter the following commands:

    gpresult /z>gpresult.txt

    notepad gpresult.txt

    Please examine the output for settings related to Remote Desktop Services and then modify the GPO as needed.  After making a GPO change you should run gpupdate /force on the servers so that the new settings will take effect right away.

    Thanks.

    -TP

    Monday, November 25, 2013 9:10 PM

All replies

  • Which group policies did you check specifically?  Make sure to check all the settings under the following sets of policies:

    Computer Configuration\Policies\Administrative Templates\Windows Components\Remote Desktop Services\Remote Desktop Session Host\Connections            

  • User Configuration\Policies\Administrative Templates\Windows Components\Remote Desktop Services\Remote Desktop Session Host\Connections            

Monday, November 25, 2013 5:40 PM
  • Hi,

    You may check which Group Policy Object is affecting your server using gpresult.  On a problem server, please open an administrator command prompt and enter the following commands:

    gpresult /z>gpresult.txt

    notepad gpresult.txt

    Please examine the output for settings related to Remote Desktop Services and then modify the GPO as needed.  After making a GPO change you should run gpupdate /force on the servers so that the new settings will take effect right away.

    Thanks.

    -TP

    Monday, November 25, 2013 9:10 PM