none
SharePoint 2013 Workflow Not Publishing

    Question

  • Greetings,

    I have created a simple approval workflow, using SharePoint Designer 2013, and am unable to publish it.  I check the workflow for errors and none are reported.  When I attempt to publish it, I receive the following error:

    --------------------------

    Microsoft.SharePoint.SPEndpointAddressNotFoundException: There are no addresses available for this application.
       at Microsoft.SharePoint.SPRoundRobinServiceLoadBalancer.BeginOperation()
       at Microsoft.SharePoint.Administration.SPServiceApplicationProxyBase`1.ExecuteOnChannel(Boolean requireDelegation, Action`1 codeBlock)
       at Microsoft.SharePoint.AppManagement.AppManagementServiceApplicationProxy.GetScaleOutDatabaseMap()
       at Microsoft.SharePoint.SPScaleOutDatabaseMap.GetMapCacheEntries

    --------------------------

    Can anyone tell me what the problem might be?

    Thank you!

    Sunday, April 21, 2013 3:48 PM

Answers

All replies

  • Have you installed/configured workflow manager and it's dependencies? You also need to create app Management service as well as need to configure user profile sync service to make the workflow working. You also should not use system account to develop/publish/run workflow.

    Thanks,
    Sohel Rana
    http://ranaictiu-technicalblog.blogspot.com

    Monday, April 22, 2013 12:49 AM
  • Hi Sohel,

    Thank you for the response.  Yes, I have installed and configured workflow manager, its dependencies, an App Management Service and user profile service.  I am not logged in as a system account either.

    The error is:

    -----------------------

    Microsoft.SharePoint.SPEndpointAddressNotFoundException: There are no addresses available for this application.
       at Microsoft.SharePoint.SPRoundRobinServiceLoadBalancer.BeginOperation()
       at Microsoft.SharePoint.Administration.SPServiceApplicationProxyBase`1.ExecuteOnChannel(Boolean requireDelegation, Action`1 codeBlock)
       at Microsoft.SharePoint.AppManagement.AppManagementServiceApplicationProxy.GetScaleOutDatabaseMap()
       at Microsoft.SharePoint.SPScaleOutDatabaseMap.GetMapCacheEntries

    -----------------------

    Thank you!

    Tuesday, April 23, 2013 7:01 PM
  • As pert the stacktrace, the problem might be with app management service. Can you please delete and recreate the app management service with proxy and try? Please also try to register the workflow manager with sp-registerworkflowmanager command using force.

    Thanks,
    Sohel Rana
    http://ranaictiu-technicalblog.blogspot.com


    Wednesday, April 24, 2013 3:36 AM
  • I am having this exact issue.  I deleted and recreated the app management service, with no luck.  Do I need to re-register workflow manager with SharePoint?  
    Thursday, September 26, 2013 10:01 PM
  • I did both of the action you said. But still no-luck.

    I have registered workfolow manager with my application.

    SPEndpointAddressNotFoundException:

    Sunday, March 16, 2014 8:43 AM
  • Posted rest of the solution for this issue on goto my comments : Solution for EndPointNotFoundException
    Sunday, March 16, 2014 9:14 AM