none
Stop monitoring some Exchange servers

    Question

  • I have several Exchange 2010 servers and need to stop monitoring Exchange on some of them (with a common string in the name). Without impacting other Windows monitoring, how do I prevent the Exchange discovery from catching these servers?

    Thanks.

    Monday, December 30, 2013 11:07 PM

Answers

  • Hi, yes!

    Create a Group (in an Exchange specific MP, or follow your override mp standars) and populate it dynamically with Windows Server instances, using Principal Name with a proper match for your common string.

    Then go to Authoring->Management Pack Objects->Object Discoveries.

    Type Exchange in the Look for search box.

    Now, scroll through the list of discoveries and for EACH that is targeted at Windows Server (I found these):

    • Microsoft.Exchange.2010.ClientAccessRole.DiscoveryRule
    • Microsoft.Exchange.2010.EdgeTransportRole.DiscoveryRule
    • Microsoft.Exchange.2010.ClientAccessRole.DiscoveryRule
    • Microsoft.Exchange.2010.MailboxRole.DiscoveryRule
    • Microsoft.Exchange.2010.HubTransportRole.DiscoveryRule
    • Microsoft.Exchange.2010.UnifiedMessagingRole.DiscoveryRule
    • Microsoft.Exchange.2010.EdgeTransportRole.DiscoveryRule

    create an Override (in the Exchange specific MP) that, for the Group you created previously, sets the enabled parameter to false (do not use the "Disable the Object Discovery" button)

    Now, last but not least, you need to run the

    Remove-SCOMDisabledClassInstance PowerShell commandlet.

    on a Management Server. If you have a large management Group, please run this at a time when you are causing as Little disturbance as possible.

    /Roger


    This posting is provided "AS IS" with no warranties, and confers no rights.

    • Marked as answer by mhashemi Tuesday, January 07, 2014 8:08 PM
    Tuesday, December 31, 2013 12:04 AM

All replies

  • you can put the server in maint mode OR you can override disable the seed discovery of Exchange on the servers, then run:

    remove-disabledmonitoringobject from the scom powershell command window.


    Regards, Blake Email: mengotto<at>hotmail.com Blog: http://discussitnow.wordpress.com/ If my response was helpful, please mark it as so, if it answered your question, then please also mark it accordingly. Thank you.

    Monday, December 30, 2013 11:40 PM
  • Hi, yes!

    Create a Group (in an Exchange specific MP, or follow your override mp standars) and populate it dynamically with Windows Server instances, using Principal Name with a proper match for your common string.

    Then go to Authoring->Management Pack Objects->Object Discoveries.

    Type Exchange in the Look for search box.

    Now, scroll through the list of discoveries and for EACH that is targeted at Windows Server (I found these):

    • Microsoft.Exchange.2010.ClientAccessRole.DiscoveryRule
    • Microsoft.Exchange.2010.EdgeTransportRole.DiscoveryRule
    • Microsoft.Exchange.2010.ClientAccessRole.DiscoveryRule
    • Microsoft.Exchange.2010.MailboxRole.DiscoveryRule
    • Microsoft.Exchange.2010.HubTransportRole.DiscoveryRule
    • Microsoft.Exchange.2010.UnifiedMessagingRole.DiscoveryRule
    • Microsoft.Exchange.2010.EdgeTransportRole.DiscoveryRule

    create an Override (in the Exchange specific MP) that, for the Group you created previously, sets the enabled parameter to false (do not use the "Disable the Object Discovery" button)

    Now, last but not least, you need to run the

    Remove-SCOMDisabledClassInstance PowerShell commandlet.

    on a Management Server. If you have a large management Group, please run this at a time when you are causing as Little disturbance as possible.

    /Roger


    This posting is provided "AS IS" with no warranties, and confers no rights.

    • Marked as answer by mhashemi Tuesday, January 07, 2014 8:08 PM
    Tuesday, December 31, 2013 12:04 AM
  • Roger, that looks good. I completed the steps, but the servers are still in SCOM. I've asked the admin of those boxes, to restart the health service and delete the health state folder. We'll see if that does the trick.
    Thursday, January 02, 2014 10:40 PM
  • I followed the steps, but still see the non-monitored servers in the SCOM console (under Exchange 2010). I thought that deleting the health state folder and restarting the service would fix that, but it didn't. 

    How do I get SCOM to stop considering these servers as Exchange?

    Thanks.

    Monday, January 06, 2014 4:56 PM
  • Hi!

    Are the servers, where you want to stop monitoring Exchang, part of the same Exchange Organization as the ones still being monitored?

    /Roger


    This posting is provided "AS IS" with no warranties, and confers no rights.

    Monday, January 06, 2014 8:38 PM
  • For some reason, the override didn't take. When I viewed the summary, there was nothing. I re-applied the override and Exchange is no longer monitored. Thanks.
    Tuesday, January 07, 2014 8:08 PM