none
SP Link Location

    Question

  • I'm troubleshooting a link location within SharePoint.  I can access the in SharePoint and see my Subsites across the top toolbar; however there's a link located on the far left of my toolbar with the Intranet Site name that I can not locate whatsoever.  I'd like to get this link changed so I can set it to my homepage address http://kibser/default.aspx as it's now going to a http://kibser/SitePages/Home.aspx

     

     

    The KIB Elect Intranet is the link I'd like to change however I'm not having any luck locating anything in either Central Administration or within SP Designer to allow this to happen.

    Any help and/or suggestions would be greatly apprecaited!

    Thanks,
    Brian

    Monday, October 10, 2011 1:43 PM

Answers

  • Go to Site Settings > Look and Feel section > Welcome page (it shows up if you have publishing feature enabled). In SP Designer, you can right click on any other page and select 'set as homepage'
    • Proposed as answer by KSDN Monday, October 10, 2011 2:43 PM
    • Marked as answer by Margriet BruggemanMVP Tuesday, April 10, 2012 1:54 PM
    Monday, October 10, 2011 2:06 PM

All replies

  • Go to Site Settings > Look and Feel section > Welcome page (it shows up if you have publishing feature enabled). In SP Designer, you can right click on any other page and select 'set as homepage'
    • Proposed as answer by KSDN Monday, October 10, 2011 2:43 PM
    • Marked as answer by Margriet BruggemanMVP Tuesday, April 10, 2012 1:54 PM
    Monday, October 10, 2011 2:06 PM
  • Site Settings > Look & Feel > Welcome Page is displaying the proper page.  It's the link located under my image that's point to an incorrect page (It's labeled KIB Electronics Intanet in the image).  My site doesn't like my SharePoint Designer install so I'm hosing it and bringing it back to see if it works together a little better.


    This may clear it up a bit; In SharePoint Designer I can select the following:

    Site Objects > Home (KIB Electronics Intranet) > (Custumization Tab) Edit site Home Page

    I will receive an error saying the following; Server could not complete your request; for more info click the details button.

    Details states this:

    soap:ServerServer was unable to process request. ---> The file http://###/SitePages/Home.aspx does not exist.


    Monday, October 10, 2011 2:41 PM
  • That's strange. If you go to site settings, what do you see under navigation or top link bar properties? 

    Another way to set home page would be to open the desired home page in the browser, show ribbon, and under 'Page' section there will be a button called "Make Homepage".

    And then of course there's always the powershell way:

    $site = Get-SPSite http://kibserver8
    $web = $site.RootWeb
    $folder = $web.RootFolder
    $folder.WelcomePage = "Pages/default.aspx"
    $folder.update()

    Monday, October 10, 2011 3:52 PM
  • In Site Settings \ Navigation I see this below.  My homepage is pulling up properly everytime through GP and also when selecting Home in the browser; however some users would like to hit the Logo and/or KIB Electronics Intranet (located next to the administrative tab) tab on the Top Bar Link and get back to the main page. 

    My problem is that the KIB Electronics Intranet Tab does not show up in Navigation Editing and Sorting option within the Navigation Page.  I created a home button to get the job done but I now have a button that goes to a dead link on the Top Bar.

    Monday, October 10, 2011 6:04 PM
  • I'm having the exact same problem. Did you ever find a solution?
    Friday, August 29, 2014 6:17 PM
  • It was 3 or 4 years ago.....foggy memory but I'm pretty sure I did this:

    Try Site Actions > Site Settings > Look & Feel \ Naviation > Navigating Editing and Sorting Field.  It's been a very long time since that day.  Try that out and let me know.

    Friday, August 29, 2014 6:37 PM