none
SBS2003 to SBS2008 No Error, Public Folder Instances will not empty on moving replicas

Answers

  • Replication has completed without an error!  Fixing the user lists to show on SBS Console did the trick!  Now I can move on to next item in the instruction...

    Thanks for all the replies.

    Wednesday, March 07, 2012 1:52 PM

All replies

  • Enable diagnostic logging on sbs 2003 and then restart msexchangeIS and post back the events in application log,also have a look at:

    http://www.msexchange.org/articles/public-folder-replication-troubleshooting.html

    Sunday, March 04, 2012 10:49 PM
  • After setting "max" for diagnostic loging" and restarting the msexchangeIS, causes only one error:

    MSExchangeIS Public Store
    Replication Errors:
    Event ID: 3093
    Error -2147221233 reading property 0x67010003 on object type tbtOwningFolders from database "First Storage Group\Public Folder Store (TCPMSRV)". 

    But http://support.microsoft.com/kb/225090 states it's by design and is harmless.

    There are several identical warning events:

    Computer: SBS2003 (old server)

    Administrator@tricitypm.com failed an operation on folder /O=FIRST ORGANIZATION/OU=FIRST ADMINISTRATIVE GROUP/CN=RECIPIENTS/CN=SYSTEM CONFIGURATION18FD1CAE483B30EDC997E083671389A4FF0000 on database "First Storage Group\Public Folder Store (TCPMSRV)" because the user did not have the following access rights: 'Delete' 'Read Property' 'Write Property' 'Create Message' 'View Item' 'Create Subfolder' 'Write Security Descriptor' 'Write Owner' 'Read Security Descriptor' 'Contact' The entry ID of the folder is in the data section of this event.

    Strangely, we have no user name "Administrator" in AD.  This happens even after http://support.microsoft.com/kb/313866.

    Other event messages are just infos repeating:

    0 messages are waiting to be transferred out to the Microsoft Exchange MTA (sent) from gateway /o=First Organization/ou=first administrative group/cn=Configuration/cn=Connections/cn=SMTP (TCPMSRV)/cn={A30A5622-17F6-4BC8-9DD4-747F48F917D3}. 
    There are no messages ready to transfer out (send) for gateway /o=First Organization/ou=first administrative 
    group/cn=Configuration/cn=Connections/cn=SMTP 
    (TCPMSRV)/cn={A30A5622-17F6-4BC8-9DD4-747F48F917D3}. The transfer out thread is sleeping. 
    There are no messages ready to transfer out (send) for gateway /o=First Organization/ou=first administrative 
    group/cn=Configuration/cn=Connections/cn=SMTP 
    (TCPMSRV)/cn={A30A5622-17F6-4BC8-9DD4-747F48F917D3}. The transfer out thread is sleeping. 

    Also, ran best practice analyzers on both server and repaired most of the errors, which wasn't there before the migration.  One thing I noticed on the SBS2008, all users are not displaying on SBS Console although they display in AD.  After fixing it and restarting "Move All Replicas", an hour later, list in "Public Folder Instanaces" has shrunk to less than half.  Perhaps, it's working now.  Also, the Outlook clients were getting errors, but now they started to work again.  I'll give until tomorrow to see what developes.  I'm getting excited..



    Monday, March 05, 2012 12:05 AM
  • For users not displaying in sbs console you can refer to:

    http://blogs.technet.com/b/sbs/archive/2008/09/22/why-are-some-of-my-users-not-displaying-in-the-sbs-console.aspx

    If after doing this the replicas have moved then you might have been missing some permissions.

    Monday, March 05, 2012 9:28 AM
  • Fine, it seems that the public folder replication works properly both on server side and client side. So let's monitor the final status. If there is any update from your side, please feel free to let me know.

    Regards,

    James


    James Xiong

    TechNet Community Support

    Tuesday, March 06, 2012 1:47 AM
  • Replication has completed without an error!  Fixing the user lists to show on SBS Console did the trick!  Now I can move on to next item in the instruction...

    Thanks for all the replies.

    Wednesday, March 07, 2012 1:52 PM