none
How to delete tape already written in DPM 2010

    Question

  • Hello people,

    I have some issue to delete tape in DPM 2010. I created a protection group to make every day a full backup with following settings:

    -short term protection using tape
    -encrypted data
    -retention range 4 weeks, daily and full backup

    the problem is that when I put in the library an already written tape, it can't be re-write again because an error appear:

    "

    The selected tapes cannot be erased because they belong to protection groups.

    You need to stop protection of the associated protection groups before you can erase the tapes. The protection group that a tape belongs to is listed in the Protection Group column.

    "

    How can I proceeed, i couldn't find any solutions. How can I stop the protection on a group to erase tape?

    thank you

    Alessandro

    Thursday, March 08, 2012 11:19 AM

Answers

  • Hello All,

    After many times I could use the script. there was an "=" on another line, probably mine copy-paste error :D
    By the way, it works great, now the voice mark tape as free appeared in the right menù in the section management.
    thanks everybody for you patiente and time

    thank you

    Tuesday, April 24, 2012 7:31 AM

All replies

  • Hi,

    You can use the following power shell script to expire all RP on a given tape, then mark it free.

       http://blogs.technet.com/dpm/archive/2007/09/04/cli-script-force-mark-tape-as-free.aspx

    If you have a standalone tape drive - get the script from this post:

        http://social.technet.microsoft.com/Forums/en-US/dpmtapebackuprecovery/thread/ab431377-665e-44e3-956d-e74a71000d77


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.

    Thursday, March 08, 2012 5:01 PM
  • Hello Mike, sorry for the late, I was busy on a workproject.
    I tried to lunch the script but an errore accoured.

    what is exactly the command to lunc script in dpm management shell? I used:

    ./file_name.ps1
    ./file_name

    .\file_name.ps1
    .\file_name

    regards

    Ale

    Friday, March 30, 2012 11:21 AM
  • Hello Allessandro,

    you have to add the parameter "-forcefree"

    whole command: .\file_name.ps1 -forcefree

    regards

    Phil


    Friday, March 30, 2012 11:33 AM
  • Hi Ale,

    Nothing special required, just be sure you are in the DPM powershell and not the Windows powershell.  It should prompt you for DPM servername, ask to select the library name (copy / paste), and type in the slot-# as seen below.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.

    Friday, March 30, 2012 3:06 PM
  • Hello All,

    After many times I could use the script. there was an "=" on another line, probably mine copy-paste error :D
    By the way, it works great, now the voice mark tape as free appeared in the right menù in the section management.
    thanks everybody for you patiente and time

    thank you

    Tuesday, April 24, 2012 7:31 AM