none
Exchange server 2003 SMTP

    Question

  • Hi Guys

    I'm having issue with Exchange Server 2003 R2 Enterprise, it was working perfectly (local and external), all of the sudden sending and receiving local mails successful, sending mail to external mail bounces back with error code: "5.5.0 smtp;553 sorry, that domain isn't in my list of allowed rcpthosts" when using the mail hosting SMTP (GoDaddy), not, when i configure Exchange server to use smarthost, there was no error but when i go Exchange System Manager, it's in the queue "Retry"

    Steps taking:

    - Configure smart host for SMTP routing
    - Configure DNS forwarder to Google DNS, ISP DNS, etc.
    - Perform Kaspersky antivirus scan

    -Uninstall antivirus

    Still to no avail

    Please help



    yours affectionate Niyi Okunola

    Friday, September 20, 2013 2:54 PM

Answers

All replies

  • Your problem looks like something you should discuss with your ISP; my guess is that they are the one blocking your e-mail.


    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."

    Saturday, September 21, 2013 5:08 PM
  • Hi Niyi,

    Like Ed said, this issue related on ISP.

    The fix for this situation is to change the SMTP server in the mail client to match the one provided by the ISP.

     

    Following desription is what I found, originally posted by akumi:

    The error means that we are trying to send email using the wrong SMTP server.

    SMTP related errors may have different numbers and slightly different wording, eg, "Relay access denied for...", but are all related to the same problem.

    The SMTP server that we use to send email is not determined by who hosts our email, but rather is a service of our Internet connection provider. All ISP's provide their customers with SMTP servers, regardless of their email address.

    One of the most important reasons for doing this is so spammers cannot connect to an unauthorized SMTP server and use it to send mountains of spam.

    Occasionally, spammers find these "open" systems and flood them with mail. These systems are known as "open relays" and are the result of careless configuration by the operator.

    Client commonly see this error when they configure their PC at work, then try to use the same configuration at home, where the Internet connection is provided by a different ISP.

     

    More details in the following link, just for your reference:

    http://forums.msexchange.org/m_150274600/mpage_1/key_/tm.htm#150274611

     

    Hope it is helpful

     

    Thanks

    Mavis

    Wednesday, September 25, 2013 2:18 AM
  • Hi Guys

    Thanks for your fast response.

    My concern now is that on and SBS 2008, SBS 2011, when configuring smart using ISP setting, it requires smart host address, username and password, but on Exchange server 2003, it doesn't ask for username and password.

    And i changed it from mail host SMTP settings to ISP smarthost and still no avail.

    Does it mean that without username and password it will work on Exchange server 2003.

    Further more, the ISP let me  understood that a static IP address has being assigned for the client which simply means that port 25 for SMTP open and still to no avail, and the ISP usually use port 26 for non static IP address users, I've tried Port 26 with the smarthost address without the username and password simply because exchange server 2003 doesn't require the username and password for using ISP smarthost.

    Please kindly help.


    yours affectionate Niyi Okunola

    Wednesday, September 25, 2013 3:57 PM
  • Hi Guys

    Thanks for your fast response.

    My concern now is that on and SBS 2008, SBS 2011, when configuring smart using ISP setting, it requires smart host address, username and password, but on Exchange server 2003, it doesn't ask for username and password.

    And i changed it from mail host SMTP settings to ISP smarthost and still no avail.

    Does it mean that without username and password it will work on Exchange server 2003.

    Further more, the ISP let me  understood that a static IP address has being assigned for the client which simply means that port 25 for SMTP open and still to no avail, and the ISP usually use port 26 for non static IP address users, I've tried Port 26 with the smarthost address without the username and password simply because exchange server 2003 doesn't require the username and password for using ISP smarthost.

    Please kindly help.

    yours affectionate Niyi Okunola

    Wednesday, September 25, 2013 3:59 PM
  • I recommend that you post your question in the SBS forum because there are significant differences in the way you set up SBS and Exchange.

    http://social.technet.microsoft.com/Forums/en/smallbusinessserver/threads


    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."

    Wednesday, September 25, 2013 4:30 PM
  • Hi Niyi,

    Sorry for my less known about SBS.

    Please do as Ed said, re-new a question on the SBS forum.

     

    Thanks

    Mavis

    Thursday, September 26, 2013 1:50 AM