none
Task updates not saving - plans reverting to previous dates etc

    Question

  • Hi All,

    I've received an email from one of our PMs. She has logged in to her plan today and tasks that were previously complete and showing 100% and with a completion date have overnight reverted back to their previous status - incomplete and the previous dates are showing instead.

    After calling to discuss it she confirmed that she had published and checked in the plan last night, and closed it down properly. She waited until she saw the "publish complete" messages etc.

    She, and this project, are currently being audited so it's an urgent matter and it's causing us some concern. Has anyone encountered this before? Any clues as to what may be going on please?

    Thanks in advance for your help!

    Clair.

    Tuesday, October 15, 2013 9:48 AM

All replies

  • Check the tasks that were impacted.  Has Work or Duration changed on those tasks?



    • Edited by Edward Hanna Wednesday, October 16, 2013 12:39 AM Remove signature
    Wednesday, October 16, 2013 12:39 AM
  • Make sure that the changes were committed to the project on the server and not a local version. (see recent projects in Project Professional)

    we had some weird isses like that but most of the time the users did something wrong or did not wait.

    Installing CU1 can help too.

    Good luck!

    Maxim

    Wednesday, October 16, 2013 12:38 PM
  • Service Pack 2 corrects an issue that is similar to what you are experiencing--

    When status updates are accepted, the status update job will show that the job completed successfully;  however, the update apply process failed and the submitted actuals do not show up in the project plan and subsequent downstream reports.





    • Edited by Edward Hanna Wednesday, October 16, 2013 8:23 PM Remove Signature Line
    Wednesday, October 16, 2013 8:23 PM
  • I've seen similar and have attributed it to two potential causes:

    1) Some sort of error in the resource pool, so when I hit save, it doesn't actually save.  In this case, it doesn't sound like that as the status message is displayed.

    2) User error.....the task is done, then I change duration, etc.

    To help troubleshoot, I wrote the blog post below.  If you're comfortable in SQL and have daily archiving set up, you can look in past versions of the schedule to see the status of specific tasks.

    http://azlav.umtblog.com/2013/07/12/quick-and-dirty-project-server-forensics-rummaging-in-the-archive-attic/

    It helps isolate when the problem is happening and allows you to put some data on it.


    Andrew Lavinsky [MVP] Blog: http://azlav.umtblog.com Twitter: @alavinsky

    Thursday, October 17, 2013 2:08 AM
  • Hi All,

    Thanks for your responses!

    I have asked her if work or duration had changed but she was unwilling to go back through and check for me...

    I do suspect it's more user error than anything else but I wanted to check here before I said as much. We are also looking in to the Service Pack 2 option as well, so thank you for the suggestion.

    Thanks all!

    Clair.

    Wednesday, October 23, 2013 10:48 AM
  • How about trying "work-plan cleansing"?
    Thursday, October 24, 2013 4:09 PM
  • Hello Clair,

    I've been having the same problem... on multiple projects.  The percent complete is correct until users enter timesheet information, then the tasks change to less than 100% complete.  This happens for tasks that do not have time logged against them.    How was it resolved?

    Thanks,

    Mike

    Monday, December 09, 2013 7:43 PM