none
Unattend Installation

    Question

  • Hi there.

    I'm attempting to test an unattended installation I built. I'm doing this in a VM (Virtual Box) I've tried fixed size, and dynamic. VHD and VDI. Both return the same error 

    Windows cannot be installed ot the selected parittion. Installation requires at least 14053mb of free space. To install windows, free additional space and restart the installation.

    I just created this VHD (currently fixed, 25gb) it should be 'empty'

    Here is my autounattended.xml

    <?xml version="1.0" encoding="utf-8"?>
    <unattend xmlns="urn:schemas-microsoft-com:unattend">
        <settings pass="windowsPE">
            <component name="Microsoft-Windows-International-Core-WinPE" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="NonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <SetupUILanguage>
                    <UILanguage>en-US</UILanguage>
                </SetupUILanguage>
            </component>
            <component name="Microsoft-Windows-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="NonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <DiskConfiguration>
                    <Disk wcm:action="add">
                        <DiskID>0</DiskID>
                        <WillWipeDisk>true</WillWipeDisk>
                        <CreatePartitions>
                            <!-- System partition -->
                            <CreatePartition wcm:action="add">
                                <Order>1</Order>
                                <Type>Primary</Type>
                                <Size>100</Size>
                            </CreatePartition>
                            <!-- Windows partition -->
                            <CreatePartition wcm:action="add">
                                <Order>2</Order>
                                <Type>Primary</Type>
                                <Extend>true</Extend>
                            </CreatePartition>
                        </CreatePartitions>
                        <ModifyPartitions>
                            <!-- System partition -->
                            <ModifyPartition wcm:action="add">
                                <Order>1</Order>
                                <PartitionID>1</PartitionID>
                                <Label>System</Label>
                                <Letter>S</Letter>
                                <Format>NTFS</Format>
                                <Active>true</Active>
                            </ModifyPartition>
                            <!-- Windows partition -->
                            <ModifyPartition wcm:action="add">
                                <Order>2</Order>
                                <PartitionID>2</PartitionID>
                                <Label>Windows</Label>
                                <Letter>C</Letter>
                                <Format>NTFS</Format>
                            </ModifyPartition>
                        </ModifyPartitions>
                    </Disk>
                    <WillShowUI>OnError</WillShowUI>
                </DiskConfiguration>
                <ImageInstall>
                    <OSImage>
                        <InstallTo>
                            <DiskID>0</DiskID>
                            <PartitionID>2</PartitionID>
                        </InstallTo>
                    </OSImage>
                </ImageInstall>
                <UserData>
                    <ProductKey>
                        <Key>HYF8J-CVRMY-CM74G-RPHKF-PW487</Key>
                        <WillShowUI>OnError</WillShowUI>
                    </ProductKey>
                    <AcceptEula>true</AcceptEula>
                </UserData>
            </component>
        </settings>
        <settings pass="oobeSystem">
            <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="NonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <OOBE>
                    <NetworkLocation>Home</NetworkLocation>
                    <HideWirelessSetupInOOBE>false</HideWirelessSetupInOOBE>
                </OOBE>
                <DisableAutoDaylightTimeSet>false</DisableAutoDaylightTimeSet>
                <TimeZone>Pacific Standard Time</TimeZone>
            </component>
        </settings>
        <cpi:offlineImage cpi:source="wim:c:/win7/sources/install.wim#Windows 7 PROFESSIONAL" xmlns:cpi="urn:schemas-microsoft-com:cpi" />
    </unattend>
    

    Friday, August 23, 2013 3:05 AM

All replies

  • When you create partition 2, have it Extend = False and specify a size, say 20480.

    On your modify partition for part 2 (c) add Extend = True.

    Friday, August 23, 2013 3:04 PM
  • Hi,

    Please open an elevated command prompt and run diskpart command line.

    Then run list disk and report back here with all the output.

    I will help to check whether there is something incorrect in your disk settings.


    Kate Li

    TechNet Community Support

    Monday, August 26, 2013 5:29 AM
  • I made those changes and now the installation proceeds, however this is not the end goal. If I understand correctly, Expand option will fill the rest of the hard drive.

    We would like this autounattended to work independent of hard drive size, without leaving unallocated space. 

    Tuesday, August 27, 2013 11:38 PM
  • Hi,

    Try to resize partition 1 as below:

    <CreatePartition wcm:action="add">

                                <Order>1</Order>

                                <Type>Primary</Type>

                                <Size>250</Size>

                            </CreatePartition>

    Refer to this article:

    DiskID

    http://technet.microsoft.com/en-US/library/ff716278.aspx 


    Kate Li

    TechNet Community Support

    Tuesday, September 03, 2013 3:28 PM