none
Stop Users Moving\Deleting Folders>> Server 2003

    Question

  • Hi All,

    We have 5 login accounts for each of the years at my school and we want to be able to stop the kids from moving and deleting folders on the network. Can anyone help, with the file\folder level permissions to stop this happening?

    We have a Windows Server 2003 DC and mainly XP and some Win7 clients.

    Your help is greatly appreciated

    Father Merrin
    Sunday, November 17, 2013 4:57 PM

Answers

All replies

  • Hi,

    Based on your description, you can select the share folder, right click and select Properties. On the Properties dialog box, select Security tab. Please don’t assign those users Delete Permission. Then those Kids won’t be able to move and delete the folders.

    Meanwhile, please note, some applications like Microsoft Word require the Delete Permission. When you edit a file, actually you didn’t edit the source files. Just create some provisional copys. If you prevent Word to delete the old files, you would see many previous versions of files with weird filenames and extensions. For detailed explains, please refer to the similar question.

    prevent delete own files and folder in a shared folder

    http://social.technet.microsoft.com/Forums/windowsserver/en-US/9dc9cce9-9b46-41ae-9e2b-6378ee9451a6/prevent-delete-own-files-and-folder-in-a-shared-folder?forum=winserversecurity

    If you meet the above issue, please ensure the “creator owner” group have delete permission. Then you will edit the files successfully.

    Hope this helps.

    Best regards,

    Justin Gu

    Thursday, November 21, 2013 11:01 AM
    Moderator
  • Hi there,

    I followed your instructions and the GOOD news is the kids can not move or delete folders, but the BAD new is the can not create new folders and then change the folder name, or create new files!!

    Please can you suggest a way to fix this??

    Thanks for any help?

    Regards

    FM

    Tuesday, November 26, 2013 7:52 PM
  • Hi,

    Please assign delete permission to the “Creator Owner”. You can refer to the following operations.

    1.  Right click the share folder and select Properties. Then the folder properties dialog box will display.
    2. On folder properties dialog box, select Security tab. Then please click Advanced button (At the bottom of the dialog box).
    3. On Advanced Security Settings dialog box, please click Add button. Then Permission Entry dialog box will display.
    4. On Permission Entry dialog box, please select and click “Select a principal”. The Select User, Computer, Service Account, or Group dialog box will diaplay. Please type Creator Owner and click Check Names button. Then click OK.
    5. You will see that come back to Permission Entry dialog box. Also, the Principal had change to CREATOR OWNER. Then please click Show advanced permissions.
    6. Please ensure that you have assigned Delete permission to the CREATOR OWNER.

    Please check if this setting will help you achieve your target.

    Hope this helps.

    Best regards,

    Justin Gu

    Wednesday, November 27, 2013 8:42 AM
    Moderator
  • Thanks again Justin for your help.

    I followed you guide word for word, but unfortunately, when a user tries to save a Windows Movie Maker file for example, it says file already exist and overwrites it with a blank file! If I save the file locally and then moves it to the network folder, all is good.

    Also still have the issue with users not be able to rename folders they create.

    If you can help further or double check your original guidance, I'd really appreciate it.

    Thank you.

    FM

    Tuesday, December 03, 2013 9:22 PM
  • Please, can someone help me with the above?

    Much appreciated.

    FM

    Saturday, December 07, 2013 11:28 AM