none
Exchange 2013. Erreur de topology

    General discussion

  • Bonjour

    Tout d'abord je précise que je n'ai qu'un tout petit niveau en administration de serveur. J'ai posé cette question sur d'autres forums, mais je n'ai pas eu de réponse. Celui-ci est ma dernière chance. ;-)
    La dernière semaine de 2012 (entre Noël et jour de l'an) j'ai installé un Windows Server 2012 Standard sur un serveur. C'est le seul serveur de l'entreprise. Il est donc contrôleur de domaine, serveur DNS, DHCP, d'impression. Mais bon, on n'est pas nombreux non plus.
    J'ai voulu installer un serveur Exchange 2013 (pour avoir des calendriers partagés dans Outlook). j'ai donc suivi les quelques tutoriels trouvés sur la toile. Tout s'est à peu près déroulé comme sur les tutos.
    C'est lorsque j'ai voulu administrer le serveur Exchange que cela se gâte. :-(
    J'ai essayé de l'atteindre par http://terreaux et il m'a méchamment répondu :
    Une erreur d'application s'est produite sur le serveur. Les paramètres d'erreur personnalisés actuels pour cette application empêchent l'affichage à distance des détails de l'erreur de l'application (pour des raisons de sécurité). Cependant, ils peuvent être affichés par les navigateurs qui s'exécutent sur l'ordinateur serveur local.

    Pas encore énervé, je suis allé sur le serveur où j'ai tapé la même adresse, et là il m'a répondu :
    Erreur du serveur dans l'application '/ecp'.
    An error occurred during forest discovery (lugdunum.confluence).
    Description : Une exception non gérée s'est produite au moment de l'exécution de la requête Web actuelle. Contrôlez la trace de la pile pour plus d'informations sur l'erreur et son origine dans le code.
    Détails de l'exception: System.ServiceModel.FaultException`1[[Microsoft.Exchange.Data.Directory.TopologyDiscovery.TopologyServiceFault, Microsoft.Exchange.Data.Directory, Version=15.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35]]: An error occurred during forest discovery (lugdunum.confluence).


    Puis je suis allé voir mon gestionnaire de serveur et je me suis rendu compte que pour mon serveur local il y avait 11 services qui étaient arrêtés (ou en démarrage imminent). Tous ces services étaient liés à Exchange.

    Après avoir redémarré le serveur plusieurs fois, je me suis dit que j'avais peut-être loupé un truc lors de l'installation d'Exchange. Il fallait donc le désinstaller. Ceci n'a pas été possible car il y avait des boîtes existantes. En cherchant sur le Net, j'ai vu qu'il fallait d'abord supprimer ces boîtes via Powershell avant de désinstaller Exchange.
    J'ai donc lancé Exchange Management Shell, mais là aussi, il y avait un message d'erreur :
    New-PSSession : [terreaux.lugdunum.confluence] La connexion au serveur distant terreaux.lugdunum.confluence a échoué avec le message d'erreur suivant : The process failed to read the Exchange topology in the allotted time.

    Ce qui fait que je ne peux pas non plus désinstaller Exchange :-((

    Le problème semble être la topologie, mais je ne vois pas ce que cela peut être, ni quelle sera la solution.

    Merci à ceux qui ont lu jusqu'au bout. Encore plus merci à ceux qui m'aideront ;-)

    Bonne année à tous.
    Pierre
    Wednesday, January 09, 2013 3:31 PM

All replies

  • Bonsoir

    Le problème pourrait provenir d'un échec de "communication" ou de "droits" entre votre Exchange 2013 et votre DC/GC.

    Quand vous dites que tout s'est déroulé à peu prés comme sur les tutos, pouvez vous me donner les différentes étapes ?

    Dans votre serveur Exchange 2013 vous avez bien un event id 2080 MSExchangeADAccess ?

    Il arrive qu'il faille relancer une préparation de l'AD pour réparer cela pour réaffecter les droits.

    Prepare Active Directory and Domains

    Merci


    Hakim Taoussi

    Wednesday, January 09, 2013 7:58 PM
  • Bonsoir,

    le problème le plus classique (et pas seulement pour Exchange 2013) provient de la configuration des serveurs DNS.

    L'unique IP  de serveur DNS qui doit apparaître sur le serveur/contrôleur de domaine/Exchange et sur les stations doit être l'adresse IP du contrôleur de domaine. AUCUNE autre adresse IP de DNS ( du FAI ou autre) ne doit apparaître dans la configuration IP d'aucune machine.

    Une fois que l'AD et la topologie Exchange accéderont aux données de l'annuaire, cela facilitera le fonctionnement du serveur Exchange.

    A+


    Thierry DEMAN. Exchange MVP. MCSA Windows Server 2012 (73 MCPs). https://mvp.support.microsoft.com/profile=CE2B565B-B13D-4C24-B04D-F0D5766D14A1 http://www.faqexchange.info

    Wednesday, January 09, 2013 9:21 PM
    Moderator
  • Bonsoir

    Merci de m'avoir répondu et donné de l'espoir. J'ai donc vérifié en faisant un ipconfig/all sur mon serveur.

    Le seul serveur DNS qui est configuré, c'est bien lui-même. Il en est ainsi pour les postes de travail qui obtiennent leur adresse par serveur DHCP. J'ai bien vérifié les options d'étendues. Tout ce qui fait référence à un serveur (de temps, de noms, DNS, NTP, WINS, NBDD NetBIOS) à comme u nique adresse IP celle du serveur. Seul le routeur est différent (mais cela me semble normal).

    Tout me semble donc normal par rapport à vos prérequis.

    Il me semble bien qu'avant d'avoir installé Exchange, je n'avais pas d'erreurs.

    En espérant pouvoir avancer avec le forum

    Pierre


    Thursday, January 10, 2013 5:26 PM
  • Bonsoir

    Le principal tutos que j'ai suivi (il n'y en a pas beaucoup en ce moment sur l'installation d'Exchange 2013 en français, à peu prés compréhensible pour un néophyte) est celui-ci :

    florent-appointaire.fr/installation-exchange-2013-windows-server-2012

    Ce qui n'a pas voulu s'installer c'est le SP1 pour MS Office filter pack 2010 (j'ai pensé que le filter pack que j'avais téléchargé était à jour).

    A la réflexion, là où j'ai copié sans réfléchir c'est sur la ligne de préparation du domaine car j'ai mis :

    .\setup.exe /PrepareAD /OrganizationName:florent-appointaire /IAcceptExchangeServerLicenseTerms

    car j'ai laissé florent-appointaire (et bien entendu mon domaine ne s'appelle pas ainsi). J'avais essayé de relancer cette ligne de commande en modifiant mais cela n'a pas fonctionné. Je pensai pouvoir le changer par la suite.

    Je ne comprend pas quand vous dites "vous avez bien un event id 2080 MSExchangeADAccess ". Comment fait-on pour savoir si j'ai bien cet event id ?

    Pour relancer la préparation de l'AD, est-ce qu'il faut recopier la phrase ci-dessus (en changeant mon OrganizationName) ?

    Merci à vous

    Pierre

    Thursday, January 10, 2013 5:40 PM
  • Bonsoir

    Ce que vous avez fait en copiant la ligne de commande c'est que vous avez donné ce nom à votre organisation Exchange. Ce nom n'est pas modifiable et il n'est pas visible pour vos utilisateurs.

    Vous devez dans le journal d'evenements de votre serveur et faire un filtre de recherche dans le journal "Applications" et vous pouvez saisir l'ID 2080

    Pour relancer une préparation AD comme indiqué il n'est pas necessaire de saisir /OrganizationName car ce "switch" n'est utilisé que lorsque vous préparez un domaine Active Directory dépourvu d'organisation Exchange.

    Setup /PrepareAD /IAcceptExchangeServerLicenseTerms

    Merci


    Hakim Taoussi

    Friday, January 11, 2013 5:35 PM