none
SharePoint 2010: Social and Tagging

    Question

  • Hi,

    We are only now starting to use the tagging functionality, but I am having some problems.  I can tag items just fine (for example tagging external web pages with the button in the browser toolbar), and the tags show up fine in my own profile.  But when I view the tag cloud web part from another site, and click on a tag, no items are displayed for that tag in the tag profile.  (the message simply is: "There are no available items tagged with '<tag>'.

    I also cannot use the Search - I have two issues here.  The first is that when I click the link on the Tag Profile page to search for items with that tag, I am redirected to a URL for the search center that includes the library pages (eg, http://mysite/search/pages/Results.aspx?k=SocialTagId%3A"9066a30c-734b-47b5-bb59-d6f51c3dd05f"), but my search URL for the Mysite site collection is at  http://mysite/search/Results.aspx?k=SocialTagId%3A"9066a30c-734b-47b5-bb59-d6f51c3dd05f" (without the Pages, in other words).  Is there perhaps a setting where I can correct the URL that is being used for the My Site searching of tags?

    The second problem with the search is that it when I manually fix the URL to remove "Pages", the search does not actually find any items - it returns: "We did not find any results for SocialTagId:"9066a30c-734b-47b5-bb59-d6f51c3dd05f"."

    My search instances seems to be working fine, it has other content and is being indexed daily.

    The server has been rebooted a couple of times, but no difference.

    Does anyone perhaps have any ideas or advice?

     

    thanks,

    Nico


    http://blogs.umtsa.co.za/nicoo
    Thursday, January 05, 2012 3:07 PM

Answers

  • Hi,

    1. Please add your service account into Term Store Administrators from central administration > manage service applications > Managed Metadata Service to giva a try.

    2. Please go to check your search service application to make sure there is keywords managed property. and the scopes does not exclude these content.

    3. If you use SSL for your sites, please add sps3s://domain into your content sources.

    4. make sure does not check "keywords" in site settings > searchable columns

    5. reboot your server and do a full crawl to check it again.

    Regards,

    Seven 

    • Marked as answer by Seven M Friday, January 13, 2012 7:21 AM
    Tuesday, January 10, 2012 8:01 AM

All replies

  • You can set the search path for MySites by going to Central Admin -> Mange Service Applications -> Click on your User Profile Service Application.

    From here under the MySite Heading the first option is Setup My Sites. Once you click on this the first section is where you can set the Search Center for My Sites. You can also configure the scopes for People and Documents.

    Friday, January 06, 2012 8:03 PM
  • Thanks Kyle, that sorted my first issue :)

    I still cannot seem to search for tagged items, though.  Do you know if I should be adding anything else to my Search content sources (the defaults apply, with all site collections on all web apps being indexed).


    http://blogs.umtsa.co.za/nicoo
    Saturday, January 07, 2012 6:00 AM
  • Hi,

    1. Please add your service account into Term Store Administrators from central administration > manage service applications > Managed Metadata Service to giva a try.

    2. Please go to check your search service application to make sure there is keywords managed property. and the scopes does not exclude these content.

    3. If you use SSL for your sites, please add sps3s://domain into your content sources.

    4. make sure does not check "keywords" in site settings > searchable columns

    5. reboot your server and do a full crawl to check it again.

    Regards,

    Seven 

    • Marked as answer by Seven M Friday, January 13, 2012 7:21 AM
    Tuesday, January 10, 2012 8:01 AM
  • Thanks Will check this.


    http://blogs.umtsa.co.za/nicoo

    Friday, January 13, 2012 7:59 AM