none
Logon Attempt Failed

    Question

  • Hi all,

    I am taking the Windows 8 MCSA and as such would like to setup Winodws 8.1 in a lab environment for study/practice.  I have Windows Server 2012 R2 Standard installed on a Server and would like to run Windows 8.1 Enterprise in Hyper-V for the purpose of quick rebuilding. I have installed both OSs successfully however if I attempt to RDP into the VM from my desktop running 8.1 Pro I get the message "Logon attempt failed". Google tells me I need to allow RDP through Windows Firewall but this has not worked and I have even tried disabling Windows Firewall both on the Windows 8.1 VM and Win Server 2012. Curiously, I can RDP into the VM from Windows Server 2012.

    Any advice would be appreciated.

    Monday, May 26, 2014 11:25 AM

All replies

  • Hi

    • First enable RDP access
    • Turnoff firewall just to ensure no block
    • Ensure you Hyper V switch is able to communicate with the host or outside network Ie same network
    • Ping the PC and see for the reply
    • if all the above works, you should be okay to RDP
    Monday, May 26, 2014 12:00 PM
  • Hi Syn3rgi3,

    In addition, please check the security event log on the Windows 8.1 VM and find if there is any error or failed information.

    Please also check the local security policy: "Network security: LAN Manager authentication level" on the Windows 8.1 VM and Windows 8.1 desktop, and make sure these two OS can use the same authentication method, for more detailed information, please refer to this article:

    Case of the Logon Attempt Failed RDP Connection

    I hope this helps.

    Tuesday, May 27, 2014 3:26 AM
  • Hi,

    This has not resolved the issue.

    Monday, June 02, 2014 10:50 AM
  • Hi,

    I know this might be a bit on the obvious side, and apologies if it is, but have enabled "Remote Access" on the Windows 8/8.1 VM?  You do this through the System Properties/Remote of the client VM. 

    It's also a good idea to domain join the client VM, in the virtualized environment, and to have your client management machine, the machine you are using to access the virtualized environment, joined to the same virtualized domain environment.  Then ensure that you, as an administrator, are a member of the Remote Management Group as well as the Remote Users' Group, I know there is a bit of replication here but bear with me here; membership of the Domain Administrators Group is normally a default, but check to make sure. Speaking of which, pop your user account into the Administrators Group as well. If you use two separate accounts one in the VM environment and one for your external client management machine, then put both accounts into the groups.

    Now you can put yourself as a "Selected" User on the client Windows 8/8.1 VM. 

    If this doesn't work or only works partially, then there might be a need to look at the Advanced Firewall Rules, but that's something that can be tried later.

    Cheers

    Andrew

    Monday, June 02, 2014 1:30 PM
  • I forgot to mention, make sure network discovery is enabled on the client Windows 8/8.1 machine!
    Monday, June 02, 2014 3:07 PM
  • The user account I was logging onto was named "User", since it is only a test VM. However if I use *ANY* other account name I can logon - is this a known limitation?!
    Friday, June 06, 2014 12:24 PM