none
Winmail.dat attachments from Exchange 2013 on premi and Hosted Office 365 set up.

    Question

  • Hello TechNet,

    I have an on going situation with winmail.dat attachments. I currently have a ticket open with Microsoft, but I want to see if anyone has personal experience with this. Here is the rundown.

    We have migrated from an Exchange 2007 server to Exchange 2013 for the migration to Office 365. We also have a hosted Office 365 server with half of our mailboxes in the cloud and half of them on the Exchange 2013 on premise server.

    The current settings for TNEFEnabled:

    On Premise: False

    Hosted: False

     Whenever a internal email with a calendar invite(exchange calendar, go to meeting) goes out to any external domain the recipients receive winmail.dat.

    When settings for TNEFEnabled On Premise and Hosted are set to true both calendar invites and PDF, Excel attachments etc the recipients receive winmail.dat.

    When speaking with Microsoft about this issue. The representative was watching me through a LogMeIn session as I set both TNEFEnabled false on both on Premise and Hosted.

    This is really frustrating as many employees depend on this to be fully functional, and to be honest am tired of dealing with this.

    I need help.

    -Ben

    Tuesday, October 29, 2013 1:26 AM

Answers

  • Ben

    Have you tried:

    Turning off Rich Text sending for messages in Microsoft Outlook.

    1) Click on Tools

    2) Click Options, and then click the Mail Format tab.

    3) In the Send in this message format list, select Plain Text, and then click OK.

    This will set your default sending method to Plain Text, which will lose your special formatting options with fonts, colors, etc. However everyone, no matter what Email program they are using, will now be able to receive your email with no problems.


    Fred Chamanara | Advanced Agile Technology LLC | Hire us for Consulting | please mark "Propose As Answer" if helpful, Thanks.

    Tuesday, October 29, 2013 2:15 AM

All replies

  • Ben

    Have you tried:

    Turning off Rich Text sending for messages in Microsoft Outlook.

    1) Click on Tools

    2) Click Options, and then click the Mail Format tab.

    3) In the Send in this message format list, select Plain Text, and then click OK.

    This will set your default sending method to Plain Text, which will lose your special formatting options with fonts, colors, etc. However everyone, no matter what Email program they are using, will now be able to receive your email with no problems.


    Fred Chamanara | Advanced Agile Technology LLC | Hire us for Consulting | please mark "Propose As Answer" if helpful, Thanks.

    Tuesday, October 29, 2013 2:15 AM
  • Fred,

    Thanks for the feedback, but winmail.dat is still being received.

    Tuesday, October 29, 2013 2:24 PM
  • The Mailbox that is still getting Winmail.dat is it On-Premises or in the Cloud?


    Fred Chamanara | Advanced Agile Technology LLC | Hire us for Consulting | please mark "Propose As Answer" if helpful, Thanks.

    Tuesday, October 29, 2013 2:57 PM
  • Fred,

    If sending from an on premise mailbox or cloud mailbox the end result is the same. If my old Exchange 2007 server is still online could this be causing confliction. No mailboxes reside on this server, but the server does show in Office 365 with the ability to edit information.

    -Ben

    Tuesday, October 29, 2013 3:18 PM
  • If you send Email from a "test mailbox" on the Exchange 2007 On-Premises, still getting the Winmail.dat? 


    Fred Chamanara | Advanced Agile Technology LLC | Hire us for Consulting | please mark "Propose As Answer" if helpful, Thanks.

    Tuesday, October 29, 2013 3:26 PM
  • I could try that. Not sure the connectors are set up correctly for the old On Premise exchange. Are current on premise is Exchange 2013.

    -Ben

    Tuesday, October 29, 2013 3:29 PM
  • Tested from an Exchange 2007 mailbox and still the same problem.
    Tuesday, October 29, 2013 6:11 PM
  • Well you have a ticket with MS now.

    When you were Exchange 2007 On-Premises you did Not have this issue, after going Hybrid with Cloud you Have this issue, point this out and see if they have seen this issue with Hybrid.


    Fred Chamanara | Advanced Agile Technology LLC | Hire us for Consulting | please mark "Propose As Answer" if helpful, Thanks.

    Tuesday, October 29, 2013 6:21 PM
  • I have explained everything to them and I am just waiting for them to come up with something. Figured Id give technet a shot to see if anyone has encountered this personally. Thanks for your input though Fred.

    -Ben

    Tuesday, October 29, 2013 9:07 PM
  • does this help?

    http://support.microsoft.com/kb/278061/

    also have you checked setting on the receivers outlook?

    Does this happen to internal addresses?

    Does this happen to other / multiple domains/recipients?

    Tuesday, October 29, 2013 10:24 PM
  • I am having the same issue.

    Luckily I have only migrated my own mailbox to office365.

    Tried both true and false TNEFEnabled on both onpremise and office365 via powershell and confirmed that both have been applied.

    If I send the email as a plain text then the attachment works ok. If I send it as HTML then I get winmail.dat.

    The above KB doesnt really help me, sending plain text emails is like going back to the dark ages!

    I am sending from outlook to outlook (I send from my external email address, to my work email address and visa-versa)

    If someone with an onpremise mailbox sends me an email, the attachment works ok.

    If someone sends me an attachment via hotmail, the attachment works ok.

    It seems to only effect emails I send to myself through outlook, i am sending it through a POP3 account to our onpremise exchange 2010 which forwards the email to office365


    • Edited by growls Monday, February 17, 2014 3:32 AM
    Sunday, February 16, 2014 8:57 PM