none
Problème avec CopyProfile

    Question

  • Bonjour,

     

    Je suis actuellement en train de créer un système de restauration avec un fichier Autounattend.xml. Tout se fait automatiquement j'usqu'au mode Audit de la machine où un compte Administrator me permet d'installer des logiciels, de personnaliser les gadgets et la configuration du systèmes ainsi que les paramêtres du bureau. Ensuite, lorsque j'ai terminé j'utilise la boîte de dialogue Sysprep afin de démarrer en mode OOBE avec l'option Generaliser coché. L'odinateur redémarre et se configure afin de démarrer l'écran d'acueil du nouvel utilisateur qui doit mettre un nom pour se logger, choisir son papier peint ect... Le problème est que certains icones du bureau disparaissent et la configuration des gadgets sont réinitialiser tout comme les icones de l'odinateur et du réseau. Pourtant j'utilise CopyProfile True mais rien y fait ! Peut-être il y a une erreur dans mon fichier de configuration ? Voici mon code :

     

    Code Snippet
    <?xml version="1.0" encoding="utf-8"?>
    <unattend xmlns="urn:schemas-microsoft-com:unattend">
        <servicing>
            <package action="configure">
                <assemblyIdentity name="Microsoft-Windows-Foundation-Package" version="6.0.6000.16386" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="" />
                <selection name="InboxGames" state="true"/>
            </package>
        </servicing>
        <settings pass="specialize">
            <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/Statehttp://schemas.microsoft.com/WMIConfig/2002/State">http://schemas.microsoft.com/WMIConfig/2002/State</A< A>>" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
               '>http://www.w3.org/2001/XMLSchema-instance">http://www.w3.org/2001/XMLSchema-instance">
               ; <CopyProfile>true</CopyProfile>
            </component>
        </settings>
        <settings pass="oobeSystem">
            <component name="Microsoft-Windows-Deployment" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/Statehttp://schemas.microsoft.com/WMIConfig/2002/State">http://schemas.microsoft.com/WMIConfig/2002/State</A< A>>" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
               '>http://www.w3.org/2001/XMLSchema-instance">http://www.w3.org/2001/XMLSchema-instance">
               ; <Reseal>
                    <ForceShutdownNow>false</ForceShutdownNow>
                    <Mode>Audit</Mode>
                </Reseal>
            </component>
        </settings>
        <settings pass="auditSystem">
            <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/Statehttp://schemas.microsoft.com/WMIConfig/2002/State">http://schemas.microsoft.com/WMIConfig/2002/State</A< A>>" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
               '>http://www.w3.org/2001/XMLSchema-instance">http://www.w3.org/2001/XMLSchema-instance">
               ; <Display>
                    <ColorDepth>32</ColorDepth>
                    <DPI>96</DPI>
                    <HorizontalResolution>1024</HorizontalResolution>
                    <RefreshRate>85</RefreshRate>
                    <VerticalResolution>768</VerticalResolution>
                </Display>
            </component>
        </settings>
        <settings pass="windowsPE">
            <component name="Microsoft-Windows-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/Statehttp://schemas.microsoft.com/WMIConfig/2002/State">http://schemas.microsoft.com/WMIConfig/2002/State</A< A>>" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
               '>http://www.w3.org/2001/XMLSchema-instance">http://www.w3.org/2001/XMLSchema-instance">
               ; <Diagnostics>
                    <OptIn>false</OptIn>
                </Diagnostics>
                <DiskConfiguration>
                    <WillShowUI>Always</WillShowUI>
                </DiskConfiguration>
                <DynamicUpdate>
                    <Enable>false</Enable>
                </DynamicUpdate>
                <UserData>
                    <ProductKey>
                        <WillShowUI>Never</WillShowUI>
                        <Key>XXXXXXXXXXXXXXXXXXXXXXXXXx</Key>
                    </ProductKey>
                    <AcceptEula>true</AcceptEula>
                </UserData>
                <ComplianceCheck>
                    <DisplayReport>Never</DisplayReport>
                </ComplianceCheck>
                <LogPath>%SystemRoot%\temp</LogPath>
                <UseConfigurationSet>true</UseConfigurationSet>
            </component>
            <component name="Microsoft-Windows-International-Core-WinPE" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/Statehttp://schemas.microsoft.com/WMIConfig/2002/State">http://schemas.microsoft.com/WMIConfig/2002/State</A< A>>" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
               '>http://www.w3.org/2001/XMLSchema-instance">http://www.w3.org/2001/XMLSchema-instance">
               ; <SetupUILanguage>
                    <UILanguage>fr-FR</UILanguage>
                    <WillShowUI>Never</WillShowUI>
                </SetupUILanguage>
                <InputLocale>fr-FR</InputLocale>
                <SystemLocale>fr-FR</SystemLocale>
                <UILanguage>fr-FR</UILanguage>
                <UILanguageFallback>fr-FR</UILanguageFallback>
                <UserLocale>fr-FR</UserLocale>
            </component>
        </settings>
    </unattend>

     

     

    J'espère recevoir de l'aide ! Merci !

    • Moved by SachinW Wednesday, February 03, 2010 10:03 PM Forum Consolidation (Origine :Windows Vista – Déploiement)
    Friday, July 20, 2007 4:08 PM

Answers

  • C'est bon j'ai trouvé ! J'ai utilisé Sysprep avec un fichier de réponse et ça fonctionne (sysprep /generalize /oobe /shutdown /unattendTongue Tiedysprep.xml). Voici le code si ça peut aider :

     

    Code Snippet
    <unattend xmlns="urn:schemas-microsoft-com:unattend" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State">
     '>http://schemas.microsoft.com/WMIConfig/2002/State">http://schemas.microsoft.com/WMIConfig/2002/State">
     ; <settings pass="specialize">
       <component name="Microsoft-Windows-Shell-Setup" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" processorArchitecture="x86">
          <CopyProfile>true</CopyProfile>
       </component>
      </settings>
    </unattend>

     

    A bientôt !

    Friday, July 20, 2007 10:00 PM