none
SBS 2011 RWA not accepting computer connections, related to memory use?

    Question

  • Hi,

    Have a rather 'simple' SBS install, basically used for some 20-odd mailboxes for 9 users and enabling remote access to mail and desktops for those users through RWA.

    This has worked just fine for almost a year now and apart from the regular updates of the published fixes nothing really major has been changed in this boxes configuration.

    We are not running web services or SharePoint, net even for internal only use.

    Until some time ago (can't really pinpoint when this has started to happen) remote computer connections through RWA worked like a charm. They don't anymore.

    I have noticed that the store.exe and sqlserver.exe processes are gobbling up almost half of the 16GB memory. Some 10-odd IIS worker processes , take care of most of the remainder of those 16GB. In total this comes up to the tune of about 96% of physical memory on the box being in use.

    When that stage is reached trying to RDP to one of the computers won't work anymore. My guess is because it cannot get enough memory to do it's little trick, because when I reboot the machine and those processes sort of 'start afresh', these RDP connections throug RWA are set up just fine.

    However, over the course of the next couple of days after reboot, the situation gets to the point again where I no longer can get RDP sessions established.

    Quite frankly I'm at a loss as to how to remedy this behaviour, or even if I CAN remedy this, and if so what to look for / check or possibly change.

    I would appreciate any and all insight that may help.

    Thanks and best regards,

    Dyslexia

    Wednesday, July 17, 2013 9:33 PM

Answers

  • Hi:

    Store and SQL processes are programed to work as you see them.  It is  possible to hold down the amount of RAM they use, but unused RAM is really wasted RAM, although I agree that a buffer must be maintained.

    Can you open the event viewer and check if you have any red errors?  If you have not already, please run the SBS BPA and fix anything it finds.  Open Task Manager, processes tab, click View on the menu, check all the memory choices.  Once they are shown, click each column and notice any extraordinarily high numbers.  You may have to click each column twice to get the biggest numbers to rise to the top.

    For events, post up the event id and source.

    Another concept is to use msconfig (start - run - msconfig) and uncheck all the non MS services (essentially "safe mode" and restart. 

    And don't over look the possibility of malware.  Scan the entire system with a reliable malware scanner.

    Please keep us advised.


    Larry Struckmeyer[SBS-MVP] If your question is answered, please mark the response as the answer so that others can benefit.

    Thursday, July 18, 2013 12:58 AM
  • Open ADSIEDIT:
    Browse to:

    Configuration\Services\Microsoft Exchange\<First Organization>\Administrative Groups\<Exchange Administrative Group>\Servers\<Server Name>\Information Store

    Right click on Information Store and select properties.

    set msExchESEparamCacheSizeMax and also msExchESEparamCacheSizeMin.

    nx1024x1024/32  (where n is the value of RAM in GB that you would like to assign store.exe)

    If you set only msExchESEparamCacheSizeMax, Exchange 2010 will simply ignore it.

    For SQL instances, first find out which instance is taking up maximum memory.

    Follow the steps below.

    http://beyondrelational.com/modules/24/syndicated/519/Posts/18111/sql-server-limit-memory-usage-of-sql-server.aspx


    Regards, Lohorong

    Thursday, July 18, 2013 10:08 AM

All replies

  • Hi:

    Store and SQL processes are programed to work as you see them.  It is  possible to hold down the amount of RAM they use, but unused RAM is really wasted RAM, although I agree that a buffer must be maintained.

    Can you open the event viewer and check if you have any red errors?  If you have not already, please run the SBS BPA and fix anything it finds.  Open Task Manager, processes tab, click View on the menu, check all the memory choices.  Once they are shown, click each column and notice any extraordinarily high numbers.  You may have to click each column twice to get the biggest numbers to rise to the top.

    For events, post up the event id and source.

    Another concept is to use msconfig (start - run - msconfig) and uncheck all the non MS services (essentially "safe mode" and restart. 

    And don't over look the possibility of malware.  Scan the entire system with a reliable malware scanner.

    Please keep us advised.


    Larry Struckmeyer[SBS-MVP] If your question is answered, please mark the response as the answer so that others can benefit.

    Thursday, July 18, 2013 12:58 AM
  • Open ADSIEDIT:
    Browse to:

    Configuration\Services\Microsoft Exchange\<First Organization>\Administrative Groups\<Exchange Administrative Group>\Servers\<Server Name>\Information Store

    Right click on Information Store and select properties.

    set msExchESEparamCacheSizeMax and also msExchESEparamCacheSizeMin.

    nx1024x1024/32  (where n is the value of RAM in GB that you would like to assign store.exe)

    If you set only msExchESEparamCacheSizeMax, Exchange 2010 will simply ignore it.

    For SQL instances, first find out which instance is taking up maximum memory.

    Follow the steps below.

    http://beyondrelational.com/modules/24/syndicated/519/Posts/18111/sql-server-limit-memory-usage-of-sql-server.aspx


    Regards, Lohorong

    Thursday, July 18, 2013 10:08 AM